Jump to content
EwinRacing Flash Series Gaming Chairs
Edrc

Please, some help for installing GTX 980M in AW 17 R1 (June 2014 60Herts)

Recommended Posts

Hello,

 

I am new on this forum, so I am sorry if posting at the wrong place. It's been 2 weeks that I am searching how to make my GTX 980M 8GB working Inside my Alienware 17 R1 (June 2014, i7 4710MQ, 60 Herts Display, OPTIMUS and the GTX 880M Inside died.)

After "quickly" looking some forums, I saw that a 980M would easily fit Inside … but maybe I was wrong.

 

Hardware wasn't a problem. I've also could install drivers by modding the nvdmi or nvcvi. inf files. The card was recognied BUT :

the clock speed is locked a 135 or 405 Mherts and fan is not runing when booted up.

I tried to flash vBios with nvflash and some ROM I found on vBios collection … but no way to get this working properly.

 

So, i'm coming here. I've seen many people talking about Prema or svl7 or other big boss in the place … but ? how ? where ? when ?

 

Inside the peripherial manager I have this in remote acces path : PCI\VEN_10DE&DEV_1617&SUBSYS_05AA1028&REV_A1\4&D590A51&0&0008

So I assume my GTX 980M card ID is 1617 and vendor and PC Model are 05AA 1028.

But near the "Standard Microsoft Video Card" there is a yellow exclamation point and Inside details it says "this peripherial doesn't work properly" when no Nvidia drivers installed.

I could find some vBios with 1617 (Asus) but black screen at boot up. :( Since laptop model where not the same .. probably.

And I wasn't able to find 1617 with the existing 05AA 1028 … as the GTX 980M was not an option for my model. (AW 17 R1 2014 ,60Herts)

I tried 353.60, 382.33 and 419.35 drivers. The latest one seems easier to install but longer.

 

BIOS is A16 from Dell. And I am using Windows 10. Got a Dell 330W brick. 

 

I saw a guy with the exact model as me, he gets a modded vBios especially for his configuration, then everything worked easily … but can't find the topic again :(

 

I guess depending on the card info and the laptop model … a dedicated vBios is required … 

 

So, If anyone here got some informations or any kind of help for me, it would be very nice.

 

Thanks for reading and help. :) 

 

PS: there are a lot of files, pictures and links that I can't see on this forum .. even after registration …. 

 

Share this post


Link to post
Share on other sites
10 hours ago, Edrc said:

Hello,

 

I am new on this forum, so I am sorry if posting at the wrong place. It's been 2 weeks that I am searching how to make my GTX 980M 8GB working Inside my Alienware 17 R1 (June 2014, i7 4710MQ, 60 Herts Display, OPTIMUS and the GTX 880M Inside died.)

After "quickly" looking some forums, I saw that a 980M would easily fit Inside … but maybe I was wrong.

 

Hardware wasn't a problem. I've also could install drivers by modding the nvdmi or nvcvi. inf files. The card was recognied BUT :

the clock speed is locked a 135 or 405 Mherts and fan is not runing when booted up.

I tried to flash vBios with nvflash and some ROM I found on vBios collection … but no way to get this working properly.

 

So, i'm coming here. I've seen many people talking about Prema or svl7 or other big boss in the place … but ? how ? where ? when ?

 

Inside the peripherial manager I have this in remote acces path : PCI\VEN_10DE&DEV_1617&SUBSYS_05AA1028&REV_A1\4&D590A51&0&0008

So I assume my GTX 980M card ID is 1617 and vendor and PC Model are 05AA 1028.

But near the "Standard Microsoft Video Card" there is a yellow exclamation point and Inside details it says "this peripherial doesn't work properly" when no Nvidia drivers installed.

I could find some vBios with 1617 (Asus) but black screen at boot up. :( Since laptop model where not the same .. probably.

And I wasn't able to find 1617 with the existing 05AA 1028 … as the GTX 980M was not an option for my model. (AW 17 R1 2014 ,60Herts)

I tried 353.60, 382.33 and 419.35 drivers. The latest one seems easier to install but longer.

 

BIOS is A16 from Dell. And I am using Windows 10. Got a Dell 330W brick. 

 

I saw a guy with the exact model as me, he gets a modded vBios especially for his configuration, then everything worked easily … but can't find the topic again :(

 

I guess depending on the card info and the laptop model … a dedicated vBios is required … 

 

So, If anyone here got some informations or any kind of help for me, it would be very nice.

 

Thanks for reading and help. :) 

 

PS: there are a lot of files, pictures and links that I can't see on this forum .. even after registration …. 

 

 

Hi!

Send me your file bios backup from your laptop, I'll take a look.

For creating backup of bios use attached program. Extract attached archive directly on the Desktop and run the program as administrator (right click mouse). Program will create archive "results" directly on the Desktop. Send me this archive "results" via PM or upload it to any fileserver and send me the link.

https://www.sendspace.com/file/mxoavw

or

http://www120.zippyshare.com/v/NC9WuxRI/file.html

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Dr_Cachetes
      Hello everyone, it is 2020 and i've been looking literally EVERYWHERE for a modded vBios for an Asus G751jy (980m 4gb) to unlock voltage control above 25mV, can someone help me?
      I've seen people have been linking the mod so here's mine, latest 213
      GM204.rom
    • By BAKED
      BAKED BIOS FOR TM, KM, DM, P6, P4 SERIES WITH MOST MENUS AND OPTIONS UNLOCKED PLUS OTHER MODIFICATIONS
       
      NEW:
      I HAVEN'T BEEN ACTIVE IN A WHILE BUT I MIGHT FIND SOME TIME SOON TO WORK ON AND RELEASE NEW MODS.
      I STARTED WORKING ON V3.0 A WHILE BACK WHICH WILL INCLUDE UPDATED UEFI DRIVERS, MICROCODE, BIOS SCREEN SHOT SUPPORT AMISCE SUPPORT(For some models) PLUS MORE. 
      ALL TM, KM AND DM SERIES ARE V2.0 AND NOW HAVE WINDOWS FLASHER INSTEAD, JUST EXTRACT AND RUN FLASH.BAT
      WARNING! BIOS FLASHING IS RISKY SO MAKE SURE YOU KNOW WHAT YOU'RE DOING BEFORE PROCEEDING. 
      FLASHING THE WRONG BIOS OR INTERRUPTING THE FLASHING PROCESS WILL BRICK YOUR SYSTEM! 
      USE AT YOUR OWN RISK!
      TM, KM AND DM SERIES
      P6 AND P4 SERIES
      INSTRUCTIONS
       
    • By BasedKnight
      I recently purchased a replacement 980M (Clevo model) for my P770DM-G after the original died, however, after installing the card the laptop doesn't boot. I only get a black screen, and after a couple minutes the fans spin to max before shutting down, which is the same thing that happens when I try to boot it without any gpu at all. I've tried the reset procedure, unplugging, removing battery, and removing CMOS, to no avail. It does beep before shutting down (I counted 22 times exactly). Anyone have any insight as to what the problem is?
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.