Jump to content
Sign in to follow this  

M18x R2 980m assistance required (8 beeps).

Recommended Posts

Help me Tech Inferno, you're my only hope.


Ok so firstly, apologies for yet another 8 beeps thread. I must have read 100 of them over the last week. I feel like I'm missing something obvious, but I'm totally burned out after days of working on this so would appreciate some outside perspective.


I live in the UK, so I've avoided buying a 980m to upgrade my 660 for years to due the price/import tax etc. I finally found a good priced 980m on Ebay a few weeks ago so I thought why not give my trusty 18x r2 a few extra years of life.


I ordered the 100w heatsink, x bracket etc from Eurocom at the same time and everything arrived on the same day.


Here's what I've done so far in the last 7 days:


-Flashed unlocked A11 BIOS (I rolled back to Dell A11 first)


-Removed  660m and installed 980m


-With BIOS in Legacy, Installed Windows 7 on a new SSD with BIOS set to IGFX


-Tried to switch to PEG but got 8 beeps so reset CMOS battery


-Switched to SG and booted to Windows. 980m detected as default hardware. Installed 980m Driver from Eurocom and restarted. Device manager shows 980m  working normally along with HD Graphics 4000. Tried PEG again but still got 8 beeps


-Reset battery, booted to Windows and disabled the 980m in Device Manager


-Flashed VBIOS from here  (I read that the dell VBIOS doesn't work well so tried Clevo one first, but I've since tried both and a few others)


-Re enabled 980m and restarted Laptop still in Legacy SG.


-Tried to test a game but they only want to use HD Graphics 4000. When I try to open NVIDIA Control Panel and change some settings I get a blue screen and have to restart.


-Tried PEG again, still 8 beeps



I've tried many combinations of drivers, VBIOS and BIOS settings over the last week but the result is mostly the same. I get 8 beeps in PEG. I thought perhaps the seller had sent me a G-sync version as I have read these don't play well with PEG, but I checked the hardware ID (PCI\VEN_10DE&DEV_13D7&SUBSYS_05501028&REV_A1) and what I've read seems to indicate this is the Non G-Sync card.


I got the 980m rather than the 1060 after reading the forums as I saw so many success stories I figured it would be the safer option.


I understand this laptop is basically dead to most of you now, but if any techsperts are around and could give me some other things to try I'd greatly appreciate it.



Thank you,












DDU image.png

Edited by Max2016
Adding some pictures

Share this post

Link to post
Share on other sites

Update: I've installed a new SSD with Windows 10. In SG, it has automatically found and installed all the drivers including the Nvidia one, and the 980m shows up with no errors. However, I still get 8 beeps when setting Graphics to PEG, and for some reason when I switch from Legacy to UEFI the Laptop just keeps blue screening before Windows can load. I have to try several times to get back into BIOS so I can change it back to Legacy.


Update 2: I've fixed the Uefi issue by cleaning the SSD and switching it to GPT. Reinstalled Windows and can boot in UEFI now. Even with Legacy ROM & Fast Boot Disabled and PEG always on, system will still not POST in PEG.

Share this post

Link to post
Share on other sites

Update 3 Well after a lot of messing around, re seating, re pasting and cleaning (I'm not convinced the card was new like stated when I bought it), I managed to boot in PEG. However I get blue horizontal lines across the screen.


I downloaded the latest Drivers via Windows 10 update and the lines vanish for a minute. They are then replaced with blue squares and the Laptop gets stuck in a boot cycle until I go into Safe Mode and remove them with DDU. The other thing that can happen is the card disables itself in Device Manager (Code 43).


I really am stumped with this one. I've got one more thing to try which is trying it in my friends Alienware 17 this week. Will report back with the results then.

blue lines.jpg

Blue Squares.jpg

Edited by Max2016

Share this post

Link to post
Share on other sites

Update 4 Well it's official. All these problems have been caused by a faulty card :logik:

Tried it in another machine and had the exact same problems. Tried flashing the official Dell/Alienware & Clevo VBIOS from Techpowerupwith no improvement. Card is now being returned.


I will update when a new card arrives (and hopefully works).

Edited by Max2016

Share this post

Link to post
Share on other sites
Posted (edited)

Hey. How did you go with this? I have a beautiful Nebula Red R2 sitting in a box in the garage and I'd love to do this same upgrade. It's got dual 675M's in it. 

I have another R2 with dual 780M's but they were pretty easy to install. The 980's seem a little daunting with all these steps but I want to get this girl rolling again.  


Also, where did you get the unlocked BIOS? From here?

Edited by MattyB

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Edrc
      I am new on this forum, so I am sorry if posting at the wrong place. It's been 2 weeks that I am searching how to make my GTX 980M 8GB working Inside my Alienware 17 R1 (June 2014, i7 4710MQ, 60 Herts Display, OPTIMUS and the GTX 880M Inside died.)
      After "quickly" looking some forums, I saw that a 980M would easily fit Inside … but maybe I was wrong.
      Hardware wasn't a problem. I've also could install drivers by modding the nvdmi or nvcvi. inf files. The card was recognied BUT :
      the clock speed is locked a 135 or 405 Mherts and fan is not runing when booted up.
      I tried to flash vBios with nvflash and some ROM I found on vBios collection … but no way to get this working properly.
      So, i'm coming here. I've seen many people talking about Prema or svl7 or other big boss in the place … but ? how ? where ? when ?
      Inside the peripherial manager I have this in remote acces path : PCI\VEN_10DE&DEV_1617&SUBSYS_05AA1028&REV_A1\4&D590A51&0&0008
      So I assume my GTX 980M card ID is 1617 and vendor and PC Model are 05AA 1028.
      But near the "Standard Microsoft Video Card" there is a yellow exclamation point and Inside details it says "this peripherial doesn't work properly" when no Nvidia drivers installed.
      I could find some vBios with 1617 (Asus) but black screen at boot up. Since laptop model where not the same .. probably.
      And I wasn't able to find 1617 with the existing 05AA 1028 … as the GTX 980M was not an option for my model. (AW 17 R1 2014 ,60Herts)
      I tried 353.60, 382.33 and 419.35 drivers. The latest one seems easier to install but longer.
      BIOS is A16 from Dell. And I am using Windows 10. Got a Dell 330W brick. 
      I saw a guy with the exact model as me, he gets a modded vBios especially for his configuration, then everything worked easily … but can't find the topic again
      I guess depending on the card info and the laptop model … a dedicated vBios is required … 
      So, If anyone here got some informations or any kind of help for me, it would be very nice.
      Thanks for reading and help.  
      PS: there are a lot of files, pictures and links that I can't see on this forum .. even after registration …. 
    • By Seolly
      I have several questions on upgrading my M18X R2.
      My rig's GPU is 680m and video ram is 2GB. It's a relic :p So I will change it to 980m.
      1. Is it working on windows 7? (If it works, legacy or UEFI mode?)
      2. Is 980m /w G-sync compatible with my rig? 
      3. Are there any compatibility issues with M18X R2 and Windows 10? 
      I tried to find useful information far as I can do, but my English ability sucks :S
      Guys, please help me!
    • By Mengqin
      Hi there,
          This is the quick step, if you don't want read more:
         1. download intel graphics driver
         2. Do the inf hack, looks into the Graphics directory, find the file igdlh64.inf, modify it. Add this line into windows 7 install section [IntelGfx.NTamd64.6.1]
                   %iKBLULTGT2%        = iSKLD_w7, PCI\VEN_8086&DEV_5917
         3. Find the file igdumdim32.dll, edit it by a hex editor, like winhex or ultraedit. Search this binary string in it:
                   83 F8 13 75 43 F7 42 04 00 00 00 02
             modify the following two bytes into
                   90 90
         4. Find the file igdumdim64.dll, edit it by a hex editor, like winhex or ultraedit. Search this binary string in it:
                   01 76 17 83 F9 13 75 44 F7 42 04 00 00 00 02
             modify the following two bytes into
                   90 90
         5. install the driver, restart.
         6. install/reinstall the discrete video card driver, not recommend a newest one. I use nvidia 397.64 driver on my MX150.
         7. enjoy it with full fucntion works.
      Start from here:
           As you know Intel didn't support graphics drivers for 7th and 8th CPU on windows 7, I do lots of research on web found some inf hack to resolve it like this:
          This way looks  work, but not perfect, I found when I playback video, player always crash on my UHD 620 (Embedded in I7 8550U) , whatever I used.
         And someone said replace some dll file will let playback work normal, but 3D function couldn't work, like this guy:
          I try all methods in the post found the same issue, so I try to dig into this problem, and finally I hack the driver binary file(DLL file) successfully.
          I must say this is not easy, you need some hacking background to understand how it work.
          First things, choose a right driver version. I do a lot testing work to test different version.I try to merge some of them but all of them couldn't work stable enough. Finally I did some research the about the  display drivers difference between winows 7 and windows 10.
          Basically, the display drivers support windows 7 must follow WDDM  1.1, but on windows 10 it support WDDM 2.0+. This means you must choose a version which support WDDM 1.1 and it support 6th or 7th CPU at the same time. Another words, your driver version must support both windows 7, and then  can support graphics like HD 620 on windows 10. 
          Drivers can match this demands isn't too much, the newest you can found officially is version (
          This version is OK, but I didn't use it, because I found drivers in same series 21.20.16.xxx, which is 4839 is listing on the windows update catalog directory by Microsoft. This means it should be more stable, you can download it from here:
          The windows catalog version is here:
          Then, the inf hack work, this is most easy part. You can learn how to do it on youtube from my first link. Here's some notice, the UHD 620's device ID is PCI\VEN_8086&DEV_5917, add the line in windows 7 section which should be like the following part. Here I use a new marco iKBLULTGT2R , and this can let you name your device, but not use HD 620's name,
      ;    Windows 7 Install - DT Only
      ; SKL HW
      %iSKLULTGT1%     = iSKLD_w7, PCI\VEN_8086&DEV_1906
      %iSKLULTGT2%     = iSKLD_w7, PCI\VEN_8086&DEV_1916

      %iSKLWSGT4%    = iSKLD_w7, PCI\VEN_8086&DEV_193D
      %iKBLULTGT2R%        = iSKLD_w7, PCI\VEN_8086&DEV_5917
            And add some lack parts for UHD 620, this is not really important thing, if you don't do it's OK. Add these lines follow the 5916 section:
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5916, DeviceID, %REG_DWORD%, 0x5916
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5916, VendorID, %REG_DWORD%, 0x8086
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5916, APIVersion, %REG_DWORD%, 0x108
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5916, Merit,%REG_DWORD%, 0x08000015
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5916, Path, %REG_SZ%, "%16422%\Intel\Media SDK\libmfxhw32.dll"
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5917, DeviceID, %REG_DWORD%, 0x5917
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5917, VendorID, %REG_DWORD%, 0x8086
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5917, APIVersion, %REG_DWORD%, 0x108
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5917, Merit,%REG_DWORD%, 0x08000015
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5917, Path, %REG_SZ%, "%16422%\Intel\Media SDK\libmfxhw32.dll"
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5921, DeviceID, %REG_DWORD%, 0x5921
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5921, VendorID, %REG_DWORD%, 0x8086
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5921, APIVersion, %REG_DWORD%, 0x108
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5921, Merit,%REG_DWORD%, 0x08000015
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5921, Path, %REG_SZ%, "%16422%\Intel\Media SDK\libmfxhw32.dll"
          And here:
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5916, DeviceID, %REG_DWORD%, 0x5916
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5916, VendorID, %REG_DWORD%, 0x8086
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5916, APIVersion, %REG_DWORD%, 0x108
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5916, Merit,%REG_DWORD%, 0x08000015
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5916, Path, %REG_SZ%, "%16422%\Intel\Media SDK\libmfxhw64.dll"
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5917, DeviceID, %REG_DWORD%, 0x5917
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5917, VendorID, %REG_DWORD%, 0x8086
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5917, APIVersion, %REG_DWORD%, 0x108
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5917, Merit,%REG_DWORD%, 0x08000015
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5917, Path, %REG_SZ%, "%16422%\Intel\Media SDK\libmfxhw64.dll"
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5921, DeviceID, %REG_DWORD%, 0x5921
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5921, VendorID, %REG_DWORD%, 0x8086
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5921, APIVersion, %REG_DWORD%, 0x108
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5921, Merit,%REG_DWORD%, 0x08000015
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5921, Path, %REG_SZ%, "%16422%\Intel\Media SDK\libmfxhw64.dll"
           And don't forget add the new display name at the end of this file:
      ; KBL 
      iKBLULTGT1     =   "Intel(R) HD Graphics 610" 
      iKBLULTGT2     =   "Intel(R) HD Graphics 620" 
      iKBLULTGT2R     =   "Intel(R) UHD Graphics 620" 
      iKBLULTGT2F    =   "Intel(R) HD Graphics 620" 
      iKBLULTGT3E15  =   "Intel(R) Iris(TM) Plus Graphics 640" 
      iKBLULTGT3E28  =   "Intel(R) Iris(TM) Plus Graphics 650" 
      iKBLULXGT2     =   "Intel(R) HD Graphics 615" 
      iKBLDTGT1      =   "Intel(R) HD Graphics 610" 
          OK, now save the file and run setup to install the drivers, it should be work. After restart, you will found the Aero came back again. And run dxdiag to check if the 3D function can work, it should work. Here you even can play some 3D game now. But the player crash couldn't stop. And the video tab of intel configure panel will crash too.
         Most tutorial  on web will end here, but my hacking is just begin. Here I must claim someone wants try to merge file to let this work, I don't think this will work. Because the different WDDM support in diffferent system, if one driver only support in windows 10 it couldn't be run on the windows 7.
         I tried merge the windows 10 driver into windows 7, and resolved tons of DLL missed and function redirect, modify tons of improt table of DLL, The drivers can be loaded, but it won't work. Just like you install a defalut VGA driver, no 3D function will work correctly.
         I started from the player crash, it reported that it crash in igdumdim32.dll @0x59c4EA0C,  the igdumdim32.dll and igdumdim64.dll is the Intel's user space graphics drivers' core file, the Intel's graphics has a small kernel part called miniports, it only open the tunnel between userspace application and the hardware, the real working part is in the DLL, like 3D function, video acceleration  and Direct draw. Use a debuger like ollydbg to debug it I found it's a function do some  setting work:
      59C4E948    8B87 0C010000   mov     eax, dword ptr ds:[edi+10C]
      59C4E94E    53              push    ebx
      59C4E94F    57              push    edi
      59C4E950    FFD0            call    eax
      59C4E952    8B8F 00010000   mov     ecx, dword ptr ds:[edi+100]
      59C4E958    8BD8            mov     ebx, eax
      59C4E95A    8D45 DC         lea     eax, dword ptr ss:[ebp-24]
      59C4E95D    50              push    eax
      59C4E95E    57              push    edi
      59C4E95F    FFD1            call    ecx
      59C4E961    8B56 10         mov     edx, dword ptr ds:[esi+10]
      59C4E964    8B0A            mov     ecx, dword ptr ds:[edx]
      59C4E966    F7C1 00002000   test    ecx, 200000
      59C4E96C    74 0C           je      short 59C4E97A                   ; igdumdim.59C4E97A
      59C4E96E    C746 18 2404655>mov     dword ptr ds:[esi+18], 5E650424
      59C4E975    E9 84000000     jmp     59C4E9FE                         ; igdumdim.59C4E9FE
      59C4E97A    F7C1 00000004   test    ecx, 4000000
      59C4E980    74 09           je      short 59C4E98B                   ; igdumdim.59C4E98B
      59C4E982    C746 18 5C04655>mov     dword ptr ds:[esi+18], 5E65045C
      59C4E989    EB 73           jmp     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E98B    F7C1 00000020   test    ecx, 20000000
      59C4E991    74 09           je      short 59C4E99C                   ; igdumdim.59C4E99C
      59C4E993    C746 18 9404655>mov     dword ptr ds:[esi+18], 5E650494
      59C4E99A    EB 62           jmp     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E99C    85C9            test    ecx, ecx
      59C4E99E    79 09           jns     short 59C4E9A9                   ; igdumdim.59C4E9A9
      59C4E9A0    C746 18 CC04655>mov     dword ptr ds:[esi+18], 5E6504CC
      59C4E9A7    EB 55           jmp     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E9A9    8B45 DC         mov     eax, dword ptr ss:[ebp-24]
      59C4E9AC    83F8 15         cmp     eax, 15
      59C4E9AF    74 1C           je      short 59C4E9CD                   ; igdumdim.59C4E9CD
      59C4E9B1    83F8 16         cmp     eax, 16
      59C4E9B4    74 17           je      short 59C4E9CD                   ; igdumdim.59C4E9CD
      59C4E9B6    83F8 13         cmp     eax, 13
      59C4E9B9    75 43           jnz     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E9BB    F742 04 0000000>test    dword ptr ds:[edx+4], 2000000
      59C4E9C2    75 A3           je     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E9C4    C746 18 AC05655>mov     dword ptr ds:[esi+18], 5E6505AC
      59C4E9CB    EB 31           jmp     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E9CD    8B42 04         mov     eax, dword ptr ds:[edx+4]
      59C4E9D0    A9 00004000     test    eax, 400000
      59C4E9D5    74 09           je      short 59C4E9E0                   ; igdumdim.59C4E9E0
      59C4E9D7    C746 18 3C05655>mov     dword ptr ds:[esi+18], 5E65053C
      59C4E9DE    EB 1E           jmp     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E9E0    A9 00008000     test    eax, 800000
      59C4E9E5    74 09           je      short 59C4E9F0                   ; igdumdim.59C4E9F0
      59C4E9E7    C746 18 0405655>mov     dword ptr ds:[esi+18], 5E650504
      59C4E9EE    EB 0E           jmp     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E9F0    A9 00000001     test    eax, 1000000
      59C4E9F5    74 07           je      short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E9F7    C746 18 7405655>mov     dword ptr ds:[esi+18], 5E650574
      59C4E9FE    85DB            test    ebx, ebx
      59C4EA00    74 0D           je      short 59C4EA0F                   ; igdumdim.59C4EA0F
      59C4EA02    8B4B 04         mov     ecx, dword ptr ds:[ebx+4]
      59C4EA05    85C9            test    ecx, ecx
      59C4EA07    74 06           je      short 59C4EA0F                   ; igdumdim.59C4EA0F
      59C4EA09    8B46 18         mov     eax, dword ptr ds:[esi+18]
      59C4EA0C    8948 0C         mov     dword ptr ds:[eax+C], ecx         <============ crash here
      59C4EA0F    C746 1C 1800000>mov     dword ptr ds:[esi+1C], 18
      59C4EA16    C746 20 4000000>mov     dword ptr ds:[esi+20], 40
      59C4EA1D    C746 24 4000000>mov     dword ptr ds:[esi+24], 40
      59C4EA24    C746 28 4000000>mov     dword ptr ds:[esi+28], 40
      59C4EA2B    C746 2C 0400000>mov     dword ptr ds:[esi+2C], 4
      59C4EA32    C746 30 1000000>mov     dword ptr ds:[esi+30], 10
      59C4EA39    C746 34 1000000>mov     dword ptr ds:[esi+34], 10
      59C4EA40    C746 38 0008000>mov     dword ptr ds:[esi+38], 800
      59C4EA47    C746 3C 8000000>mov     dword ptr ds:[esi+3C], 80
      59C4EA4E    C746 40 2000000>mov     dword ptr ds:[esi+40], 20
      59C4EA55    C746 44 0008000>mov     dword ptr ds:[esi+44], 800
      59C4EA5C    C746 48 2004000>mov     dword ptr ds:[esi+48], 420
      59C4EA63    C746 4C 4004000>mov     dword ptr ds:[esi+4C], 440
      59C4EA6A    C746 50 2000000>mov     dword ptr ds:[esi+50], 20
      59C4EA71    C746 54 1000000>mov     dword ptr ds:[esi+54], 10
      59C4EA78    56              push    esi
      59C4EA79    C786 B8000000 3>mov     dword ptr ds:[esi+B8], 59C4D630
      59C4EA83    C786 BC000000 1>mov     dword ptr ds:[esi+BC], 59C4E410
      59C4EA8D    C786 C0000000 3>mov     dword ptr ds:[esi+C0], 59C4D830
      59C4EA97    C786 C4000000 4>mov     dword ptr ds:[esi+C4], 59C4E440
      59C4EAA1    C786 C8000000 A>mov     dword ptr ds:[esi+C8], 59D71FA0
      59C4EAAB    C786 CC000000 1>mov     dword ptr ds:[esi+CC], 59C4DB10
      59C4EAB5    C786 D4000000 8>mov     dword ptr ds:[esi+D4], 59C4E680
      59C4EABF    C786 D8000000 1>mov     dword ptr ds:[esi+D8], 59C4DC10
      59C4EAC9    C786 DC000000 8>mov     dword ptr ds:[esi+DC], 59C4E680
      59C4EAD3    C786 E0000000 8>mov     dword ptr ds:[esi+E0], 59C4E880
      59C4EADD    C786 E4000000 2>mov     dword ptr ds:[esi+E4], 59C4DD20
      59C4EAE7    C786 EC000000 6>mov     dword ptr ds:[esi+EC], 59C4CE60
      59C4EAF1    C786 F0000000 D>mov     dword ptr ds:[esi+F0], 59C4CED0
      59C4EAFB    C786 F4000000 8>mov     dword ptr ds:[esi+F4], 59C4CC80
      59C4EB05    C786 F8000000 F>mov     dword ptr ds:[esi+F8], 59C4E8F0
      59C4EB0F    E8 7CF8FFFF     call    59C4E390                         ; igdumdim.59C4E390
      59C4EB14    8B4D FC         mov     ecx, dword ptr ss:[ebp-4]
      59C4EB17    5B              pop     ebx
      59C4EB18    5F              pop     edi
      59C4EB19    33CD            xor     ecx, ebp
      59C4EB1B    5E              pop     esi
      59C4EB1C    E8 7354EEFF     call    59B33F94                         ; igdumdim.59B33F94
      59C4EB21    8BE5            mov     esp, ebp
      59C4EB23    5D              pop     ebp
      59C4EB24    C2 0400         retn    4
          This function is setting some thing according a flag which read from call on @59C4E95F, and the following part is a complex branch to select correct arguments for the function call @59C4EB0F. I tried some trace route and found we need let  branch @59C4E9C2 goes false, so here we make it to nop like this:
      59C4E9B1    83F8 16         cmp     eax, 16
      59C4E9B4    74 17           je      short 59C4E9CD                   ; igdumdim.59C4E9CD
      59C4E9B6    83F8 13         cmp     eax, 13
      59C4E9B9    75 43           jnz     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E9BB    F742 04 0000000>test    dword ptr ds:[edx+4], 2000000
      59C4E9C2    90              nop
      59C4E9C3    90              nop
      59C4E9C4    C746 18 AC05655>mov     dword ptr ds:[esi+18], 5E6505AC
      59C4E9CB    EB 31           jmp     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E9CD    8B42 04         mov     eax, dword ptr ds:[edx+4]
      59C4E9D0    A9 00004000     test    eax, 400000
      59C4E9D5    74 09           je      short 59C4E9E0                   ; igdumdim.59C4E9E0
          OK, the most important part comes, translate the RVA into file address, and modify it. Sounds really hard isn't it? Good news is there is a more easy way, and this is the signature about this fix:
          83 F8 13 75 43 F7 42 04 00 00 00 02
          Search this hex string in the file, modify the following two bytes into "90 90"
      00291280h: 74 09 C7 46 18 5C 35 C6 14 EB 73 F7 C1 00 00 00 ; t.荈.\5?雜髁...
      00291290h: 20 74 09 C7 46 18 94 35 C6 14 EB 62 85 C9 79 09 ;  t.荈.??隻吷y.
      002912a0h: C7 46 18 CC 35 C6 14 EB 55 8B 45 DC 83 F8 15 74 ; 荈.??險婨軆?t
      002912b0h: 1C 83 F8 16 74 17 83 F8 13 75 43 F7 42 04 00 00 ; .凐.t.凐.uC鰾...
      002912c0h: 00 02 90 90 C7 46 18 AC 36 C6 14 EB 31 8B 42 04 ; ..悙荈.???婤.
      002912d0h: A9 00 00 40 00 74 09 C7 46 18 3C 36 C6 14 EB 1E ; ?.@.t.荈.<6??
      002912e0h: A9 00 00 80 00 74 09 C7 46 18 04 36 C6 14 EB 0E ; ?.€.t.荈..6??
           We need the do same thing for file igdumdim64.dll, but because this is 64bit dll, so the signature is different:
         01 76 17 83 F9 13 75 44 F7 42 04 00 00 00 02
          The modify should like this
      002d56f0h: 73 09 48 8D 05 1F AD A7 04 EB 6D 0F BA E1 1D 73 ; s.H?..雖.横.s
      002d5700h: 09 48 8D 05 48 AD A7 04 EB 5E 85 C9 79 09 48 8D ; .H?H.隵吷y.H?
      002d5710h: 05 73 AD A7 04 EB 51 8B 4C 24 20 8D 41 EB 83 F8 ; .s.隥婰$ 岮雰?
      002d5720h: 01 76 17 83 F9 13 75 44 F7 42 04 00 00 00 02 90 ; .v.凒.uD鰾.....?
      002d5730h: 90 48 8D 05 30 AE A7 04 EB 2E 8B 42 04 0F BA E0 ; 怘?0.?婤..亨
      002d5740h: 16 73 09 48 8D 05 AE AD A7 04 EB 1C 0F BA E0 17 ; .s.H???.亨.
      002d5750h: 73 09 48 8D 05 67 AD A7 04 EB 0D 0F BA E0 18 73 ; s.H?g.?.亨.s
           OK after modify the two file, replace it into the windows directory, if your windows is 64 bit, put igdumdim64.dll into windows\system32, and  igdumdim32.dll into windows\sysWow64. This must be done under the safe mode, restart windows and press F8 before windows startup, goes into safe mode to replace it.
          After reboot, you will get all things work.
         PS: In my system the nvidia's video card cause some problem, it will let system hang sometime, I highly recommand to reinstall the nvidia's drivers after install the Intel's drivers. and choose a lower version, but not the newest version. I have UHD 620 and MX 150 in my system, and after I reinstall the 397.64 nvidia drivers the problem gone away and the laptop works like a charm.
    • By Losercore13
      I have installed my 980M on myR2, Got the 8 Beeps, I thought with the A12 BIOS and Windows 10 it should have worked. Oh well, going to tear it back down and put the 675M's back in. Ijust got promoted and am downloading the A11 unlocked BIOS . So, Next teardown I am going to be completely ready. I just want to get this in and see if I can get it working before my return window passes. I have posted a few places here, and on Notebook Review on several threads about this stuff, and have received one response. Is this site still active? Do I need a modified driver still, all that stuff looks really old, 2013-2016 type stuff. I need to know about 2018. I have read that Nvidia added support for the maxwell in m18x r2. Am I wrong? Can someone offer advice? I have read that this thing should have been plug and play with windows 10 on Eurocom, Do I just need their driver? PLEASE HELP!!! Thank You!!!

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.