Jump to content
Munchicken

Alienware m17x r3 with Dell r9 m290x(HD8970m)

Recommended Posts

Hi,
I just got a Dell r9 m290x card for my m17x r3. I'm using the stock A12 BIOS. Had PEG set in the BIOS and on boot had a black screen. I cleared CMOS, most likely reverted back to SG and on boot had a black screen with 8 beeps.
I've seen people on here report that it is working for them. Do I need to use a different vBIOS? Or maybe the unlocked A12 BIOS with some settings changed?
Any help would be appreciated :)  Thanks.

Share this post


Link to post
Share on other sites
Another episode of "trying to do things that weren't meant to be done"...
 
I was wrong about it switching back to SG, it stayed on PEG.  I tried a few more things today and will just summarize from the beginning here:
 
I have an Alienware M17x R3 with an AMD HD6870M.  I got a Dell R9 M290X to replace the 6870.  BIOS was set to PEG upon starting procedure.
 
1) Swapped thermal solution to new card & installed new card
2) Powered on, got black screen
3) Powered off, removed CMOS battery
4) Powered back on, got black screen & 8 beeps
5) Powered off & on a few times, same results
6) CTRL+ALT+DEL, rebooted, same results
7) Removed new GPU
8) Booted fine with no discrete GPU
9) Checked BIOS, was still set to PEG
10) Set BIOS to SG
11) Reinstalled new GPU
12) New GPU shows in BIOS - ATI GFX
13) New GPU shows in Device Manager - AMD Radeon HD8970M
14) Intel GFX driver had a bang - Code 31 could not load drivers
15) Rebooted, same results
16) I'm using the Dell Intel driver - 8.15.10.2342 (it's old, but it allowed me to use HDMI-In with the old card)
17) Rebooted, now both cards have bangs
18) New card's driver says Code 12 cannot find enough free resources
19) Tried to auto update drivers, same results
20) Uninstalled both devices from Device Manager
21) Rebooted
22) Both showed up under Other Devices with no drivers
23) Reloaded drivers, Intel driver works, but same results with AMD driver
34) Had read somewhere that the integrated audio might interfere with some of these cards, so I tried disabling the onboad audio in BIOS, same results
35) Listed devices by connection in Device Manager, saw that AMD High Definition Audio Bus was on same controller, so tried uninstalling that, same results after reboot
36) Enabled show hidden devices in Device Manager, saw old 6800 series driver still there, but showing disconnected
37) Uninstalled old card's driver, rebooted, same results
38) Ran GPU-Z, shows vBIOS 015.046.000.014.045579
39) GPU-Z did not show any sensor data
40) Ran HWInfo, shows GPU fan at 35%, but I have not seen the fan come on at all
38) Set back to PEG in BIOS
39) No black screen this time, was able to see the OpROM screen for RAID controller
40) Right after that, got corruption/artifacts on the screen (several vertical blue lines with some scrambled looking text)
 
Suspect the artifacts/corruption might be due to heat, since the fan does not seem to be working.  Will let it cool off and try again later.
 
Here's some info on the resource usage shown in Device Manager:
HD8970M - PCI bus 1, device 0, function 0
I/O - 0000000000006000-00000000000060FF
Memory - 00000000A0000000-00000000AFFFFFFF & 00000000C8400000-00000000C843FFFF
IRQ - (PCI) 0x00000007

Share this post


Link to post
Share on other sites
Continued...
I let it cool down, since I thought heat might be causing the corruption on the screen.  And repositioned my external fan to help keep it cool.
 
Rebooted, still got corruption after the RAID opROM screen.
 
Remembered that I had been using a different charger for testing that had been causing an error on boot - not the factory charger yada-yada, press F1 to continue.  So I thought this might be that screen and pressed F1.  Yep, that worked and it started loading Windows.  All the following screens were ok.
 
In Windows, no driver was loaded and the device was listed under Other Devices.
 
I chose to reinstall the drivers.  It said drivers successfully installed.  But then went to the login screen (no reboot).  After logging back in, I noticed a message in the notification area saying the video driver had failed to start.  So I checked Device Manager.  But the driver was loaded and said it was started properly.  Perhaps that was from the first time and it had re-started since.
 
The GPU fan never did start turning, so I had to use HWInfo to control it manually.  This worked fine.
 
I tried a few apps and games, all went well.  I got awesome frame rates compared to the old card.
 
I think everything is going to work out ok with it, I only had a couple of concerns:
1) Once when I rebooted, I hit F2 to go to BIOS, the BIOS Information page was completely blank!  Bizarre, but only happened once, during early testing.
2) The fan not turning, although HWInfo manual control seems to work fine.
3) The scrambled screen on boot after the RAID opROM loads.  If there is an error, it will be unreadable.  However, if I switch back to SG, I should be able to read it.
4) My external monitor's resolution is reported a little shy of the max.  This is likely a driver problem and I will fiddle around with it later.
 
So the HD8970M / R9 M290X does work in an M17x R3.  Takes some effort & frustration, but works in the end :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By yoshomiamoto
      Hello Fellow Tech Gurus!

      I am having a huge headache after upgrading the ram memory of my m17x r3. 

      First let me start by saying I have been experiencing issues with my current ram setup recently, and so i decided to replace the ram inside of my computer, thinking they had gone out on me. It originally came with x4 2gb memory sticks, and as I started to experience issue, I started to removed them, and I was down to 1 2gb stick. It seems to me ram slots 1 & 2 are not working properly as when I put ram memory into them I would get BSOD in 5-10 mins of computer usage after boot. So I am thinking the slots have gone out. I also tested each slot individually and still same effect.

      So I went on the try out slots 3 & 4 under the keyboard, which seems to work just fine when I use only 1 ram chip in one or the other. But the problem occurs when I try and fill both ram slots in slots 3 & 4 under the keyboard with crucial 2x 8 gb of ram sticks, which total to 16gb total ram memory.

      BSOD and freezing occurs like crazy. But if I use just one of the ram sticks in either slot, no problem.

      I dunno if this is hardware or software. I am think that my motherboard is on its way out the door, but any suggestions you all have would be great. I have already clean installed win 7, and is currently running bios A10 (unlocked, I believe)

      I would also like to note that my motherboards internal vga is not detected, and just noticed this a few days ago upon trying to figure out the ram situation.

      other issues is my laptop battery is pretty much dead, and the only for my computer to cut on is if the AC adapter is connected

      I would also like to know can 1x 16gb 1600 ram stick run in my computer? or is it not supported by my motherboard? 

      thanks!

      Specs:

      Alienware M17xR3 (2011 3D FHD ed)

      Service Tag:
      30W75Q1

      Bios ver:
      A10 (should be unlocked)


      Operating System
      Microsoft Windows 7 Home Premium (64-bit)

      Processor
      Intel® Core™ i7-2960XM CPU @ 2.70GHz

      Chipset
      Intel® 6 Series/C200 Series Chipset Family

      Graphics
      Nvidia GTX 680m

      Audio
      IDT High Definition Audio CODEC
      High Definition Audio Device

      Networking and I/O
      DW1501 Wireless-N WLAN Half-Mini Card
      Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20)
      HMA TAP-Windows Adapter V9

      Memory
      Crucial 8 GB (x2 qty) DDR3 PC3-12800 • CL=11 • Unbuffered • NON-ECC • DDR3-1600 • 1.35V • 1024Meg x 64 •

      (these only work under bay 3 or 4, but not dual 8gb at the same time, otherwise BSOD)

      Configuration ID:
      CT3283724

      Storage
      WDC WDBNCE5000PNC SSD (installed into bay 0)
    • By deviantology
      Hey guys, 
       
      I have an Alienware m17x R3. i bought it as scrap. but currently working. i have this issues with this device. i hope you guys can help me out with this.
       
      Issues:
       
      The device is charging when its turned off. and when its on (on) state, when i plug in the charger it turns off the light in the charger port.
      solutions that i have tried: changed the charger and battery, flashed the bios.
       
      change a capacitor near charging port. 
       
      after all of the solutions i tried. i have found one thing to be suspicious about. The device charges normally even on (on) state and doesn't kill the light in the chargers port. if i dont install the driver of the GPU 680m Dell 2gb. 
      can anyone help me with his matter? thank you
    • By Henrik9979
      Okay here is what's going. I have a alienware m18x r1 running an amd 8970m, I wanted to upgrade it to crossfire but I could see a 8970m was more expensive than a r9 m290x
      So I decided to buy a r9 m290x and see if I could make it work in my alienware and also run crossfire.
      Even though many shops refused to sell me one because the didn't think it would work in an alienware m18x r1 only in the r2.
       
      Here is the whole process.
       
      19/08/17 23:15
      No post bios showing when booting, so impossible to enter bios menu, but can boot into windows 10 with no problems.
       
      19/08/17 23:20
      Because I haven't deleted the old AMD 8970m the r9 m290x shows as a 8970m with no problems.
       
      19/08/17 23:34
      First performance test was a success. The r9 m290x changed p-state normally. The gpu fan start spinning normally. But because of no thermal paste, the test lasted 20 seconds because the temperature raised fast.
       
      20/08/17 00:00
      Created a backup of the vbios version
      015.032.000.004.044450
       
      20/08/17 00:10
      Flashed a new clevo vbios version 015.032.000.003.044465
      Caused the card to be corrupted and resulted the 8 beep code.
       
      20/08/17 00:35
      Finally managed to flash the back and return the graphics card to its original state.

      20/08/17 00:50
      Flashed a new dell vbios version 015.046.000.014.045579
      No change in behavior
       
      20/08/17 01:07
      After trying multiple vbios with no luck I finally found one.
      Dell vbios Version 015.041.000.000.044966
      Brings back the post bios screen and I can now enter the bios menu through the r9 m290x.
      Note: This vbios reduce the cards performance from 900 mhz to 850 mhz
       
      20/08/17 01:21
      After more testing I found one that is working with no limits.
      Clevo vbios version
      015.036.000.005.044618
      Brings back the post bios screen and I can now enter the bios menu through the r9 m290x.
      This will be the vbios I will keep at the moment.

      20/08/17 01:56
      I completely uninstalled the previous driver and installed the newest driver. The graphics card is recognized as a 8970m but works normal.

      21/08/17 20:15
      I have inserted my old 8970m in the secondary slot and will start testing crossfire.
       
      21/08/17 21:45
      I have found out that the fan for the secondary fan did not spin. The is a cable that have felt out. I will fix it now.

      21/08/17 22:00
      In my try to test crossfire compatibility, I installed the newest AMD driver 17.7.2 but as soon it installed the driver for the secondary card it caused black screen. Only booting the computer in safe mode brings the screen back.

      21/08/17 23:02
      After many frustrating hours I finally managed to get crossfire working with the r9 m290x as the primary card and my old 8970m as the secondary.
      I have flashed the same vbios on both cards so the r9 m290x shows up I device manager as a 8970m.
       
      I first installed AMD driver version 16.2.1
       
      Then installed AMD driver version 16.6.1 in order to play battlefield

      21/08/17 23:20
      First test run in battlefield 1

      21/08/17 23:40
      Battlefield 1 is flickering bad, this can maybe be solved with a new patch or driver.
      Other games I have tried is working perfect with crossfire on.


      Now what I would like to try is somehow force the r9 m290x driver to be installed and see if it will make it possible to run the latest AMD driver without getting a blackscreen.
       
      I have tried to edit the .inf file like you would do with nvidia but no luck.
      I have also tried to figure out how to edit the device id in the vbios, but I find it too complex.






























       
    • By poboy975
      As the title says, does anyone know where the bios chip location is on the R3 motherboard? Is it the same as the R4? I've seen posts about the R2 and R4, but not the R3 This is the R4 post:
       
    • By poboy975
      Just like the title says, I cant get the driver to install. I'm on Windows 10 x64 release 160906. The card works in 1920 x 1080 with the windows vga drivers. I've disabled driver signing, I'm in test mode. I've tried the nvidia driver versions, 365.19, 372.54, 372.70, 372.90. With modded inf's for each from laptopvideo2go.com They all start the install, but when it gets to the driver install, the screen goes black for about 30 seconds, then the computer just reboots. The drivers don't get installed. I've seen a bunch of threads around about Windows 8, but nothing that seems to answer for windows 10. Is there something that I'm missing to get the drivers installed?
       
      Update, found this thread. 
      I got the drivers installed following the directions, but after rebooting back into normal mode, the computer just reboots. I see the windows logo, screen goes black, then after about 30 seconds, it just reboots. This was using the 372.90 and inf files from the thread.
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.