Jump to content
Review: E-Win Champion Series Gaming Chair Read more... ×
EwinRacing Flash Series Gaming Chairs
Brian

Hack/Workaround to remove "Prototype Test Only. nVidia Confidential" while using 3D.

Recommended Posts

Credit goes to lubu for creating a hack to work around this overlay message. Currently there is no real solution from Dell/nVidia and I doubt there will be one anytime soon.

Purpose of method: To replace a bitmap file in nvstres.dll that contains the red overlay with the "prototype test only. nVidia confidential" while in 3D mode.

  • Download PE Explorer
  • Add in the replacement bitmap (see attached)

Steps

1. Install and open PE explorer

2. Load your nvstres.dll file which is located in C:\Program Files (x86)\NVIDIA Corporation\3D Vision (select All Files in File Types)

3. Click on Resource Viewer/ Editor

4. Go to Bitmap folder and select 201 (this is the template of the warning msg)

5. Double clicks on 201 a new window should appear allowing you to edit the file

6. Open the replace201 bitmap file

7. Close the editor and save it as nvstres1.dll (for some reasons it wont allow me to save over the old file)

8. Delete the original nstres.dll and rename the new one as nvstres.dll

9. Restart your laptop

These steps will have to be repeated each time the driver is updated to a new one.

replace201.zip

Edited by Brian
  • Thumbs Up 5

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Similar Content

    • By Henrik9979
      First I want to thank the community, who have inspired me to do this project.
      I will give you guys the chance to follow me on this journey.
       
      I hope you will all help me come up with ideas, techniques and parts that could become handy.
       
      This modding may be possible to convert to allot of laptops.
       
      Let's begin!
      Here is the measurement of the went hole.
      77mm X 16mm

       
      I have 2 ideas for what can be done.
       
    • By svl7
      Patched this together on request, M18x R1 BIOS A05 (unlocked) with the RST 11.5 OROM.
      The orom comes from the station-drivers site, not sure whether it will work fine with the M18x, though I don't really see why it shouldn't.
      Btw, something's weird with the original orom in the R1 BIOS, the checksum is wrong... confusing.
      Anyway, here's the BIOS, let me know how it performs. Also remember to use the latest RST driver for this ROM.
      Flash with your favorite BIOS utility or the tools provided by Dell.
      As always, use at your own risk.
       
      Download link:
       
    • By gaffycool
      Hi everyone,
      I am having issues with my gtx 880m. I currently have a m18x r1 unlocked a05 bios and modded drivers (368.69 also tired 372.90)
       
      basically when im playing battlefront the game plays for about 1 min, and then crashes and I got this direct x error message on screen (shown in pic below)
      I managed to fix this error by turning on vertical sync in settings in the game and also in the nvidia control panel (it was set to auto, or adaptive and I changed this to on), and this fixed this create texture error.
       
      Now I am getting a completely new error and I was able to play the game for now more than 1 min, usually around 10-12 mins before crashing, i am now seeing a new error,
       
      directx function "DX11 Renderer::tryMap" failed with DXGI_ERROR_DEVICE_REMOVED ("The video card has been physically reomved from the system, or a driver upgrade for the video card has occurred. ").
       
      I have tried to change drivers, change clock speeds, turn off overclocking and running everything on low, I have also tried to delete the ndvi64.api file from system32 as suggested in an ea forum, and still no luck.
       
      Anyone else had this error? took me 3 days to finally get the gtx 880m to work in the mx18 r1 and now the only game that plays is battlefield, which works floorlessly on ultra for 4+ hours game play constantly with no issues. but its just when I play battlefront it crashes
       
      ive tried to even do the directx web installer to install latest files and still didnt work..
       
      any help would be appreciated and im sure would help out alot of mx18r1 users or gtx 880m users out there.
       
      thanks
       

       
      then I managed to fix this error
    • By CoolSheep
      Hi
      My m18x has dual 580m and I can't switch to them, fn-f7 just boots the Intel graphics. I might also get "Error : MXM Structure not found or invalid"Anyone know what the problem is?
      Thanks
    • By xnz1201
      Clevo P370em with GTX980M 344.75
      ROG PG278Q connect with DP
      3D Vision 2
      NV control panel can correctly recognize my monitor and IR emitter, but I can't turn on the emmiter. I ran the setting guide, it told me to connect emmiter and push the green button. I pushed, it didn't react, still dark green. I click Next, it pop up this

      As you see, how can I deal with this
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.