Jump to content
EwinRacing Flash Series Gaming Chairs
Klem

Lenovo ThinkPad X240 unlocked BIOS menu / wlan / wi-fi whitelist mod

Recommended Posts

6 hours ago, mac_vti said:

Hi Klem,

Could you please remove the WWAN/WLAN whitelist and unlock the Advanced Menu for my Thinkpad X240 bios please? A link to my bios can be found here: https://drive.google.com/file/d/1pmZRp6tfcBy63z2sY-jfoO1IKrHjwI9J/view?usp=sharing

 

Thanks a million!

Hi!

Ok. Check PM.

6 hours ago, AlonsoA said:

Hi @Klem, could you help me with whitelist please?

 

https://mega.nz/folder/AwJW0TZI#I7-HXOVAeKOIkEJ4Sbp3lg

 

Thanks!

Hi!

Ok. Check your Inbox.

Share this post


Link to post
Share on other sites
Posted (edited)

Sorry for beeing so late with my reply. I'll try to put it all in one long answer.

 

I received the laptop with the words: "Here. We had this lying around for ages because the guy who set the password doesn't work here anymore and noone knows the password, found some videos online, that you can bridge two contacts to bypass it. Want to give it a try? It's useless anyway"

 

Free laptop? Sure! 

 

So I found the videos like this, too and gave it a try. Should have done some more research in the beginning... but having IT background myself I just assumed that the BIOS would skip the password check if it received invalid response when the method is called... 

 

So I tried to get the "correct timing" but I failed every time. And that last time the laptop made beeping noises (which I can't recall exactly) but kind of like "missing RAM". And from that moment the laptop didn't boot anymore. 

 

That means: The mainboard started, the hdd spun up, the fan spun up shortly, the cpu started to get warm, the F1 Key lit up shortly but the screen stayed black. 

I assumed I blew a fuse while trying to bridge it and that It might just be missing screen backlighting, but the screen stayed completely off. 

Checked with a good known USB keyboard with CAPS-Lock light if it turns on during boot. But it didn't.

Removed the ram. Beeping but no booting (as expected).

 

Tried the wildest combinations of power draining. Disconnected the internal battery, disconnected, the CMOS battery, tried the built in "reset button". But not luck. 

 

Took the laptop to work and used a CH341A programmer with Clip to see if I blew the Winbond 25Q128FVSQ, but to my amazement It detected the chip and I could read the contents. 

 

Then I thought I might be able to get a fresh BIOS from the Lenovo BIOS Update Package. But while looking at the procedure of how to extract it form the updater.exe or the iso I found an (seemingly) already extracted BIOS here.

 

I emptied the chip, programmed it with the bin aaaaaand: The screen turned on. The POST started and then it failed with a CMOS Time error (I expected that) and a Error 0183 Bad CRC in Security Settings in EFI Variable - Press F1 to start Setup. 

 

Pressing F1 results in a Supervisor Password prompt (little guy besides the lock)

 

On the original BIOS I could just hit enter an came at least in a read only mode into the BIOS settings. But now I just received the crosses (after three tries) and a "stop signaling hand" 

 

I was intrigued, that the flashed BIOS might have a password set (although at that time I learned, that the password seems to be stored on another chip)

 

So I checked again on the website where I downloaded the bios.bin if there is a note like "password is 1234 or something"

 

Unfortunately I didn't find anything. But another post on the same website here wich leads to another google drive with another binary. 

 

Did a Hex diff and saw that it is indeed different. cleared the chip. flashed the second bios. 

Laptop boots (with another Logo) but still the Bad CRC error came up and the F1 Setup prompted for a password. 

 

Just for the kicks I flashed the original BIOS I read from the chip in the beginning to check if it magically boots again, but no it doesn't.

 

Reflashed one of the downloaded. Boots again (still prompting for a password)

 

Then I thought: Maybe I can use a Open Source Bios like libreboot or coreboot. But I learned that the bios has to be signed from the X240 upwards because of Intels BootGuard

 

Then I stumbled across this post and thought I could give it a try because it seems like you're kind of deep into the matter and you might have a solution or a hint of what I can do. 

 

At this point I'm thinking about: 

1 ) Maybe I do the effort to extract the bios from the official Lenovo bios update

2 ) I try to research where the password is stored and if it is possible to replace the chip (or clear it)

 

Because now that I saw the laptop came back to life again I'm kind of intrigued that I might get it back working completely again.

 

 

 

Sorry for the long story. Hope I didn't miss anything. 

Any help is appreciated

 

Kind regards

 

Xcame

 

Edited by Xcame
typos

Share this post


Link to post
Share on other sites
26 minutes ago, Xcame said:

Sorry for the long story. Hope I didn't miss anything. 

Any help is appreciated

 

Kind regards

 

Xcame

 

Unfortunately I can't help you in your case, because I don't work with any passwords. Sorry.

Share this post


Link to post
Share on other sites

Hi Klem,
Can you please remove LCD whitelist for my X240? I replaced from HD TN (1366 x 768) to FHD IPS (1920 x 1080) and now I cant lower brightness.
Thanks

Share this post


Link to post
Share on other sites
20 minutes ago, 0karlk0 said:

Hi Klem,
Can you please remove LCD whitelist for my X240? I replaced from HD TN (1366 x 768) to FHD IPS (1920 x 1080) and now I cant lower brightness.
Thanks

Hi!

Ok. Send me your bios dump.

Share this post


Link to post
Share on other sites

PLS CHECK AGAIN

 

Edited by rehan

Share this post


Link to post
Share on other sites
43 minutes ago, rehan said:

PLS CHECK AGAIN

 

Ok. Check PM.

Share this post


Link to post
Share on other sites

Hi, Klem! I have exactly the same programmer as on the picture in you first post. I know there is a problem with signal output voltage  (5v instead 3.3v). There are problems on the X 230 with a burnout of the bios chip strapping, I do not know if there are similar problems with x 240. And i know also that guys with x230 do the trick with wake on lan and active ethernet cable to do the bios dump and flashing to avoid breakdowns. Do I need to modify programmer before using, and to make any tricks with power supply on x240?

Share this post


Link to post
Share on other sites
4 hours ago, Donkey Hot said:

Do I need to modify programmer before using, and to make any tricks with power supply on x240?

Hi!

No, with X240 you can use CH341A programmer as is.

Share this post


Link to post
Share on other sites
11 hours ago, Klem said:

Hi!

No, with X240 you can use CH341A programmer as is.

Well, here is my dump. Is it possible to remove remove whitelist complitely? If it's not i'm interested in wlan, modem and lcd. I will also be gratefull for unlocking the advanced menu. Thx!

https://litter.catbox.moe/56fh0y.bin

Share this post


Link to post
Share on other sites
5 minutes ago, Donkey Hot said:

Well, here is my dump. Is it possible to remove remove whitelist complitely? If it's not i'm interested in wlan, modem and lcd. I will also be gratefull for unlocking the advanced menu. Thx!

https://litter.catbox.moe/56fh0y.bin

 

Ok. Check PM.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hi, Klem!

Please, help me clean BIOS whitelist (wlan, wwan, lcd) and get addition menu. Here is dump of my Lenovo X240 by programmer CH341A https://yadi.sk/d/78No5YIH1qOLPA

Thanks.

Edited by Miha

Share this post


Link to post
Share on other sites
43 minutes ago, Miha said:

Hi, Klem!

Please, help me clean BIOS whitelist (wlan, wwan, lcd) and get addition menu. Here is dump of my Lenovo X240 by programmer CH341A https://yadi.sk/d/78No5YIH1qOLPA

Thanks.

Hi!

Ok. Check PM.

Share this post


Link to post
Share on other sites

Привет, Клем. 350р. донатом на пиво устроит?

Share this post


Link to post
Share on other sites
1 hour ago, Miha said:

Привет, Клем. 350р. донатом на пиво устроит?

Hi!

I answered you in PM.

Share this post


Link to post
Share on other sites
2 hours ago, taucoder said:

Hi, Klem!

Can you please remove LCD (EDID) whitelist? 

BIOS dump

 

Hi!

Ok. Check PM.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By pippocarlot
      Hello everyone! I am looking for an answer to a problem I cannot find a solution to ... I purchased an Amd wx 4150 MXM GPU module su e bay to upgrade my HP 8570W Mobile Workstation which is currently equipped with a Fire Pro M4000. Once the new GPU has been installed, the PC screen no longer turns on but works only with external monitors connected via the docking station. The same happens once the drivers are updated! If I put the old card back on, the integrated monitor starts working again ... How can I fix it?
    • By Swick1981
      Bios Release Version – v2.0.0
       

       
      Updated or Modded Items:
      A11 UNLOCKED BIOS FOR m18Xr2 (UNLOCKED BY SVL7 AND FULL CREDIT GOES TO HIM FOR UNLOCKING!)
      SVL7 Also created the PRR2.EXE tool that allows you to flash the new bios by unlocking it.  (FULL CREDIT GOES TO HIM FOR THAT FILE PRR2.EXE)
       
      Here are ALL the things I've added, modded, and enhanced on this bios -
      I've added FULL LEGACY SUPPORT ON THIS BIOS with ONE or TWO CARDS (SLI).  You can FINALLY use Win 7 OS on your machine and run the 900 series GPU's! 
      This is a MAJOR breakthrough!
       
      LEGACY SUPPORT Confirmed.  Works with 900 series GPu's in single OR SLI formation Updated the Intel RST Legacy to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated Intel RST UEFI to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated the ONBOARD Video Card for the HD3xxx to v2171 - FROM v2132 Updated ONBOARD Video Card for the HD4xxx to v2171 - FROM v2132 Updated the LAN Firmware & PXE Boot from 2.0.5.9 to v2.0.6.6 ADDED NvMe Support for m18xr2 ADDED M.2 support for m18xr2 Updated CPU Microcode to v29 for the 2900 CPU's Updated CPU Microcode to v1c for the 3900 CPU's Updated GOP Driver for Intel Sandy Bridge CPU Updated GOP Driver for Intel Ivy Bridge CPU Updated MAIN GOP Policy module for the m18xR2 Eliminated some code that wasn't used in the m18xR2 Updated CSM Module (v2) Streamline some coding to make mod(s) run a little more efficiently (v2) Added FPARTS.TXT to rar file in v2. (I had forgot to add it in v1) v2.5 to be released shortly.  I've updated a few more modules that I didn't realize could be updated.  (It's only 3 modules, but it's still an update!)   It should be released in about a week.  Hope this helps ya'll!  
      Instructions to flash:
      Use a flash drive to create a boot disk into dos Unzip ALL files into the root of the flash drive (flash.bat, r2final.bin, fpt.exe, flash.bat, prr2.exe, fparts.txt,m18r2.hdr, m18r2.hdr.bin, readmefirst.txt) BOOT INTO DOS – Note, that when you set the bios to legacy in order to boot into dos, you MAY have to reinstall OS!  (Just be prepared to reinstall no matter what) Once you boot into dos, run the file flash.bat It will unlock your bios (THANKS TO SVL7’s BIOS UNLOCKING TOOL – ALL CREDIT TO HIM FOR THIS TOOL!) Let it flash… Reboot your pc, and enjoy the MASSIVE updates!  
      Be on the lookout as I do plan to release newer version with more updates in the future.  However, it wont be for at least a few weeks as I'm now working on legacy support for the m17xR4 and several other systems.  So please be patient!
       
      ENJOY!
       
      Thread link for more information and discussion:
       
    • By svl7
      Files contained in this archive:
      FTP-DOS.zip prr2.zip M18x R2 - BIOS A03 'unlocked.zip M18x R2 - BIOS A08 'unlocked.zip M18x_R2_-_BIOS_A08_-_[unlocked]_-_[IRST 11.0.6.1702].zip M18x_R2_BIOS_A03_-_[unlocked] - [IRST 11.6.0.1702].zip M18x_R2_BIOS_A09_-_[unlocked].zip [FPT]-M18x_R2_BIOS_A09_-_[unlocked].zip [FPT]-M18x_R2_BIOS_A10_-_[unlocked]_V2.zip M18x_R2_-_BIOS_A08_-_[unlocked].zip M18x_R2_BIOS_A03_-_[unlocked].zip  
      For information on how to use the files in this archive, see here:
       
       
      My donation link in case you want to buy me a beer
    • By Anderitos135
      I have a iBuypower CZ-17 laptop, with a 2012 AMI BIOS that has E1762 as the version, which I believe means I have an MSI G70 motherboard. It has a 675MX GPU, but it's not useable in Windows 10 despite being "seen" in the device manager. I believe an updated, unlocked BIOS would fix my issue and have located the thread on this site with the BIOS I need.

      First of all, am I right? Will this fresh BIOS make my laptop that originally ran Windows 8 work with this old GPU?

      And second, I created this account, will wait 24 hours and made this post. Is that enough to allow me to download the file, or do I need to post elsewhere?

      Thanks!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.