Jump to content
Sign in to follow this  
Sarafan

Can I upgrade my GT60 Barebones (16F4) GPU from 970m to 1070?

Recommended Posts

 

Does anyone have experience with this?

Some threads I've seen have done it on a 17 inch laptop, I was wondering if it was possible on the 15 inch version as well.

What issues will I face? I read about having to have a custom BIOS and vBIOS..but also HDMI/audio issues.

I guess I should also upgrade my CPU, which runs really hot (i7 4800MQ), but not sure another Haswell chip will run any cooler.

I've used liquid metal and even that hasn't changed temperatures much, it still reaches 93C pretty easily.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Edrc
      Hello,
       
      I am new on this forum, so I am sorry if posting at the wrong place. It's been 2 weeks that I am searching how to make my GTX 980M 8GB working Inside my Alienware 17 R1 (June 2014, i7 4710MQ, 60 Herts Display, OPTIMUS and the GTX 880M Inside died.)
      After "quickly" looking some forums, I saw that a 980M would easily fit Inside … but maybe I was wrong.
       
      Hardware wasn't a problem. I've also could install drivers by modding the nvdmi or nvcvi. inf files. The card was recognied BUT :
      the clock speed is locked a 135 or 405 Mherts and fan is not runing when booted up.
      I tried to flash vBios with nvflash and some ROM I found on vBios collection … but no way to get this working properly.
       
      So, i'm coming here. I've seen many people talking about Prema or svl7 or other big boss in the place … but ? how ? where ? when ?
       
      Inside the peripherial manager I have this in remote acces path : PCI\VEN_10DE&DEV_1617&SUBSYS_05AA1028&REV_A1\4&D590A51&0&0008
      So I assume my GTX 980M card ID is 1617 and vendor and PC Model are 05AA 1028.
      But near the "Standard Microsoft Video Card" there is a yellow exclamation point and Inside details it says "this peripherial doesn't work properly" when no Nvidia drivers installed.
      I could find some vBios with 1617 (Asus) but black screen at boot up. Since laptop model where not the same .. probably.
      And I wasn't able to find 1617 with the existing 05AA 1028 … as the GTX 980M was not an option for my model. (AW 17 R1 2014 ,60Herts)
      I tried 353.60, 382.33 and 419.35 drivers. The latest one seems easier to install but longer.
       
      BIOS is A16 from Dell. And I am using Windows 10. Got a Dell 330W brick. 
       
      I saw a guy with the exact model as me, he gets a modded vBios especially for his configuration, then everything worked easily … but can't find the topic again
       
      I guess depending on the card info and the laptop model … a dedicated vBios is required … 
       
      So, If anyone here got some informations or any kind of help for me, it would be very nice.
       
      Thanks for reading and help.  
       
      PS: there are a lot of files, pictures and links that I can't see on this forum .. even after registration …. 
       
    • By aBug
      Hello Everyone!
       
      I have problem with VBIOS/EEPROM(?) after installing of a GTX1060 N17E-G1-A1 GPU NVIDIA Graphics Chipset (old one has temp. damages). 
       
      I  modified new 416  and old 391 nvmii.inf file and try to install drivers, but every combination gave me no success. There is only yellow triangle in  Windows Device Manager :|
      Is there a way to bring my card to life?
       
    • By Adomis63
      Hi guys,
       
      I'm sorry for making another thread just for this but I really wanted to pick your brains on this!
       
      I have an m15x with a 770m running windows 7 and everything works. Rock. Solid. I'm pretty happy with it. Since windows 7 is on it's way out, I would like to upgrade to windows 10. Now I've looked into it before and had a really hard time getting the 770m to behave nicely and had all these issues with green/yellow/pink screens and I remember it being a miracle I got it to work on 7 as good as it does.
       
      My question is how well does the 970m install vs the 770m - particularly on windows 10? I would buy it in a heartbeat if it makes the install less tedious with the colored screens and all that. Especially if all the functions work on it! I have been searching the internet and I cannot find nearly as many problems with the 970m as I could with the 770m, or am I just  not looking in the right places?
       
      Thanks a million!
    • By handale30
      I added this post in the another forum a few months ago but felt like it could also help someone here, enjoy... So ive owned quite a few Alienware laptops but out of all of them my favorite has always been the great m17x R4. I love its aggressive looks, its lines and grills remind me of lamborgini design, the 1 glass sheet screen, the media keys looked futuristic and its laser etched name plate added a touch of personalization and attention to detail that they used to have. So considering it still has powerful specs for modern standards, i7 processors, 32gb ram, 2ssd and 1msata slots, 120hz 3D display, mxm slot, sd card reader, I couldn't help but to sell my 2 current laptops (15 R1 980m, 4k, 15 R3 1060) and purchase a pristine example of this machine with all its original packaging to upgrade it up to todays specs.   The Original Specs of this particular system were:  * Intel i7 3820qm 2.7ghz / 3.7ghz  * Nvidia GTX680m 2gb  * 8gb DDR3 RAM 1600mhz CL11  * 250gb Samsung 840pro SSD  * 1tb Seagate Momentum HDD  * 17" 1080p 120hz 3D display Desired Upgrades:  * Intel i7 3940mx 3.0ghz / 3.9ghz  * Nvidia GTX 1070 8gb  * 32gb DDR3 Ram 1600 CL10 Corsair  * 1tb Samsung 860 EVO SSD  * Liquid Metal and better thermal pads    2019 Specs: * Intel i7 3940mx 3.0ghz / 3.9ghz  * Zotac GTX 1070mxm 8gb  * 32gb DDR3 Ram 1866 CL9 Corsair Vengeance  * 1tb Samsung 860 Evo SSD  * 256gb Samsung 840 Pro SSD  * Liquid Metal and Fujipoly 17w/mk thermal pads  * 17.3" 1080p 120hz 3D display   I already purchased the GTX 1070 mxm, 32gb RAM and the 1tb SSD. The GTX1070 is installed and working at its full power. I applied Thermal Grizzly Conductonaut liquid metal thermal compound to both CPU and GPU and Fujipoly ultra extreme 17.0 W/mK thermal pads with my modified GPU heatsink and new X-bracket. CPU is overclocked from OEM BIOS to stage1    4.1ghz  3.9ghz 4cores. No chasis or board was cut or damaged during this process as I wanted to keep its integrity and no throttle issues what so ever. As I already had the 120hz edp screen, it was an easier job to do and thanks to @Striker123 and to @D4ddy for their threads as they made me have the guts to go through the project and to Rick for selling me this perfect example of a computer.   Alienware m17x r4 1070 mxm http://forum.notebookreview.com/threads/msi-gtx-1070-mxm-successfully-working-on-alienware-m17x-r4-another-socket-victory-against-bga-crap.803637/ Alienware m17 Ranger 1070 mxm http://forum.notebookreview.com/threads/alienware-17-r5-gtx-1070-mxm-3-1b.800137/   Here are some before and after benchmarks so you can see this baby flying let me know what you think about these numbers... I will be uploading more pictures soon as it only lets me upload 5. If you guys have any questions id be glad to help out.   current issues:    - the GPU fan does not automatically work so I have to use HWinfo to manually build the fan table but HWinfo sucks balls at this and doesn't start them automatically either, also with HWinfo I take control of both CPU and GPU fans at the same time and sometimes I just want my CPU fan to be spinning. so if someone has a fix for this man that would be great!    
    • By captcavy
      Hello everyone,, I need your expertise, I have a m17 r4, (2012) unlocked A15 bios thanks to Klem, it has a Gtx 675m in it now, 
      I would like to know the best GPU to upgrade to without losing a lot of the factory functions of the alienware laptop, like being able to use both VGA functions such as intel 4000, and the factory bios for the cooling of the GPU, I don't want to solely rely on the nvidia
      As a full dedicated GPU, let me know what VGA card to get and what vbios to use, I will gladly donate beer to you for your help, or point me to a member on this forum who can help me,
      Thanks, Shelby,  Aka captcavy
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.