Jump to content
Sign in to follow this  
true2456

m15x 980m Upgrade

Recommended Posts

Hey all, decided to get a cheap m15x and managed to get an msi gtx 980m along with it. I've ordered two fans I'm planning on trying to mod in, one being a 13 cfm dell m6700 fan and the other a 11cfm m4700 fan to try and help with the heat. I currently have a 210 or 240 watt? power adapter and a 920xm installed so I'm planning on undervolting the gpu. Is it best to do this inside afterburner or is better to do try and mod the vbios? Also will I have to flash the dell vbios onto my card to get it working with my system or will I just have to modify the .INF file?

Share this post


Link to post
Share on other sites

Out of curiosity have you considered running the 330W PSU instead of undervolting the GPU? Btw, which thermal pads are you planning to use for the GPU ram? I feel like your biggest concern is going to be extra heat on this build.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Soapy
      I reversed the input polarity on my m15x jack after a botched psu repair. Computer worked fine, but overall power control is messed up. System only boot on both battery and psu, no battery charge, and a very low battery drain (arround 6wh).
       
      I aways had battery issues whith my 8 years old m15x after my original battery died. Bought a new one two years ago, didn't work. Checked on upower, basically no info on manufacturer, power or history. So i refunded and used the system hooked on the psu as usual. In August i bought a new one, worked flawlessly for a day. The next day the battery died from nowere. Checked upower, bus was ok, battery was charging extremely slowly (6wh), history showed subpar disharge before shutting down. I got mad at this point, decided that psu was to blame. Opened it, checked everything, noticed some wear on the male jack. Resoldered it, connected on computer. Nothing happened, so i checked the voltage. That's when i realised that i screwed up big time. I swaped the positive and negative wires. Decided that one mistake was enough, so i sent my m15x to a trusted repair shop (latter found that they just hooked the battery and gave me back as soon as it booted, they didnt even open it). Got my pc a week later, but the battery didn't charge . Worse, it was slowly discharging (same 6wh as before), and it needed both the psu and the battery to turn on. At 65%, it worked as usual for my college semester, but the battery is dead, and so is my computer. I bellieve i burned some voltage controller or something. I'm pretty competent at soldering thing's (evem smd components) when i know what to do, and i can understand simple circuit's, but when i got my hands on the m15x datasheet i got overblown. I cant make heads or tails about it. I aways lurked this forum and i bellieve your guys are the best when it comes to finding creative solutions to technical problems concerning microelectronics. I followed a guide in this forum as a teenager to upgrade this same computer to a gtx680m, overclocked stuff, got custom bios, and had a lot of fun learning. The m15x is a deprecated platform, but it's a part of my history that i dont want to let go.
      So please guys, help me.
       
    • By Edrc
      Hello,
       
      I am new on this forum, so I am sorry if posting at the wrong place. It's been 2 weeks that I am searching how to make my GTX 980M 8GB working Inside my Alienware 17 R1 (June 2014, i7 4710MQ, 60 Herts Display, OPTIMUS and the GTX 880M Inside died.)
      After "quickly" looking some forums, I saw that a 980M would easily fit Inside … but maybe I was wrong.
       
      Hardware wasn't a problem. I've also could install drivers by modding the nvdmi or nvcvi. inf files. The card was recognied BUT :
      the clock speed is locked a 135 or 405 Mherts and fan is not runing when booted up.
      I tried to flash vBios with nvflash and some ROM I found on vBios collection … but no way to get this working properly.
       
      So, i'm coming here. I've seen many people talking about Prema or svl7 or other big boss in the place … but ? how ? where ? when ?
       
      Inside the peripherial manager I have this in remote acces path : PCI\VEN_10DE&DEV_1617&SUBSYS_05AA1028&REV_A1\4&D590A51&0&0008
      So I assume my GTX 980M card ID is 1617 and vendor and PC Model are 05AA 1028.
      But near the "Standard Microsoft Video Card" there is a yellow exclamation point and Inside details it says "this peripherial doesn't work properly" when no Nvidia drivers installed.
      I could find some vBios with 1617 (Asus) but black screen at boot up. Since laptop model where not the same .. probably.
      And I wasn't able to find 1617 with the existing 05AA 1028 … as the GTX 980M was not an option for my model. (AW 17 R1 2014 ,60Herts)
      I tried 353.60, 382.33 and 419.35 drivers. The latest one seems easier to install but longer.
       
      BIOS is A16 from Dell. And I am using Windows 10. Got a Dell 330W brick. 
       
      I saw a guy with the exact model as me, he gets a modded vBios especially for his configuration, then everything worked easily … but can't find the topic again
       
      I guess depending on the card info and the laptop model … a dedicated vBios is required … 
       
      So, If anyone here got some informations or any kind of help for me, it would be very nice.
       
      Thanks for reading and help.  
       
      PS: there are a lot of files, pictures and links that I can't see on this forum .. even after registration …. 
       
    • By Adomis63
      Hi guys,
       
      I'm sorry for making another thread just for this but I really wanted to pick your brains on this!
       
      I have an m15x with a 770m running windows 7 and everything works. Rock. Solid. I'm pretty happy with it. Since windows 7 is on it's way out, I would like to upgrade to windows 10. Now I've looked into it before and had a really hard time getting the 770m to behave nicely and had all these issues with green/yellow/pink screens and I remember it being a miracle I got it to work on 7 as good as it does.
       
      My question is how well does the 970m install vs the 770m - particularly on windows 10? I would buy it in a heartbeat if it makes the install less tedious with the colored screens and all that. Especially if all the functions work on it! I have been searching the internet and I cannot find nearly as many problems with the 970m as I could with the 770m, or am I just  not looking in the right places?
       
      Thanks a million!
    • By Max2016
      Help me Tech Inferno, you're my only hope.
       
      Ok so firstly, apologies for yet another 8 beeps thread. I must have read 100 of them over the last week. I feel like I'm missing something obvious, but I'm totally burned out after days of working on this so would appreciate some outside perspective.
       
      I live in the UK, so I've avoided buying a 980m to upgrade my 660 for years to due the price/import tax etc. I finally found a good priced 980m on Ebay a few weeks ago so I thought why not give my trusty 18x r2 a few extra years of life.
       
      I ordered the 100w heatsink, x bracket etc from Eurocom at the same time and everything arrived on the same day.
       
      Here's what I've done so far in the last 7 days:
       
      -Flashed unlocked A11 BIOS (I rolled back to Dell A11 first)
       
      -Removed  660m and installed 980m
       
      -With BIOS in Legacy, Installed Windows 7 on a new SSD with BIOS set to IGFX
       
      -Tried to switch to PEG but got 8 beeps so reset CMOS battery
       
      -Switched to SG and booted to Windows. 980m detected as default hardware. Installed 980m Driver from Eurocom and restarted. Device manager shows 980m  working normally along with HD Graphics 4000. Tried PEG again but still got 8 beeps
       
      -Reset battery, booted to Windows and disabled the 980m in Device Manager
       
      -Flashed VBIOS from here  (I read that the dell VBIOS doesn't work well so tried Clevo one first, but I've since tried both and a few others)
       
      -Re enabled 980m and restarted Laptop still in Legacy SG.
       
      -Tried to test a game but they only want to use HD Graphics 4000. When I try to open NVIDIA Control Panel and change some settings I get a blue screen and have to restart.
       
      -Tried PEG again, still 8 beeps
       
       
      I've tried many combinations of drivers, VBIOS and BIOS settings over the last week but the result is mostly the same. I get 8 beeps in PEG. I thought perhaps the seller had sent me a G-sync version as I have read these don't play well with PEG, but I checked the hardware ID (PCI\VEN_10DE&DEV_13D7&SUBSYS_05501028&REV_A1) and what I've read seems to indicate this is the Non G-Sync card.
       
      I got the 980m rather than the 1060 after reading the forums as I saw so many success stories I figured it would be the safer option.
       
      I understand this laptop is basically dead to most of you now, but if any techsperts are around and could give me some other things to try I'd greatly appreciate it.
       
       
      Thank you,
       
      Max










    • By Seolly
      I have several questions on upgrading my M18X R2.
      My rig's GPU is 680m and video ram is 2GB. It's a relic :p So I will change it to 980m.
       
      1. Is it working on windows 7? (If it works, legacy or UEFI mode?)
      2. Is 980m /w G-sync compatible with my rig? 
      3. Are there any compatibility issues with M18X R2 and Windows 10? 
       
      I tried to find useful information far as I can do, but my English ability sucks :S
       
      Guys, please help me!
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.