Jump to content
EwinRacing Flash Series Gaming Chairs
GeSnow

Cannot Turn On My P370EM

Recommended Posts

It happened last Saturday. The screen turned black, but I could still hear the background music and system sound. I held the power button to turn it off, but not able to turn it on again since then. The symptoms are:

1. After push power button, I can turn on/off Caps Lock LED by pushing the Caps Lock key (I was told this is the sign of CPU passing its initial test???).

2. ~15 seconds later, all three fans are turning at max speed. The notebook starts beeping. After 22 long beeps (~ 1min), it automatically shut down.

 

I upgraded it to gtx 980m sli last month. I have tried different RAM/GPU sockets or just leave one RAM/GPU on, didn't work. I have also tried bios reset by pulling out the cord of the CMOS battery, didn't work either. 

 

I am guessing its the problem with the mobo. I really need your help!

 

Sorry for my language/grammar error. English is not my mother tongue ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.