Jump to content
Apologies for the spam Read more... ×
EwinRacing Flash Series Gaming Chairs
Sign in to follow this  
FinestOfZ

Alienware 17 R3 GTX 980m 4GB Unlocked vBios

Recommended Posts

Since a lot of weeks, I am looking on the Internet for a VBios for my Alienware 17 R3 GTX 980m 4GB.
But i found nothing. The Prema Site ist Down at this time.
Pleas Help to unlock my vBios.
Here is the file from my vBios: https://www.sendspace.com/file/an0dqv
GPU-Z Screenshot: https://www.sendspace.com/file/v9wd03
Sory for my bad English.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Lyency
      bonjour, je souhaiterai unlock mon bios A15 de mon alienware m17x r4 . pouvez vous m'aider?
      je possède l'unlock A14 est il compatible avec le bios A15?
    • By Axel de S
      Hello guys,
      I have a GT72VR 6RE with G-sync MSI Laptop. Sadly the GPU is partially dead (artefacts all over the screen, crashes, windows detecting a damaged hardware etc...).

      So I bought an other GTX1070 MXM on ebay, which was used in a Vortex G65 6RE before.
      Sadly, when I plug the new GPU in the laptop, the laptop screen stays completly off, but i can use the HDMI port. So i though that I would just have to flash the vbios to the one I was using on the GPU that died, but I couldn't because of a mismatch betwen the PCI Device ID.
      The new GPU ID is : 10DE 1BA1 - 1462 11AF and the previous GPU ID was :10DE 1BE1 - 1462 11AF
      Pretty close right? but the A1 and E1 variation are fcking everything up. I've read that 1BA1 is for non G-sync and 1BE1 is for G-sync. I've also read that the G-sync variation is not part of the card but is an external part no on the GPU board.

      So now I'm wondering what can I do : is there a way to force the vbios flash or to change the PCI ID ? I really need some help here. I'm no expert and I've try as much as I could. Maybe I need to do some vbios editing but I don't really know how to do it and what to do exactly to make this work.

      Thank you very much for your help guys
    • By learnfromit
      alienware 15 r2 970m with i7-6700hq vbios request so i can overclock and mess with voltage.

      BIOS version backup made with techpowerup GPU-z.

      GM204.rom
       
      or can someone re direct me to one already made that will work? all links i find are dead, thanks.

    • By Kunal Shrivastava
      Hi guys, I am the proud owner of a Clevo p775dm3-g notebook purchased from azom.systems (authorized Clevo reseller in India, Model rebranded as Azom Legion-17.3 inches). Here are my specs:

      Core i7 7700 (non-K version): undervolted by 110 mv and turbo boost disabled in BIOS- machine uses prema mod BIOS.
      GTX 1080: undervolted by 100 mv on all frequency steps using MSI afterburner voltage/frequency curve editor. clocks are untouched.
      16 GB DDR4: Cant remember clocks.
      1440p 120 Hz screen: No tinkering done to refresh rate.

      CPU has been delidded and repaste has been done on both CPU/GPU dies with gallium based TIM-Coolaboratory liquid ultra if I recall correctly.

      My issue is GPU hitting max temp limit of 90 degrees while playing DOOM and framerate drops from 110 avg to mid 60s-70s with horrible stuttering- this is thermal throttling for sure.

      System was running beautifully after repaste at 86 degrees max/ 77 degrees average at 100 percent fan speed. A month later I decided to see how much further I could push the system and ended up undervolting the CPU/GPU and RAM even further. The RAM undervolting part didnt work as well as I'd hoped, and I ended up resetting the BIOS to undo everything and reapply the previous setting (-110 for CPU with turbo boost disabled.) 

      I noticed that immediately after BIOS reset, both my CPU and GPU temps were 5-10 degrees higher even with the undervolt/underclock applied. Also, I think the fans were a bit louder before I reset the BIOS which leads me to believe that for some reason the fans are now capped at 80% max fan speed. There doesnt seem to be a fan speed selector in the BIOS or anywhere else so I cant say for sure whether this is a fan related issue or something else.Before the reset I could override the BIOS setting and set the fans to 100% by pressing fn+1, could I have done something to that setting after resetting the BIOS ? I dont think I have damaged the CPU or GPU as temps are holding fairly steady at 90-91 degrees and laptop doesn't shut down while gaming.

      If I have overlooked something or if anyone reading this has any solution help would be greatly appreciated.
      All settings/drivers/windows version/app version are exactly the same before and after BIOS reset.
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.