Jump to content
EwinRacing Flash Series Gaming Chairs
Bos Maior

Y510P Ultrabay Graphics Adapter Configuration Thread

Recommended Posts

Hey guys,

 

This is a thread for sharing what you have learned about configuring a graphics card using Gerald's Y510p Ultrabay Graphics Adapter. It was created to make it easier for new users to find the information they need to successfully configure and use the adapter on their computer. I consulted Gerald before creating this thread.

 

Please feel free to post information, insights and tips below.

 

The Y510P Graphics Adapter

 

What is it?

 

The Y510P Graphics Adapter is a card which will allow you to use a full-length PCIe desktop graphics card with a Lenovo Y410p or Y510p laptop. It plugs into the device's Ultrabay. This is the swappable device bay which is, for instance, used for the second NVIDIA card in Y510P SLI configurations.

Please be aware that the Y510P Graphics Adapter is currently only compatible with the Y410p and Y510p. It is not compatible, then, with the Y500 and other Lenovo or IBM laptops that feature an Ultrabay. The Y510P Graphics Adapter was developed by Gerald, a member of this forum.

 

 

What it needs to run - hardware

 

In addition to the Y410p/Y510p laptop itself, the Y510P Graphics Adapter requires a separate power supply unit (known also as a PSU) to provide the graphics card with electricity. An actual PCIe graphics card is, of course, also required.

 

If you are going to use the power supply unit to power the Graphics Adapter and the graphics card plugged into it only, a 450-watt unit will likely suffice, at least for current graphics cards. While graphics cards manufacturers may advise you to obtain a more powerful PSU, this is because the PSU would normally also be used to power other components, such as the hard drive and CPU. Note that the Radeon RX Vega 64 and R9 Fury X are exceptions to this rule, as they have been shown to draw close to 500 watts of power when they are under a lot of strain.

 

Please note that without further modifications only AMD graphics cards will work, due to checks that are carried out by the computer on startup. High_Voltage has made two mods which should allow you to use an NVDIA card with the Graphics Adapter: a BIOS mod and a hardware mod:

 

* Thread on the BIOS mod: https://www.techinferno.com/index.php?/forums/topic/12014-lenovo-y410py510p-bios-mod-to-enable-nvidia-egpu-support/

* Post on the hardware mod: https://www.techinferno.com/index.php?/forums/topic/9686-y510p-ultrabay-graphics-card/&do=findComment&comment=163854

 

Please be aware that flashing your BIOS is potentially dangerous, even if the BIOS you are installing is an official version. To minimise the risks, always back up your data first and make sure that your laptop is fully charged and connected to the electrical grid before you start the flashing process.

 

What it needs to run - software

 

Three versions of the Y510P Graphics Adapter exist:

 

* Version 1: this is the experimental version which Gerald originally posted about.

* Version 2: this is the version that Gerald sold in 2016 and part of 2017. It requires BIOS version 2.07 and Windows 10 to function. Earlier BIOS versions may also work.

* Version 3: this is the version Gerald is selling at the moment of writing. Thanks to a discovery first posted to the forums by user David 'Soap' Washington, it should work with any BIOS version, as long as one uses an AMD graphics card rather than an NVIDIA one. It may also work Windows 7, 8 and 8.1, in addition to Windows 10. I am currently using this version of the adapter with Windows 10, using BIOS version 3.08.

 

Videos on installing and using the Y510P Graphics Adapter

 

Note that these videos only illustrate the installation process and performance with AMD cards.

 

* Installing the adapter:

 

- By Tesla: a general introduction on Version 2 of the adapter and how to install it: https://www.youtube.com/watch?v=KL7muHXsAmI

- By ManyStrongWords/Go'Vic Gaming: a video on installing Version 2 of the adapter: https://www.youtube.com/watch?v=4pviqwFRDn4

 

* Gameplay/performance:

 

- By Tesla: using an AMD RX 470 with the adapter: https://www.youtube.com/watch?v=SqdDeZ0UCgc

- By me: using an AMD Vega 56 with the adapter: https://www.youtube.com/watch?v=PVbsib8eHRg&t=25s

 

Other useful videos

 

* Removing the Y510P Ultrabay, by Someone7089: https://www.youtube.com/watch?v=tYcVlaMV0Ig

 

 

Example of a configuration using the adapter

 

My own configuration consists of the following:

 

* Lenovo Y510P with an Intel Core i7-4700MQ CPU, 16 GB RAM and an Intel SSD hard drive;

* iiyama G-Master GB2888UHSU 4K monitor;

* Gerald's Ultrabay Graphics Adapter, version 3;

* AMD RX Vega 56 graphics card;

* Corsair 450W PSU;

* OS: Windows 10 Creators' Update.

 

Below is an overview of the steps I had to take to get this configuration to run well on an existing Windows 10 Creators Update install. Note that when I installed a fresh copy of the Fall Creators Update, Windows automatically recognised my hardware, monitor included, and I did not have to disable the other graphics adapters. I do find I sometimes have to reinstall the graphics drivers, as updates in AMD' s driver package sometimes result in The Witcher 3 crashing when a cutscene is played.

*****
 

In order to get my configuration to run well on an existing Windows 10 Creators Update install, I had to do the following:

 

* Run the monitor at its native resolution.

* Install the appropriate driver for the monitor, instead of the generic one provided by Microsoft.

* Disable both the NVIDIA GeForce GT 755M and the Intel HD Graphics 4600 display adapters in the device manager.

Note 1: removing the drivers for your Intel and NVIDIA display adapters is unnecessary. It is also likely to be futile as, ultimately, Windows may reinstall the driver even if you disable automatic driver updates.

 

Note 2: an HDMI connection with your monitor should work just fine without you disabling the Intel HD Graphics 4600. A Displayport connection, however, will probably only work as intended if you do disable the Intel display adapter. If you do not do this, Windows will completely duplicate the video output displayed on the internal monitor on the external monitor, including the internal monitor's resolution. Note that this is not the ordinary 'duplicate screens' feature as there is no way to disable it until the Intal graphics adapter is disabled.

 

A Displayport connection is generally preferable since most Freesync-capable monitors do not support Freesync over HDMI. Also, AMD cards usually do not output colour depths over 8bpc over HDMI connections.

 

Note 3: should you find that the backlighting of the internal monitor remains on even though only the external monitor is active, all you have to do is press the FN and F2 keys at the same time. This will switch off the internal monitor.

 

 

Edited by Bos Maior
  • Thumbs Up 3

Share this post


Link to post
Share on other sites
On 10/27/2017 at 7:50 PM, Bos Maior said:

Hey guys,

 

This is a thread for sharing what you have learned about configuring a graphics card using Gerald's Y510p Ultrabay Graphics Adapter. It was created to make it easier for new users to find the information they need to successfully configure and use the adapter on their computer. I consulted Gerald before creating this thread.

 

Please feel free to post information, insights and tips below.

 

The Y510P Graphics Adapter

 

What is it?

 

The Y510P Graphics Adapter is a card which will allow you to use a full-length PCIe desktop graphics card with a Lenovo Y410p or Y510p laptop. It plugs into the device's Ultrabay. This is the swappable device bay which is, for instance, used for the second NVIDIA card in Y510P SLI configurations.

Please be aware that the Y510P Graphics Card is only compatible with the Y410p and Y510p. It is not compatible, then, with the Y500 and other Lenovo or IBM laptops that feature an Ultrabay. The Y510P Graphics Card was developed by Gerald, a member of this forum.

 

What it needs to run - hardware

 

In addition to the Y410p/Y510p laptop itself, the Y510P Graphics Adapter requires a separate power supply unit (known also as a PSU) to provide the graphics card with electricity. An actual PCIe graphics card is, of course, also required. Please note that only AMD graphics cards will work, seemingly because features of the Y510P embedded controller prevent NVIDIA cards from working as intended.

 

If you are going to use the power supply unit to power the Graphics Adapter and the graphics card plugged into it only, a 450-watt unit should suffice, at least for current graphics cards. While graphics cards manufacturers may advise you to obtain a more powerful PSU, this is because the PSU would normally also be used to power other components, such as the hard drive and CPU. Note that the Radeon RX Vega 64 and R9 Fury X are exceptions to this rule, as they have been shown to draw close to 500 watts of power when they are under a lot of strain.

 

What it needs to run - software

 

Three versions of the Y510P Graphics Adapter exist:

 

* Version 1: this is the experimental version which Gerald originally posted about.

* Version 2: this is the version that Gerald sold in 2016 and part of 2017. It requires BIOS version 2.07 and Windows 10 to function. Earlier BIOS versions may also work.

* Version 3: this is the version Gerald is selling at the moment of writing. Thanks to a discovery first posted to the forums by user David 'Soap' Washington, it should work with any BIOS version. It may also work Windows 7, 8 and 8.1, in addition to Windows 10. I am currently using this version of the adapter with Windows 10, using BIOS version 3.07.

 

Videos on installing and using the Y510P Graphics Adapter

 

* Installing the adapter:

 

- By Tesla: a general introduction on Version 2 of the adapter and how to install it: https://www.youtube.com/watch?v=KL7muHXsAmI

- By ManyStrongWords/Go'Vic Gaming: a video on installing Version 2 of the adapter: https://www.youtube.com/watch?v=4pviqwFRDn4

 

* Gameplay/performance:

 

- By Tesla: using an AMD RX 470 with the adapter: https://www.youtube.com/watch?v=SqdDeZ0UCgc

- By me: using an AMD Vega 56 with the adapter: https://www.youtube.com/watch?v=PVbsib8eHRg&t=25s

 

Other useful videos

 

* Removing the Y510P Ultrabay, by Someone7089: https://www.youtube.com/watch?v=tYcVlaMV0Ig

 

 

Example of a configuration using the adapter

 

My own configuration consists of the following:

 

* Lenovo Y510P with an Intel Core i7-4700MQ CPU, 16 GB RAM and an Intel SSD hard drive;

* iiyama G-Master GB2888UHSU 4K monitor;

* Gerald's Ultrabay Graphics Adapter, version 3;

* AMD RX Vega 56 graphics card;

* Corsair 450W PSU;

* OS: Windows 10 Creators' Update.

 

In order to get this configuration to run well on an existing Windows 10 Creators Update install, I had to do the following:

 

* Run the monitor at its native resolution. It appears that the current drivers for this card have difficulty repeatedly switching between resolutions.

* Install the appropriate driver for the monitor, instead of the generic one provided by Microsoft.

* Disable both the NVIDIA GeForce GT 755M and the Intel HD Graphics 4600 display adapters in the device manager.

Note 1: removing the drivers for your Intel and NVIDIA display adapters is unnecessary. It is also likely to be futile as, ultimately, Windows may reinstall the driver even if you disable automatic driver updates.

 

Note 2: an HDMI connection with your monitor should work just fine without you disabling the Intel HD Graphics 4600. A Displayport connection, however, will probably only work as intended if you do disable the Intel display adapter. If you do not do this, Windows will completely duplicate the video output displayed on the internal monitor on the external monitor, including the internal monitor's resolution. Note that this is not the ordinary 'duplicate screens' feature as there is no way to disable it until the Intal graphics adapter is disabled.

 

A Displayport connection is generally preferable since most Freesync-capable monitors do not support Freesync over HDMI. Also, AMD cards usually do not output colour depths over 8bpc over HDMI connections.

 

Note 3: should you find that the backlighting of the internal monitor remains on even though only the external monitor is active, all you have to do is press the FN and F2 keys at the same time. This will switch off the internal monitor.

 

The above instructions may no longer apply. When I installed a fresh copy of the Fall Creators Update, Windows automatically recognised my hardware, monitor included, and I did not have to disable the other graphics adapters.

 

Great information here, @Bos Maior. Thanks for starting this separate thread, great idea!

Share this post


Link to post
Share on other sites

Does anyone know where it is possible to buy this ultrabay slot nowadays? Bought the laptop a few years ago and even then couldt I find anything without buying from ebay (no way ill do that)

Share this post


Link to post
Share on other sites

I am not sure what you mean. The Y410P and Y510P simply come with this slot - it is part of the machine. Gerald's adapter plugs into the slot, and allows you to use AMD graphics cards designed for ordinary desktops, rather than laptops.

Share this post


Link to post
Share on other sites

First post updated to reflect the fact that solutions allowing one to use NVIDIA cards with the adapter have now been found.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By qamar198
      Hello Everyone,

      I am trying my Sager NP 9377 to get to work but to no avail. NO POST, NO DISPLAY.
      in short>> powering on laptop causes fans to run at full speed after 10(cpu only) + 10 (now both cpu+gpu) with Caps Lock + Num Lock + Scroll Lock LEDs blinking, continuous 1 second beep, repeats for one minute with 1 second in between, then laptop shuts down.

      IN DETAIL
      System Specs are i7 4810mq 8gb gtx 880m SLI variant (though my laptop has other GPU Slot empty so only singular 880m running) 120 Hz display.

      The Problem
      > if i take out the battery and plug in AC only, the power light comes on ORANGE
      if both battery is connected, then i have both power and battery light ORANGE
      and if only battery is connected then of course laptop is waiting for me to press the power button
      but in all 3 cases the following happens
      > Pressing the power button brings laptop to some signs of life, power LED turns green, both the CPU and GPU fans have a very quick jerk but does not spin., keyboard lights up with Blue Backlight (dont know if this is relevant or not), HDD activity light starts to blink showing HDD access maybe (even when hdd is removed)
      > Display remains blank (i dont even sense the display backlight being on)
      > HDD activity light sometimes goes off after only 1-2 seconds, sometimes shows rapid blinking/activity for 4-5 seconds
      > both fans remain off (i removed back cover to check this)
      > after about 10 seconds or so, the CPU fan spins up (speed is normal, just like when using the laptop in IDLE)
      > after 10 more seconds have passed, the CPU fan seems to be turning off for a split second then both the CPU and GPU fan turn on full speed with a lot of noise.
      > Caps Lock, Num Lock and Scroll Lock LEDs all blink together with single beep for about 1 second, repeats beep with 1 second in between.
      > goes on for about 1 minute then laptop shuts down.
      > forcing the fans to spin down using FN+1 key makes them spin back up to full speed after a split second (dont even know why i tried this one -_-)

      What I Have Tried So Far
      > EC and Bios Reset (take out battery, disconnect AC Adapter, disconnect CMOS Battery, Press Power Button for upto 30 seconds)
      > Change Ram and check all available slots
      change/remove HDD
      > Repaste CPU/GPU and clean out fans
      > Checked GPU...... Flashed the 880m in this Sager with MSI vBios and tested it in a MSI Gt70 2PC i have, gpu ran fine, tested with FurMark, AC Odessey, Ghost Recon Wildlands for over an hour (unfortunately the cooling in my MSI is not good enough it already runs hot, and this 880m causes thermal throttling as well as power limit throttling sometimes). Reflash 880m with original Clevo vBios and put back into the Sager, still no boot, same results as before.
      > Checked the CPU..........checked the 4810mq in the MSI GT 70 which worked fine, as well as tried the 4810mq from the MSI in the Sager, still no boot.
      > Suspected bad GPU fan connection......therefore forced both fans to full speed as soon as i press power button (using FN+1 Keys) and both fans turn on full speed, same results.
      > tried charging the battery to the max before turning on on battery only, same results.

      >>------- The laptop has had some random shutdowns in the past too during gaming but would turn back on fine after waiting for 10 mins or so, then i sold it to some guy who brought it back to me the next day saying that it just turned off during gaming and wont turn back on, i returned his money, did all the troubleshooting above to no avail. then i finally put it aside to wait until i get some other system in which i can test the CPU and GPU.
      Then one day i turned it on (after leaving it untouched for a couple months), same results as above, i decided to try once without battery and it Freakin Turned ON!!!, used it for a couple days without battery, played a few games (thermal throttling was observed here and there), but then this happened again and this time it seems permanent . And now i have not only repeated all the steps above but this time also checked the CPU and GPU in the MSI GT70 too. ------------<<


      Some Observations
      > touching the CPU heat pipes feels warm, but the GPU heat pipes are colder (GPU never even booted?). dont know if this is normal or not.
      > i replaced one of the capacitors near the CPU once, but i did use the laptop for quite a while after that without any issues.
      > my Idle temps were always below 40c for both CPU and GPU, so an overheat warning as soon as laptop is powered on seems unlikely (false overheat warning?, but GPU does not even seem to be detected/ booted as heat pipes remain cold to touch), also i repasted the CPU and GPU multiple times.
      > The guy who sold me the laptop told me that the power adapter was originally a Dell, and it was modified to use with this Sager by replacing the cable with a 4-Pin one from a Toshiba (same pinout as the Sager), but then again i have used this laptop for quite a while on the same adapter.
      > From day 1 of having this laptop, some keys on the keyboard (w, s, t, c and numpad 4) did not work 99% of the time. pressing really hard on any one of them sometimes made ALL of them work for a while. any thoughts on this issue?? (even if its unrelated).

      So what seems to be the issue here?
      GPU not detected ?, False temperature alert?, Bad fan?.
      Any help towards resolving this will be greatly appreciated.
      Thanks in advance .
    • By Donz7733
      I am planning to get this Charger (170w 20v 8.5a) - https://www.amazon.in/Lenovo-ThinkPad-4X20E50574-170W-AC/dp/B00MLTQ99Y
      &
      the Adapter - https://www.aliexpress.com/item/32975526334.html?spm=a2g0o.productlist.0.0.27cb747e6TEc28&algo_pvid=a7db42d0-97cb-4a37-be7a-d19c44bddf73&algo_expid=a7db42d0-97cb-4a37-be7a-d19c44bddf73-0&btsid=8d6ee0f9-08e9-4474-b63b-cc751403b4c7&ws_ab_test=searchweb0_0,searchweb201602_,searchweb201603_60
       
      Will this combination work to run Both GT755m of Y510p?
       
       
      Thanks
       
    • By adam.jakey
      Hey Everyone. I'm looking through the forums and found out that I can make my old Lenovo a Hackintosh. Is it worth doing? Can you dual boot Windows 10 and OS10? 
    • By aBug
      Hello Everyone!
       
      I have problem with VBIOS/EEPROM(?) after installing of a GTX1060 N17E-G1-A1 GPU NVIDIA Graphics Chipset (old one has temp. damages). 
       
      I  modified new 416  and old 391 nvmii.inf file and try to install drivers, but every combination gave me no success. There is only yellow triangle in  Windows Device Manager :|
      Is there a way to bring my card to life?
       
    • By Kel
      I got the exp gdc beast 8.5 got all the connections right... laptop boots up... fans turn on the gpu.... device manager detects gtx 1060 with a “ ! “ in a yellow triangle. Now what to do.... i tried to do the bios mod.... but realised that i have 3.07 version. 
      Questions-
      1 is there any way to get this done without the mod?? 
      2 if mod is the only way... kindly help me with step by step instruction in laymans terms... i m not a techy... so i might not understand technical terms.... altho i am interested... but learning yet. Please help. 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.