Jump to content
Review: E-Win Champion Series Gaming Chair Read more... ×
EwinRacing Flash Series Gaming Chairs
Natebluehooves

attempting to do a m15x 880m gpu upgrade...

Recommended Posts

Hi guys! I just recently got a used m15x (with a  gt240m gpu...) and have swapped it out for a gtx880m (msi) which is not working currently. I have updated the bios to a09, and then installed the unlocked a09 bios to unlock all options to make sure something there wasn't to blame.

 

The laptop boots and gets to windows just fine if you're plugged into a monitor via VGA, but windows does not recognize the gpu or let you install drivers for the card. Additionally, if a monitor is not plugged in the laptop screen goes white and emits one very loud beep every few minutes. Aside from this, the laptop behaves as expected. I'm having trouble finding any support online regarding this issue and was hoping that somebody here could give me a bit of a pointer on where I should look to next.

 

as a side note, forgot to add that I originally purchased the card after finding a list of people showing off benchmark scores for different cards in the m15x, one of which was the 880m, which could be purchased cheaply online. I'm currently looking into how to flash vBIOS as it was mentioned in one of the few posts I could find on the subject, but am waiting to hear if this is the right course of action. thanks in advance for any assistance you can provide!

Share this post


Link to post
Share on other sites

SUCCESS!

 

so I hope that this is helpful to somebody in the future, but I figured it out on my own and want to possibly save somebody some heartache in the future. The card ended up working fine as soon as i flashed the DELL vbios onto the card, which was an MSI. 

 

The card is now working and all I had to do was modify the .inf file for the driver to install it. 100% working. only issue now is I need to get hold of you guys' vbios collection because there's a modded one there that allows for overclocking. i'll be paying to upgrade my account and grabbing that now. thanks guys, and if anyone else has issues with this card let me know in pm. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Consumerofmulch
      Hello!
       
      I have recently acquired my Dell Inspiron 15 7000, and I am interested in building an egpu setup for it. It has a USB-C port. Any recommendations/guides out there?
       
      thanks.
    • By TechDrago
      Hi,
       
      I am having some heat issues with the GTX 680m I installed on my Alienware M17x R2 (yes, its old).  Having installed and ran HWiNFO64, it appears that the maximum rpm of the GPU fan is 2560rpm, even when the GPU reached a maximum of 93° Celsius.  The rpm seems low, but what is the maximum rpm of the fan, does anyone have any ideas?
       
      Thanks
       
    • By Soapy
      I reversed the input polarity on my m15x jack after a botched psu repair. Computer worked fine, but overall power control is messed up. System only boot on both battery and psu, no battery charge, and a very low battery drain (arround 6wh).
       
      I aways had battery issues whith my 8 years old m15x after my original battery died. Bought a new one two years ago, didn't work. Checked on upower, basically no info on manufacturer, power or history. So i refunded and used the system hooked on the psu as usual. In August i bought a new one, worked flawlessly for a day. The next day the battery died from nowere. Checked upower, bus was ok, battery was charging extremely slowly (6wh), history showed subpar disharge before shutting down. I got mad at this point, decided that psu was to blame. Opened it, checked everything, noticed some wear on the male jack. Resoldered it, connected on computer. Nothing happened, so i checked the voltage. That's when i realised that i screwed up big time. I swaped the positive and negative wires. Decided that one mistake was enough, so i sent my m15x to a trusted repair shop (latter found that they just hooked the battery and gave me back as soon as it booted, they didnt even open it). Got my pc a week later, but the battery didn't charge . Worse, it was slowly discharging (same 6wh as before), and it needed both the psu and the battery to turn on. At 65%, it worked as usual for my college semester, but the battery is dead, and so is my computer. I bellieve i burned some voltage controller or something. I'm pretty competent at soldering thing's (evem smd components) when i know what to do, and i can understand simple circuit's, but when i got my hands on the m15x datasheet i got overblown. I cant make heads or tails about it. I aways lurked this forum and i bellieve your guys are the best when it comes to finding creative solutions to technical problems concerning microelectronics. I followed a guide in this forum as a teenager to upgrade this same computer to a gtx680m, overclocked stuff, got custom bios, and had a lot of fun learning. The m15x is a deprecated platform, but it's a part of my history that i dont want to let go.
      So please guys, help me.
       
    • By Lyency
      bonjour, je souhaiterai unlock mon bios A15 de mon alienware m17x r4 . pouvez vous m'aider?
      je possède l'unlock A14 est il compatible avec le bios A15?
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.