Jump to content
Jacco

eGPU not detected anymore after driver change

Recommended Posts

Hi all,

 

I have an Acer v3-571G (BIOS v2.21) laptop with integrated 710M and HD4000 graphics running Windows 10 64-bit. I've been running an eGPU setup succesfully for the past year now with a MSI GTX970 and an EXP GDC Beast adapter, both powered by a 600W Zalman ATX PSU. It worked perfectly for a year, but a few weeks ago I was messing with the graphics drivers to solve a minor brightness problem on my laptop, and my PC isn't detecting the eGPU anymore. When I was messing with the drivers the eGPU was disconnected and the Wifi-card works in the exact same mPCIe slot, so I'm pretty sure it's a software problem.

 

Things I have tried so far:

- Try A LOT of drivers (Intel Management Engine, nVidia Graphics, Intel Graphics, Acer PCIe etc.)
- Replace mPCIe to HDMI cable
- Hotplugging from sleep
- Paperclip in ATX motherboard plug to power it up before PC
- Change EXP GDC's jumper settings
- BIOS's secure boot off
(- Legacy BIOS will not detect any OS, so couldn't test this)

 

There is literally no sign of the eGPU in Device Manager, and plugging a USB in the EXP GDC does nothing as well. I'm almost 100% sure the eGPU is connected properly, since it worked perfectly for over a year, and it powers on (fans, lights) when the PC is booted.

 

Any ideas? Any suggestions/ advice is greatly appreciated!

 

Best regards,
Jacco

Share this post


Link to post
Share on other sites

Try to remove the PCIe Root Ports from device manager, even the Root Complex. Your os will probably freeze or keyboard/mouse not working after this but just reboot and windows will detect all the devices again.

If you don't want to do that then open them one by one and check the Bios name under the details tab and figure out whitch one is for your egpu => delete only that then reboot.

Edited by Doink

Share this post


Link to post
Share on other sites

Tried that, it installed all the PCI drivers again but still didn't recognize the eGPU. I found that Ubuntu can't find it as well, so I'm going to start searching for hardware problems even though that's weird since it worked before...

 

(Attached is a screenshot of Ubuntu's results when i use the lspci command)

 

Screenshot from 2017-03-13 07-52-07.png

Edited by Jacco

Share this post


Link to post
Share on other sites

I solved it! Reseated the GPU and all the plugs and the eGPU got detected again. Aforementioned use of the lspci command on a Ubuntu USB stick convinced me that it was a hardware issue and greatly narrowed down the search.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.