Jump to content
Apologies for the spam Read more... ×
EwinRacing Flash Series Gaming Chairs
Sign in to follow this  
surya kumar

Windows update: Microsoft – WPD – 2/22/2016 12:00:00 AM – 5.2.5326.4762

Recommended Posts

Microsoft has released on March 8, 2017 another mysterious update ‘Microsoft – WPD – 2/22/2016 12:00:00 AM – 5.2.5326.4762’ for  Windows 7, 8,1, 10. Some users are reporting issues with mobile devices after installing this update. Here are a few details.

The abbreviation WPD stands for Microsoft Windows Portable Devices. WPD drivers enables the communication with connected mobile devices and storage media. WPD driver should exchange Windows Media Device Manager (WMDM) and Windows Image Acquisition (WIA) drivers for mobile devices and scanners.

Currently I haven’t found details about that update on Microsoft’s web pages. At TenForums is a longer discussion about this package. Weighting the experiences with previous INTEL driver updates, my recommendation is, to block installation of this package. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Seolly
      I have several questions on upgrading my M18X R2.
      My rig's GPU is 680m and video ram is 2GB. It's a relic :p So I will change it to 980m.
       
      1. Is it working on windows 7? (If it works, legacy or UEFI mode?)
      2. Is 980m /w G-sync compatible with my rig? 
      3. Are there any compatibility issues with M18X R2 and Windows 10? 
       
      I tried to find useful information far as I can do, but my English ability sucks :S
       
      Guys, please help me!
    • By Mivas
      Hi! I registered for the specific topic. So, the big question for which I found no answer in internet.
       
      Windows 7 on Intel Core 8th generation.
       
      Officially, Intel supports windows 7 up to 6th generation. Unofficially, with an easy trick up to 7th generation. The question is, how can we make it work on 8th generation?
       
      I installed windows 7 Ultimate 64bit on my new DELL Inspiron 5770 high end non-gaming 17 inch laptop, without any issue apart from the integrated GPU (Intel UHD Graphics 620). This also blocks the functionality of the AMD Graphics card too.
       
      So, since for many reasons I want to have windows 7 instead of windows 10 or Linux, I did my best but I got stuck. I created a hybrid driver from 2 different versions of official Intel drivers, the latest, which supports this iGPU, but only on Windows 10 and the last windows 7 compatible, which does not include support for the specific 8th gen processor/graphics card, since it is newer. I mixed some files and also edited the inf file from the old driver.
       
      I will share with you what I did, so that someone who has knowledge might get 100% functionality. I get only partial.
       
      So, here is my guide.
       
      1. Download the last Win7 compatible driver from Intel for HD Graphics. It is the version win64_15.45.19.4678
      2. Download a newer version which is win10 only but contains the driver for your processor. In my case, Intel Core i7 8550U with DEV_5917. I downloaded the latest driver.
      3. Make copies/backup of both folders and save elsewhere before starting editing.
      4. Unzip both. From the unzipped ones, go to the new driver folder, then Graphics, then copy all components and paste in the Graphics folder of the old (15.45.19.4678) version. Note; So far in my case I didn't play a role if I replaced the same names of the old files with the new ones or skipped them to keep the old ones. Exception; do NOT replace the igdlh64.inf file and the igdumdim32.dll
      5. Find the DEV number of the processor. Device Manager (from Control panel or search), right click on generic VGA Adapter, properties, details, ID.
      6. Open the igdlh64 file (with a notepad) from the new version (Graphics folder) find the DEV number under windows 10 and copy the whole line.
      7. Paste it under the Windows 7 section in the igdlh64 file of the old driver and correct the ikbl win10 with iskl win7 (known trick for 7th gen).
      8. Copy all lines that include the 4-digit number from the igdlh64 file from the new driver and paste in the respective sections of the igdlh64 of old driver. In the end of the text, also add the name of the driver as a label, eg Intel UHD Graphics 620.
      9. Install the modified old driver (win64_15.45.19.4678) and reboot.
      10. After reboot. Copy the igdumdim32.dll file from the Graphics folder of the new version and paste it to the C:\Windows\SysWOW64 replace the existing files
       
      This way, I get all resolutions, full brightness, colour, contrast etc control of the display, intel graphics control panel, full windows 7 effects (aero glass etc), but I dont actually get video support (apart from 3rd party software, like VLC/GOM player which even play 4K video smoothly), 3d applications are not functional, I dont get hardware acceleration etc. I concluded that the solution is to edit the igdumdim32.dll file, so that I copy elements from the new version to the old one. This way, theoretically, it should work. Anyone who has experience with driver and dll modification???
       
    • By Mivas
      Hi! I registered for the specific topic. So, the big question for which I found no answer in internet.
       
      Windows 7 on Intel Core 8th generation.
       
      Officially, Intel supports windows 7 up to 6th generation. Unofficially, with an easy trick up to 7th generation. The question is, how can we make it work on 8th generation?
       
      I installed windows 7 Ultimate 64bit on my new DELL Inspiron 5770 high end non-gaming 17 inch laptop, without any issue apart from the integrated GPU (Intel UHD Graphics 620). This also blocks the functionality of the AMD Graphics card too.
       
      So, since for many reasons I want to have windows 7 instead of windows 10 or Linux, I did my best but I got stuck. I created a hybrid driver from 2 different versions of official Intel drivers, the latest, which supports this iGPU, but only on Windows 10 and the last windows 7 compatible, which does not include support for the specific 8th gen processor/graphics card, since it is newer. I mixed some files and also edited the inf file from the old driver.
       
      I will share with you what I did, so that someone who has knowledge might get 100% functionality. I get only partial.
       
      So, here is my guide.
       
      1. Download the last Win7 compatible driver from Intel for HD Graphics. It is the version win64_15.45.19.4678
      2. Download a newer version which is win10 only but contains the driver for your processor. In my case, Intel Core i7 8550U with DEV_5917. I downloaded the latest driver.
      3. Make copies/backup of both folders and save elsewhere before starting editing.
      4. Unzip both. From the unzipped ones, go to the new driver folder, then Graphics, then copy all components and paste in the Graphics folder of the old (15.45.19.4678) version. Note; So far in my case I didn't play a role if I replaced the same names of the old files with the new ones or skipped them to keep the old ones. Exception; do NOT replace the igdlh64.inf file and the igdumdim32.dll
      5. Find the DEV number of the processor. Device Manager (from Control panel or search), right click on generic VGA Adapter, properties, details, ID.
      6. Open the igdlh64 file (with a notepad) from the new version (Graphics folder) find the DEV number under windows 10 and copy the whole line.
      7. Paste it under the Windows 7 section in the igdlh64 file of the old driver and correct the ikbl win10 with iskl win7 (known trick for 7th gen).
      8. Copy all lines that include the 4-digit number from the igdlh64 file from the new driver and paste in the respective sections of the igdlh64 of old driver. In the end of the text, also add the name of the driver as a label, eg Intel UHD Graphics 620.
      9. Install the modified old driver (win64_15.45.19.4678) and reboot.
      10. After reboot. Copy the igdumdim32.dll file from the Graphics folder of the new version and paste it to the C:\Windows\SysWOW64 replace the existing files
       
      This way, I get all resolutions, full brightness, colour, contrast etc control of the display, intel graphics control panel, full windows 7 effects (aero glass etc), but I dont actually get video support (apart from 3rd party software, like VLC/GOM player which even play 4K video smoothly), 3d applications are not functional, I dont get hardware acceleration etc. I concluded that the solution is to edit the igdumdim32.dll file, so that I copy elements from the new version to the old one. This way, theoretically, it should work. Anyone who has experience with driver and dll modification???
       
    • By TechAce
      Hello, I need help trying to put my setup to work. I recently purchased an Akitio Thunder 2 with a GTX 1050 ti Superclocked to implement it as an eGPU for my system. I have a Macbook Pro 15” mid 2012. I’m not interested in using it with OS X (I’ve read that there is not much support by Apple for Nvidia cards Series 10). My main goal is to use it using Windows 8.1. I had some trouble with the initial connection as Windows recognized the external card but it gave me error code 12. I already got rid of the error 12 problem. The situation now is that I connected a second display through the HDMI port of the eGPU and activated it using the Nvidia Control Panel. After a restart I choose to boot windows 8.1 again but the two displays get hanged with black screens and I only see the cursor. Anybody has had this problem and was able to fix it?
       
      I did some further testing, decided to boot up with the eGPU connected but without the HDMI cable plugged. I was able to log in to Windows and the eGPU got recognized in device manager, but then I connected the HDMI cable and for one second I saw my Macbook screen displayed in the external monitor, then both screens hanged again with black screens only showing the cursor. I’m exhausted of experimenting and seeing no positive results...
       
      My goal is to be able to use the eGPU with the internal monitor of the Macbook (if that is possible with my system). If not, I would like to know how I can set it to work with a second display. I will be very grateful if somebody can help me... Sorry for the long post.
       
       
    • By SenikTheFasthog
      Good day,

      I am the owner of a used m18x r2 struggling to build it back up into a functional machine. The previous user had his system installed in RAID mode which won't suffice for my desired SSD boot speeds. I've ensured that both AHCI and UEFI are active in the A11 BIOS. I have also ensured to clean the main drive via diskpart CMD upon custom installing my copy of Win 7 Ultimate. Oddly enough, when the setup completes, I'll get an error message stating windows can't finish configuring and needs to restart. Heeding this message will only cause it to happen again on the next reboot, so CMD to the rescue and creating and off to making user account I go. Unfortunately, boot speeds are as slow as ever and I've verified that no RAID controllers have been left installed in the device manager. So far, my only potential lead is that I've noticed during each boot, Windows mentions that "Setup Is Updating Registry Settings" after about of minute of Starting Windows. I've been researching this exact string but I can't say I've found a concrete solution to attempt just yet.

      So here I am, requesting for advice as to what I should check next.

      Thanks in advance!

      EDIT: I've tried out a new install accessing the CD through legacy but still keeping the SDD Boot drive on UEFI mode. So far haven't had to mess with CMD anymore to proceed nor has the Setup needed to Update Registry Settings. I also remembered to install the intel rapid storage driver.  Alas, I'm still left with 2 minute boot times(particularly on the Starting Windows screen), so the problem still remains.

      EDIT2: Diagnosing with a Boot Manager, I discovered it takes about a minute before svchost even starts running. So with that, I ruled out it wasn't a software problem. I then decided on the possibility that maybe the other drives could be interfering with booting. Pulling out the other HDDs had no effect, but the actual culprit was the mSATA SSD that was left in from the last user. Now I can enter windows in 3 seconds!

      Even fishier, this mSATA drive says its 32 GB but Speccy says its a 1GB drive. But that's a problem for another time, at last my 850 EVO is showing off its expecting speeds.
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.