Jump to content
EwinRacing Flash Series Gaming Chairs
yugioh

Lenovo Z510 Black screen when switched on (no bios access/no lenovo logo)

Recommended Posts

Hello, 

 

Lenovo system update installed an update. Also my wifi was unstable so I downloaded the official intel update tool and tried to install the new driver for the wifi. The intel driver installer tried to install the new driver but it was unsuccessful and said reboot required before installing the driver, I rebooted the Z510. Then after reboot it automatically went to the bios. and I exited not saving the changes. 

... and black screen.

I don't even get the lenovo logo. NOVO button cause black screen too.

What I have done: 

- opening the laptop and unplugging the battery and holding the power button for 15 second and turning it on with AC adapter

- changing the ram 

- removing the hard drive

- replacing the laptop monitor with another 

- plugging external monitor and try it 

 

not luck :( 

Also, when I turn it on I noticed that the backlight of the screen blinks approximately every 2 seconds, as if it is some kind of corrupted boot loop. 

 

please help me I am student and I need my computer and I do not have money to buy a new one at the moment :(

 

If you need more information please don't hesitate to ask,

I really appreciate your help,

 

Edited by yugioh

Share this post


Link to post
Share on other sites

I don't have a Lenovo z510, but I decided to download a bios for it from the Lenovo website and used the Phoenix tool to find a bios recovery name for the z510 bios. I'm pretty sure the bios name you would have to use for a recovery is "Zx10X64.fd".

 

I had a similar problem on my Y500, and I did this:

I can't imagine that a bios recovery for a Lenovo z510 would be that much different. Perhaps the actual steps for a bios recovery on a z510 are little different, but maybe they aren't. But I'm pretty sure the right file name to use, if you have the appropriate bios, is "Zx10X64.fd".

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Anderitos135
      I have a iBuypower CZ-17 laptop, with a 2012 AMI BIOS that has E1762 as the version, which I believe means I have an MSI G70 motherboard. It has a 675MX GPU, but it's not useable in Windows 10 despite being "seen" in the device manager. I believe an updated, unlocked BIOS would fix my issue and have located the thread on this site with the BIOS I need.

      First of all, am I right? Will this fresh BIOS make my laptop that originally ran Windows 8 work with this old GPU?

      And second, I created this account, will wait 24 hours and made this post. Is that enough to allow me to download the file, or do I need to post elsewhere?

      Thanks!
    • By Zoarilamb
      A part of my BIOS got corrupted that controls my laptops backlights. Other methods like the Gary Key fix did not work for me because I do not get any light up during post. i followed this guide  that says I need to extract and use the 6MB portion of an 8MB bios dump, only AFUWIN tells me "Error, ROM file size does not match existing BIOS size which is because my laptop BIOS size is only 5.87MB.  I don't need to flash the whole BIOS, I only need to flash a portion of it. 
       
      I've searched everywhere online for a dump of my laptop model but non exist that I know of.
    • By Zoarilamb
      I fiddled around with modding my laptops BIOS to unlock XMP profiles and hopefully seeing if optimus could be disabled. After flashing my modded bios and trying it out, I noticed that my keyboards backlight no longer turns on. I was unaware it requires an official BIOS to function. They backlights wont turn on unless ASUS ATK package is installed but now it seems it also needs an official BIOS?
       
      The modded ROM and tool I used if anyone has any experience with this and doesn't mind telling me what to enable/disable, or anything else i can do to re-enable them 
        
    • By mrwayne
      My laptop is Monster Tulpar T7 v2.6. i7 4710MQ, 16 GB DDR3 1600 mHZ, GTX 970M 3GB.
    • By sam@83
      Hello !
      I tried a tutorial on the forum to remove the supervisor password on a X260 thinkpad but the winbond 25Q128FVPQ chip is not recognized with the programmer CH341A and ASprogramer (does not detect automatically and not manually). Plugged into the motherboard with a soic8.

      Can you help me with detection?
      Can I find the password with the software or do I have to write it?
       
      Thank you so much !!!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.