Jump to content
EwinRacing Flash Series Gaming Chairs
Seeker

Help please, how to connect egpu?

Recommended Posts

Hello guys i have asus a556uq with the following interfaces:
1 x VGA Interface / Mini D-sub 15-pin external display support
1 x Audio Interface (input / output Combo)
2 x USB 3.0 Interface
1 x USB 2.0 Interface
1 x Ethernet (RJ-45) Connector
1 x HDMI Interface

How i can connect my egpu?

Share this post


Link to post
Share on other sites

You need to put it directly onto your motherboard. Look for a mini PCI slot. Similar to an M.2 sata port.

Sent from my E6853 using Tapatalk

Share this post


Link to post
Share on other sites
Read before posting.



Some of these external GPUs require connecting to the motherboard of the laptop. As they don't have the USB adapter because they are usually the cheaper ones.

Sent from my E6853 using Tapatalk

Share this post


Link to post
Share on other sites

most of the enclosures you're going to find will be either thunderbolt, msata, and i've seen a small number of expresscard solutions, though i've not tested those. your best bet is going to be msata. likely just taking your wireless card out and using that slot. this will leave you with a ribbon cable going from inside your laptop to the egpu. hope you figure it out!

Share this post


Link to post
Share on other sites

It's 99% possible. 1st you have to check what version of pcie your laptop have (mPCIe or NGFF). Then you have to buy accordingly the egpu adapter (mPCIe to PCIe x1 or NGFF to PCIe x1) that fits in your laptop. Also, in most cases you need to power your gpu with external PSU, so be sure to have one. You can simply search on youtube how to connect this setup.

Now...the important stuff: Many laptops have whitelist on their bios pcie connection but in many cases they don't. Also if you have intel cpu with gpu on it and dedicated gpu like nvidia or amd, you have to disable the dedicated gpu from bios settings. If you don't have dedicated gpu, you don't have to worry, just connect the egpu set up on your mpcie or ngff slot and reboot. In some rare cases, you will not have the option to disable the dedicated gpu from bios settings, in that case you just disable it from windows device manager.

Hope that helps.

Edited by Bill.gr
  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.