Jump to content
EwinRacing Flash Series Gaming Chairs
[KOR]SeedLeSS

Quadro P5000 running on M17X R4

Recommended Posts

I got a single pcs of latest Pascal architecture Quadro P5000 based on GTX1070

Main difference is It has 16GB of VRAM.

 


[IMG]
As you can see, It is MXM3.0 B type board

[IMG]
[IMG]
[IMG]
[IMG]
 few more detail pictures for P5000

[IMG]
[IMG]
Compare with My GTX980M
Size is same and has similar layouts too.

[IMG]
Fit perfects with my M17X R4
I did upgrade my Heatsink with 3rows for CPU and 6rows for GPU for keep it cool.

[IMG]
Here is What Bios shows up.
I got Win10 64bit with EFI boots.
I tried with Single PEG but failed.
Seems Pascal only support eDP signal for screen.
I guess If I change to 3D screen, might works for Single PEG use. Update me If anybody has tips for this.

 

[IMG]

Here is How it shows out in Windows 10

[IMG]
As there is no official driver for P5000 for laptop's yet, most of information not shows out correct specs.
But as you cans see it has 16GB VRAM and 2048 shader units.

[IMG]
This is 3DMark Fire strikes for P5000
check for more details with this links : http://www.3dmark.com/fs/11422803

I did some of tests and decide to wait official driver come out from vendor's or nVIDIA.

It's not working 100% performance yet, but still can feel how powerful Graphics card it is.

Share this post


Link to post
Share on other sites

I have a M17X R4 and a M18X R2. I ordered one P5000 in Asia and get it hopefully before Christmas. ;)

 

Some question: How is the heat situation with the P5000? You mentioned that you update your CPU heatsink (3 tubes) and GPU heatsink (6 tubes). Where did you buy those? You wrote that the display port is not working with the P5000 or did I misunderstand? Because to work with external monitor is very important for me. That's why I ordered the P5000. I will sell my Lenovo W530 and want to use one of my Alienware for graphics work and gaming. 

 

#Edit: I misunderstood and read DP for display port but you mean eDP, the display connection of 120Hz FHD 3D displays. I got one in Germany for 90 bucks and will install this next week. First I will test it with GTX 1060 and then (wenn arriving) with P5000... I will keep you updated.

 

Has anybody experiences in installing the P5000 in Alienware M18X R2?

Edited by MessiWessi

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Confused Troll
      I have installed a 980m card in an M17x from early 2014 and am now here to ask the experts of this fine establishment if they can help with what needs to be done to get it to work, if at all possible.
       
      It tries to upgrade a shorted out 780m. Modded driver was installed (445.75 WHQL from 2020.3.23), but device manager says error 43.
       
      sBIOS is stock A17 from Dell. UEFI enabled, legacy and safe boot disabled.
       
      OS is Windows 10 Home 64-bit on an SSD.
       
      Can it be done at all? If it can, what needs be done?
       
      Edit:
      I think my model is actually 17 R1, judging by the date, processor being a 4th gen i7 (4700MQ) and also this matches my regulatory model.
      I know this is my only post here and in I come, asking for help, but... pretty please help?
       
      Further edit:
      I have identified the 980m as being a Dell version. (as per GPU-Z)
    • By Nospheratu
      This modification involves going a step further than a straight ID chip swap between the 240W and the 330W. The reason I chose this method was, I did not want to perform the mod again in the rare case that the 330W died and I had to get a new one.
      In order to complete this mod, you will require the following items.
      1. Dell 330W PSU (This PSU was built for the M18X and X51 product lines). Part Numbers: Y90RR / 5X3NX / F0K0N / XM3C3 / 331-2429
      2. Dell 240W PSU (Either a Flextronix or Delta). Part numbers: PA-9E / J938H / Y044M / U896K / J211H / Y044M
      3. Dell or HP standalone PSU cable/Connector. I used a right angle connector but any Dell/HP 7.4 x 5.0mm barrel connector will work.
      4. M17x/M18X Power Jack. The part number for this power jack seems to be P01E. Look for the one that resembles the one used here.
      5. Small PCB designed for a SOT-23 packaged chip. (If using the Flextronics 240W PSU).
      6. Small housing (Optional depending on whether you would like to mod the ferrite choke housing)
       
      PSU DISASSEMBLY
       
      First we begin with the disassembly of the 240W PSU to retrieve the ID chip for our adapter. Since I had the Flextronics version some of these steps might not be the same for the Delta PSU. We start by lifting up the rubber feet on the bottom of the 240W using your nail or a flat tool. Underneath each rubber foot you will find a screw which you can go ahead and unscrew.
       
       
      One of the screws will be a tamper-resistant Torx T10 type, the difference to a normal Torx T10 being a small pin the centre so you would have to use a Torx screwdriver with a hole in the center.
       
       
      TIP: If you do not have this tamper-resistant screwdriver you can use a normal Torx T10 screwdriver but you will have to hammer down the pin at the centre of the screw slightly in order to get the normal T10 screwdriver to grip.
       
      Once you have removed all screws you will have to pry open the casing. I stuck a thin knife between the power plug and the casing to gently pry it open.
       
       
      The top half and bottom half of the casing are held together by interlocking clips. Twist the case a bit to get them to unclip. Then remove the PSU from the case. You will then be presented with the first metal layer which is held on by tape. Cut the tape and slide out the first metal layer.
       
       
      You will then see the second metal layer which is held in place by 3 points soldered onto the PSU PCB. It is indicated in the picture below. Desolder all 3 points and remove the second metal layer.
       
       
      The last layer is black and seems to be a type of flexible hard plastic. It will be stuck in place by white thermal stuff on the PCB, simply lift it and peel it away.
       
       
      Depending on whether you have a Flextronics or Delta PSU your ID chip will look different.
       
       
      Desolder this chip and keep it in a safe place (If you lose it, you have to buy a new 240W PSU). On the Flextronix PSU the chip is also stuck in place apart from being soldered on, so you have to work quickly heating the solder and pushing the chip away with a bit of force.
      To reassemble the PSU reverse the above steps. You can still use this PSU connected to the adapter with your M17X so it won't be collecting dust.
       
      THE ADAPTER MOD
       
      You will have to decide on whether you want to mod the ferrite choke housing into your enclosure or use a dedicated enclosure (small as possible as this circuit is tiny). If you are using a dedicated enclosure jump straight to the labelled wire photo to continue. If you would like to mod the ferrite choke housing continue reading.
      I did not take sufficient pictures during this portion as I was unsure if the ferrite choke housing would work. The rubber around the ferrite choke and the connector that I purchased was soft and very flexible which made it easy to work with. I used a knife and pressed against the rubber of the ferrite choke housing for a clean cut so that I could glue it back together. I cut off one end and then length ways along either seam of the housing making sure to leave a bit of extra cable.
       
       
      Here is a picture of what we’re trying to achieve with the cutting.
       
       
      You will then see the ferrite choke which you can crack with a hammer. Remove the pieces (be careful as they will be very sharp).
       
       
      Then the cut off the cable strain relief that's covering the cable with small wire snips.
       
       
      You will then see the cable which you can strip to positive, negative and the ID line.
       
       
      You will then need to connect those wires to the power jack. The two pins at the top are negative. The two pins at the back forming the shape of a U are positive and the pin at the back in the centre is the ID line.
       
       
      Solder the positive wire to positive pin and negative wire to negative pins as shown in the image below. The negative wire can be soldered to the negative pins and simultaneously joining the ID pin on the jack.
       
      The reason behind joining the ID pin to the negative pins on the jack is because we need to ground the ID line coming from the 330W in order for it to operate beyond its artificial 240W limit.
       
       
      Now all that’s left to do is connect the ID chip. If you have the Flextronics PSU the ID chip will be in a SOT-23 package and the Delta ID chip will be in a TO-92 package. The Flextronics SOT-23 package is difficult to work with and should be first soldered to a bit of PCB that had a SOT-23 package so that you do not break the legs off.
      I initially soldered the wires directly to the legs and moving it about in my "enclosure" to find the best spot to place it was too much stress on the chips tiny legs and they broke off... yes, all of them. Luckily I could still see a tiny bit of metal from each of the legs. I managed to salvage it by soldering it to a piece of PCB that I jacked from a broken mouse which had SOT-23 connections.
      The blue ID wire coming from the cable needs to be soldered to the data leg of the ID chip. Connect the remaining two pins from the ID Chip together and then to the negative connection on the PSU jack.
       
      Dont judge my pathetic soldering skills!
       
      Place your ID chip into the enclosure and test the adapter to make sure all your connections have proper contact. If it’s working properly you can close it up.
       

       

       
      I considered flooding the enclosure with silicone to secure the ID chip and its connections but I did not, as I thought it would be more work if one of the connections broke and I had to open it up again. You can do it if you like.
       
      I used a drill to make the hole at the centre of the disc large enough for the 330W connector tip fit through. I then stuck the enclosure back together using superglue along the sides and then attaching the disc. Add a bit of glue to the disc/jack so that the disc and jack are stuck together as well. This is so that the jack does not move when plugging the PSU connector tip in.
       
      THE COMPLETED MOD
       

       
      Pros/Cons over the ID Chip swap Mod
      Pros
      - Allows you to use any PSU irrespective of wattage as long as the connector tip is compatible with the power jack.
      - If the 330W PSU dies all you have to do is plug a new one in. No need to perform the mod on a new 330W.
      - No need to open up the 330W at all.
      - Your ID chip donor 240W PSU can still be used with your M17X by attaching this adapter.
      Cons
      - Allows you to use any PSU irrespective of wattage as long as the connector tip is compatible with the power jack (Could be dangerous with low wattage PSU's).
      - A lot more work compared to swapping the chips.
       
      Notes: I also had to trim a bit of rubber at the right angle connector for the cable I used as it’s a bit of a tight fit if you don't. The rubber around the connector did get a warm at the right angle after testing but it's being blasted by the heat of the CPU fan continuously so I don't think it’s the connector itself that's causing it. These cables are very short and should be able to handle the power easily.
      Since there are two positive terminals you will have to either split the positive wire coming from the PSU connector to each pin or join both pins (bend one pin over to the other and solder them together making sure to place an insulator to cover the ID pin) and solder the positive wire to a single point.
      Also worth noting is that this adapter mimics the original 240W adapter perfectly. So if you experienced the "plugged in, not charging" issue when connected this adapter will not resolve it (I still have to pop the battery and clip it back in to resolve).
       
      Credits: @imsolidstate, without his in-depth investigation this would have not been possible. His website detailing his investigation and the ID chip transplant can be found here and the subsequent update here.
       
      DISCLAIMER: Perform this modification at your own risk. I take no responsibility for any damage caused by technical error, user inexperience or stupidity.
    • By AllanGeorgia
      Hi guys,
       
      Hope someone is able to help me. I bought a Dell Quadro K3100m card (the only mxm card I could find in my area). The card itself works (I was able to bypass post lockup by bridging the bios pins on the card) but the vrom on the card is not compatible with the card itself. I tried using other bios versions but they don't seem compatible. Does anyone have a stock rom for vbios version 80.04.FE.00.09? (Apologies if I posted in the wrong place - new to the forums).
       
      Your help would be greatly appreciated!!
    • By yoshomiamoto
      Hello Fellow Tech Gurus!

      I am having a huge headache after upgrading the ram memory of my m17x r3. 

      First let me start by saying I have been experiencing issues with my current ram setup recently, and so i decided to replace the ram inside of my computer, thinking they had gone out on me. It originally came with x4 2gb memory sticks, and as I started to experience issue, I started to removed them, and I was down to 1 2gb stick. It seems to me ram slots 1 & 2 are not working properly as when I put ram memory into them I would get BSOD in 5-10 mins of computer usage after boot. So I am thinking the slots have gone out. I also tested each slot individually and still same effect.

      So I went on the try out slots 3 & 4 under the keyboard, which seems to work just fine when I use only 1 ram chip in one or the other. But the problem occurs when I try and fill both ram slots in slots 3 & 4 under the keyboard with crucial 2x 8 gb of ram sticks, which total to 16gb total ram memory.

      BSOD and freezing occurs like crazy. But if I use just one of the ram sticks in either slot, no problem.

      I dunno if this is hardware or software. I am think that my motherboard is on its way out the door, but any suggestions you all have would be great. I have already clean installed win 7, and is currently running bios A10 (unlocked, I believe)

      I would also like to note that my motherboards internal vga is not detected, and just noticed this a few days ago upon trying to figure out the ram situation.

      other issues is my laptop battery is pretty much dead, and the only for my computer to cut on is if the AC adapter is connected

      I would also like to know can 1x 16gb 1600 ram stick run in my computer? or is it not supported by my motherboard? 

      thanks!

      Specs:

      Alienware M17xR3 (2011 3D FHD ed)

      Service Tag:
      30W75Q1

      Bios ver:
      A10 (should be unlocked)


      Operating System
      Microsoft Windows 7 Home Premium (64-bit)

      Processor
      Intel® Core™ i7-2960XM CPU @ 2.70GHz

      Chipset
      Intel® 6 Series/C200 Series Chipset Family

      Graphics
      Nvidia GTX 680m

      Audio
      IDT High Definition Audio CODEC
      High Definition Audio Device

      Networking and I/O
      DW1501 Wireless-N WLAN Half-Mini Card
      Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20)
      HMA TAP-Windows Adapter V9

      Memory
      Crucial 8 GB (x2 qty) DDR3 PC3-12800 • CL=11 • Unbuffered • NON-ECC • DDR3-1600 • 1.35V • 1024Meg x 64 •

      (these only work under bay 3 or 4, but not dual 8gb at the same time, otherwise BSOD)

      Configuration ID:
      CT3283724

      Storage
      WDC WDBNCE5000PNC SSD (installed into bay 0)
    • By MessiWessi
      Hi,
       
      I bought a alienware m17x r4 a few weeks ago. The problem is: I have noise (distorsion) on the right speaker. Had anybody in past the same problem and is it a known problem regarding this model? I feared at the beginning that the soundblaster is defect but I tested it with headphones and everything is fine. I already ordered a new speaker pair and will install it within the next weeks.
       
      But if you tell me that this problem is known and not resolvable I can save my effort.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.