Jump to content
Review: E-Win Champion Series Gaming Chair Read more... ×
EwinRacing Flash Series Gaming Chairs
Sign in to follow this  
Sergey Litomin

EXP GDC not working with 2GB + of RAM on a lenovo b590

Recommended Posts

I recently bought a EXP GDC adapter v8.4d for lenovo b590 but it only works if my laptop is 2GB RAM. I can't get it to work on my laptop if it is connected to 8 GB of RAM. When i turn on the laptop with 8GB of RAM with the connected adapter and external graphics card laptop turns on with black screen. In the BIOS it is also not possible to go. I've tried all methods found on this forum, but was not able to solve the problem with the black screen. Please somebody can help me. Sorry for my English I write through the Google translator

 

Laptop lenovo b590

Windows 7 Ultimate x64

8Gb RAM (2x4)

Core i5 3230m

iGPU  Intel HD 4000

dGPU Geforce 610m (disabled in BIOS)

SSD Kingston 120Gb

EXP GDC 8.4d with mPCIe cable

Power Dell D220P-01

eGPU Palit Geforce GTX 1050

 

Whitelist BIOS removed. Ways to cope with a black screen, which I found on this forum did not help

 

 

 

 

Edited by Sergey Litomin

Share this post


Link to post
Share on other sites

Hey,

 

A while back I've had the same problems with my own setup (while trying to set up a x2 link).  IMO, this has something to do with the TOLUD size of your PC and that it doesnt want to accept your card properly.

 

I've posted my solution a while back in the notebookreview forums, Im reposting here now (btw, this method helped me achieve the x2 link with the hwtool EGPU adapter PE4C 2.1, if anyone is interested, since I kinda lazyied it out :) ) ORIGINAL LINK: http://forum.notebookreview.com/threads/diy-egpu-experiences.418851/page-1192#post-10105268

 

Quote
Well, the problem might be that there might be no space left for the eGPU. Personally, I havent had any experience with eGPU vs dGPU situations, you should look up this forum or other places for the solutions. 

BTW, if you noticed, I have been ranting here about my problems with 2GB ram issues (that my eGPU works with 2GB and I also want 8GB). During my tests, I've noticed, that when with 2GB ram, the TOLUD value lowers, somehow freeing up much much more space for other PCI devices (went from 256 MB to 1 GB free PCI space). I think the same is happening here with your PC.

Just yesterday, Ive solved my problems compating my PCI devices to 36-bit space and forcing my eGPU to a 32-bit space. Aparently, this free'd up 512 MB of PCI space on my laptop = eGPU success. I believe the same soliution might work for you (or any other PCI compation) (btw, I did this without DSDT override). This method requiers you having setup 1.3, which provides the mentioned compation and also dGPU disable-type functions, which may also help.
 

 

Quote

As I understand, Windows has the eGPU graphics drivers installed, right?
If so, try this thing:
 

  1. Boot to windows without the eGPU connected
  2. Uninstall the eGPU drivers (via show hidden devices in device manager; you can keep the installation files)
  3. Shut down
  4. Now boot to your Windows with your eGPU connected.

Now, there is chance that this method could work, but only if the booting is successful, when the drivers are uninstalled. Once booted, the eGPU will not work, because there are no drivers, right? Right. So check the device manager if the eGPU is detected. If so, it should automatically start installing the missing drivers on its own. Now here comes the messy part.

5. Once the drivers are installed and the eGPU is detected fully (doesnt matter if its wokring correctly or with errors, such as 12 or 42, 43), disable the driver and try each method below until something works:
5.1 Reboot with the eGPU connected to your PC and the drivers disabled. Once booted into Windows, enable the drivers.
5.2 Reboot with the eGPU connected to your PC and boot to setup 1.3. Take note of how much TOLUD you have and how much free space you have. If lower than 256 MB, perform PCI compaction (I am not sure which one would work, check setup FAQ for that). Personally, the 56.12GB - 36-bit compaction worked for me (chose all PCI devices, force 32-bit upon eGPU). Chainload to Windows. As said above, the eGPU driver should be turned off, to once booted into Windows (if successful), enable the eGPU driver.

 

Share this post


Link to post
Share on other sites
Posted (edited)

I have same problem with my lenovo b590.egpu work only 2gb ram.i want to run it 6gb ram with nvidia 710.plzz help me. I have setup 3.5 but i am not able configure it.i don't know how i can use tell me 

Edited by Waqar

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.