Jump to content
EwinRacing Flash Series Gaming Chairs
J95

[Alienware - Clevo - MSI] Aftermarket Upgrades Driver Support - Modded INF

Recommended Posts

Few weeks ago I realised Nvidia have stopped the driver support for my  card (680M) and some games that require newer drivers simply wont run.

After some searching online I came across a couple of good instructions how to mod the .inf file and make it install on your syste.

In general every driver you download from Nvidia (provided it's for your type of card e.g. GTX, and OS) is pretty much the same, the difference is in the .inf file where the instructions are for the specific card and OS. Here are the links, very easy to follow and do. Use the tables from the video as I'm not sure how dated are the tables from the first link (maybe they are the same though). Just as a note your device ID and GPU string can be found from within your PC, it's just require some extra steps.

 

https://forums.guru3d.com/threads/nvidia-inf-driver-modding-guide.377158/

 

 

Hope it helps anybody.

 

Share this post


Link to post
Share on other sites

If manuf or nvidia stopped driver support or driver installation fail, install latest driver from manuf website and update once with Windows Update. Download latest notebook drivers from NVIDIA, extract setup and edit nv_disp.inf to add  your device from this list https://raw.githubusercontent.com/CHEF-KOCH/nVidia-modded-Inf/master/Inf/Mobile/391.35/nv_dispi.inf

 

Example. NVIDIA_DEV.13D8 = "NVIDIA GeForce GTX 970M"

 

[NVIDIA_Devices.NTamd64.10.0...17098]
%NVIDIA_DEV.13D8% = win10amobile,       PCI\VEN_10DE&DEV_13D8

Share this post


Link to post
Share on other sites

The Link is dead sir? I have alienware m17x rx4 and I upgraded it to GTX 860M What should I do Its not detecting. though. I install nvdia driver but its not working it says not compatible 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Yomaster
      Hello, 
       
      some of my computer specs are as follows: 
      CPU: I9-9900k
      GPU: RTX 2070
      memory: 32 GB (forget the manufacturer/ clocks)
      Dsanke bios mod
       
       
       I recently bought a 1440p screen that is 120hz capable, but it does not allow me to select the 120hz option. I have checked numerous places and all of the websites say that this screen is 120hz enabled. I have the dsanke bios mod on my computer. I see people being able to use this screen's 120hz functionality, but I can't get it to work. Any suggestions? If you need any additional information about my laptop, I will be happy to provide info.
       
    • By Miyagi1007
      Hello guys so i bought a used alienware m17x r3 with hd 6870m on it, so when i was trying to boot well it goes to the windows 7 loading screen that says starting windows after that the screen turns white and goes to bsod saying atikmpag.sys
       
      also i attempt to switch my integrated gpu to my discrete card ( hd6870m)  and i wont switch at all 
       
      Responses are highly appreciated 
      Thank you in advance
    • By blancaster
      does anyone know why a vbios file  8mb in size for nvidia k80 , myu backup bios is only 256kb
    • By IveGotRoot
      I have recently upgraded my laptop(an M6800 firepro 6100) and replaced it with an GTX 980m. Nvidia says that the latest driver(461) supports my card but i can only install up to 388.13 Ive tried to mod it but i can't figure it out. I can run the latest linux driver tho
    • By Freddyicy
      I have spent a little time in the past few days looking around this site. I would love for someone to point me in the right direction to a forum that has information that could help me out with my problem.
       
      I have a:
       
      Alienware M17XR3 
      Windows 7 Home Premium 64-bit
      Intel I7-2820QM 2.3
      Bios InsydeH20 Version 1.0 A12
      NVIDIA GeForce GTX 460M
      (4x) 4 GB Ram
      samsung 2.5" 256 SSD (SATA3.0Gbps)
       
      It has been an amazing machine for the last 10+ years. Minor issues, nothing that an Alien Respawn could not fix, till now! On battery power it works just perfect.  Then I plug it in and it's all OK until I try to do anything, and then the screen goes white. The screen sometimes goes yellow, sometimes blue, but mostly white screen. It will do nothing until I do a hard reset (holding the power button till it turns off and turn it back on) with the power unplugged.  If the power is not unplugged then it will go through boot up to windows swirling dots then go white again. If I plug it in and do nothing I can charge it, unplug and continue what i was doing. I have tried a lot of solutions bouncing around the internet, and thought I was having a DC Jack connection issue (replaced the ac/dc power adapter, then the motherboard). I get a better connection now but with the same white screen result. I stumbled into this forum and I'm hoping to find solutions to my issues.  Then upgrade like so many others have.
       
      Any ideas, comments or suggestions welcome.
       
      Thank you in advance!
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.