Jump to content
EwinRacing Flash Series Gaming Chairs
J95

[Alienware - Clevo - MSI] Aftermarket Upgrades Driver Support - Modded INF

Recommended Posts

   GeForce 382.05 WHQL

 

   Game Ready
      •Provides the optimal gaming experience for Prey, Battlezone, and the Gears of War 4 Multi-GPU Update.


    Added or updated the following SLI profiles:
      •Sniper: Ghost Warrior 3
      •Warhammer 40,000: Dawn of War III

    Added or updated the following 3DV profiles:
      •Warhammer 40,000: Dawn of War III - Not recommended

    Changes and Fixed Issues in Version 382.05
      •[SLI][No Man’s Sky - with The Foundation Update 1.10 patch]: With SLI enabled, there is texture corruption in the game. [200257478]
      •[SLI][GeForce GTX 670][World of Tanks]: In SLI mode, blue-screen crash occurs when pressing Alt+Tab during the game. [1895732]]
      •[GeForce GTX 1080 Ti][Gears of War]: After the bootup movies, blue-screen crash occurs pointing to nvlddmkm.sys. [1914184]
      •The NVIDIA Control Panel in the Windows desktop context menu, as well as the NVIDIA system tray icon, may be absent. [200298863/1906498]
      •System may hang at a black screen upon cold boot up. [1913854]
      •In a multi-display configuration, the extended displays are unable to enter sleep mode. [1902053]

      *Install drivers at your own risk* Windows 10 + GeForce Drivers are Killing Samsung and LG Notebook LCD Display Panels
       Uninstall PrecisionX, including screen overclocking tools. Instead, keep MSI Afterburner's RTSS for monitoring purposes.

 

       900M Requirements:

       Flash latest @Prema's v2 980M & 970M (Please consider donating to Prema)


  • Win10/8.1 'F8' Boot options 'Safe Mode' & 'Disable driver Signing'
    cmd (Admin)
bcdedit /set {default} bootmenupolicy legacy

 

        -> reboot -> F8 -> select 'Disable Driver Signature Enforcement' -> Install drivers

  • Run DDU "Clean & Shutdown (Safe Mode)
  • Extract driver using 7-Zip
  • Display.Driver folder,  copy/overwrite the proper .inf file(s).
  • Extracted driver package >> delete the folders as shown below (don't skip this step)  -> run setup.exe  

       >>> Keep these folders only <<<

373.06.PNG

 

 

    INF MOD v382.05

Alienware: nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4) excluding AW 2015 - GTX 980 , 980M , 970M , 965M , 880M , 870M , 860M , 780M , 770M , 765M , 680M , 675MX , 670MX , 660M.

Clevo & MSI non-Optimus models: nv_dispi.inf (including nvcvi.inf & nvmii.inf )

 

nvcvi.inf: Optimus Alienware 17 / 05AA (only) GTX 980M - 970M - 965M

nvcvi.inf: Clevo P170EM Optimus 980M/970M

  

  GeForce 382.05 Win7/8.1

  GeForce 382.05 Win10

 

Alienware

nv_dispi.inf_v382.05_Win7_8.1_PEG_Dedicated_Alienware.zip

nvcvi.inf_v382.05_Win7_8.1_Optimus_Alienware_17.zip

 

nv_dispi.inf_v382.05_Win10_PEG_Dedicated_Alienware.zip

nvcvi.inf_v382.05_Win10_Optimus_Alienware_17.zip

 

Clevo & MSI Laptops (non-Optimus)

nv_dispi.inf_v382.05_Win7_8.1_PEG_Dedicated_CLEVO_MSI.zip

nv_dispi.inf_v382.05_Win10_PEG_Dedicated_CLEVO_MSI.zip

 

 

AW 900M Throttling workarounds:

M18xR2

First, flash @Swick1981 [Bios Mod] M18xR2 - Legacy Support now Available 

M18xR2 980M workaround

 

Hibernation method HERE and HERE

 

 

Please use the SEARCH function to see if your question has been answered/posted already.

 

https://www.techinferno.com/index.php?/announcement/4-user-account-promotion-rules-read-before-posting/

 

@jaug1337 for that model try out "PEG" Clevo/MSI nv_dispi.inf, just copy both nv_dispi.inf & nvmii.inf (MSI).

  • Thumbs Up 5

Share this post


Link to post
Share on other sites

Will this modded inf work on a Clevo P150EM with an 980m? There is mention of the P170EM on the instructions but no file with that model to download.

Thanks

Share this post


Link to post
Share on other sites
7 minutes ago, sslmm said:

Will this modded inf work on a Clevo P150EM with an 980m? There is mention of the P170EM on the instructions but no file with that model to download.

Thanks

nvci.inf from the clevo version of the download should work. but someone correct me if Im wrong.

Share this post


Link to post
Share on other sites
On 05/05/2017 at 4:10 PM, j3tstream said:

nvci.inf from the clevo version of the download should work. but someone correct me if Im wrong.

But the clevo version on download says "non-optimus", and p150em (like p170em) have optimus (one of the big problems with this new drivers). 

Tried with the alieware optimus INF and it didn't work :/

Share this post


Link to post
Share on other sites
3 hours ago, sslmm said:

But the clevo version on download says "non-optimus", and p150em (like p170em) have optimus (one of the big problems with this new drivers). 

Tried with the alieware optimus INF and it didn't work :/

I just updated my drivers and yes is the clevo ones, you can trust. It works for p170em should work for p150em. If it doesnt you need to find the hardware device id and post it here and maybe J can include it for your laptop in the next inf's.  Mine didn't work either until I posted my IDs.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
On 5/5/2017 at 7:06 AM, sslmm said:

Will this modded inf work on a Clevo P150EM with an 980m? There is mention of the P170EM on the instructions but no file with that model to download.

Thanks

Not included...please post a GPU-Z screenshot w/ device IDs.

 

Screenshot (118).png

 

10DE = Nvidia

161A = 980N (G-Sync)

1558 = Clevo

0871 = P870DM-G

Share this post


Link to post
Share on other sites

Is there a video on how to install these modded drivers? Also I can't download some of the files since ima noob. Do I need all of the files here? Thank you.

Share this post


Link to post
Share on other sites
On 06/05/2017 at 10:57 PM, J95 said:

Not included...please post a GPU-Z screenshot w/ device IDs.

 

Screenshot (118).png

 

10DE = Nvidia

161A = 980N (G-Sync)

1558 = Clevo

0871 = P870DM-G

With the modded inf of clevo (non-optimu) it worked and everything seems do work fine, except the context menu where i could choose the GPU to use with some programs...nothing major as i can do that manually on the nvidia control panel.

Thanks for all the help.

Heres my GPU-Z screenshot to add the p150em to the device list if anyone wants it:

 

gpu.gif

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
5 hours ago, sslmm said:

With the modded inf of clevo (non-optimu) it worked and everything seems do work fine, except the context menu where i could choose the GPU to use with some programs...nothing major as i can do that manually on the nvidia control panel.

Thanks for all the help.

Heres my GPU-Z screenshot to add the p150em to the device list if anyone wants it:

 

gpu.gif

Here you go *nvcvi.inf*, like the P170EM I'll add P150EM from now on.

 

nvcvi.inf_v382.05_Win7_8.1_P170EM_P150EM_GTX980M_970M.zip

nvcvi.inf_v382.05_Win10_P170EM_P150EM_GTX980M_970M.zip

 

 

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
1 hour ago, J95 said:

Here you go *nvcvi.inf*, like the P170EM I'll add P150EM from now on.

 

nvcvi.inf_v382.05_Win7_8.1_P170EM_P150EM_GTX980M_970M.zip

nvcvi.inf_v382.05_Win10_P170EM_P150EM_GTX980M_970M.zip

 

 

THANK YOU!

 

Everything appears to work now (as with old INF mod) but the Context Menu reappeard now :)
Going to test on my windows 10 partition to see if everything goes well there too.

Will you implement this infs in the next drivers for now on? It would help us a lot (i spent nights trying to mod the infs but with every new version it seems to change here and there :/ )

Thank you again

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
6 hours ago, sslmm said:

THANK YOU!

 

Everything appears to work now (as with old INF mod) but the Context Menu reappeard now :)
Going to test on my windows 10 partition to see if everything goes well there too.

Will you implement this infs in the next drivers for now on? It would help us a lot (i spent nights trying to mod the infs but with every new version it seems to change here and there :/ )

Thank you again

Yep, I will include the P150EM.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
5 minutes ago, J95 said:

Yep, I will include the P150EM.

Thank you so much! :)

By the way, tested on windows 10 and everything works fine once again!

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hello!
Can I install a GTX 1060 MXM in a my P150EM?

Share this post


Link to post
Share on other sites

      900M Requirements:

       Flash latest @Prema's v2 980M & 970M (Please consider donating to Prema)

 

What happens if I try to flash the old SVL7 VBios with this driver? Black screens? I wanted to try some 1.000V instead of actual Prema's 1.062v bios to see if somewhat improves cooling performance.

Share this post


Link to post
Share on other sites

      900M Requirements:

       Flash latest @Prema's v2 980M & 970M (Please consider donating to Prema)

 

What happens if I try to flash the old SVL7 VBios with this driver? Black screens? I wanted to try some 1.000V instead of actual Prema's 1.062v bios to see if somewhat improves cooling performance.


Black screen because nvidia changed something in the drivers a few years ago.

Sent from my SM-T560NU using Tapatalk

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

 

GeForce Hotfix driver 382.19

 

  •This hotfix resolves a stutter issue experienced on some configurations while playing Prey


      *Install drivers at your own risk* Windows 10 + GeForce Drivers are Killing Samsung and LG Notebook LCD Display Panels
       Uninstall PrecisionX, including screen overclocking tools. Instead, keep MSI Afterburner's RTSS for monitoring purposes.

 

       900M Requirements:

       Flash latest @Prema's v2 980M & 970M (Please consider donating to Prema)


  • Win10/8.1 'F8' Boot options 'Safe Mode' & 'Disable driver Signing'
    cmd (Admin)
bcdedit /set {default} bootmenupolicy legacy

 

        -> reboot -> F8 -> select 'Disable Driver Signature Enforcement' -> Install drivers

  • Run DDU "Clean & Shutdown (Safe Mode)
  • Extract driver using 7-Zip
  • Display.Driver folder,  copy/overwrite the proper .inf file(s).
  • Extracted driver package >> delete the folders as shown below (don't skip this step)  -> run setup.exe  

       >>> Keep these folders only <<<

373.06.PNG

 

 

    INF MOD v382.19

Alienware: nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4) excluding AW 2015 - GTX 980 , 980M , 970M , 965M , 880M , 870M , 860M , 780M , 770M , 765M , 680M , 675MX , 670MX , 660M.

Clevo & MSI non-Optimus models: nv_dispi.inf (including nvcvi.inf & nvmii.inf )

 

nvcvi.inf: Optimus Alienware 17 / 05AA (only) GTX 980M - 970M - 965M

nvcvi.inf: Clevo P170EM / P150EM *Optimus* 980M - 970M

  

    GeForce 382.19 Win10

 

Alienware

nv_dispi.inf_v382.19_Win10_PEG_Dedicated_Alienware.zip

nvcvi.inf_v382.19_Win10_Optimus_Alienware_17.zip

 

Clevo & MSI Laptops (non-Optimus)

nv_dispi.inf_v382.19_Win10_PEG_Dedicated_CLEVO_MSI.zip

 

 

AW 900M Throttling workarounds:

M18xR2

First, flash @Swick1981 [Bios Mod] M18xR2 - Legacy Support now Available 

M18xR2 980M workaround

 

Hibernation method HERE and HERE

 

 

Please use the SEARCH function to see if your question has been answered/posted already.

 

https://www.techinferno.com/index.php?/announcement/4-user-account-promotion-rules-read-before-posting/

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

@J95 382.33 are out:

 

http://us.download.nvidia.com/Windows/382.33/382.33-win10-win8-win7-notebook-release-notes.pdf

 

Desktop:
Download 64 Bits (Windows 10)
Download 32 Bits (Windows 10)
Download 64 Bits (Windows 8.1, Windows 8, Windows 7, Windows Vista)
Download 32 Bits (Windows 8.1, Windows 8, Windows 7, Windows Vista)

 

Quote

Feature Highlights of Nvidia Geforce 382.33:
 

Game Ready Drivers provide the best possible gaming experience for all major new
releases, including Virtual Reality games. Prior to a new title launching, our driver team
is working up until the last minute to ensure every performance tweak and bug fix is
included for the best gameplay on day one.
  • Game Ready - Provides the optimal gaming experience for Tekken 7 and Star Trek Bridge Crew.
  • Application SLI:
    Added or updated the following SLI profiles:
    • None
  • 3D Vision Profiles :
    Added or updated the following 3DV profiles:
    • Tekken 7 - Fair
  • 3D Compatibility Mode Profiles :
    Added or updated the following compatibility mode profiles:
    • None

Fixed Issues:

 

  • [TITAN X][3D Vision][Windows 10 Creator’s Update]: The Windows Store does not open when 3D Vision is enabled. [1906805]
  • [GeForce GTX 1080Ti][Prey 2]: Stuttering occurs during gameplay. [1902201]
  • [GeForce GTX 1070][Windows 10 Creator’s Update]: In multi-display mode, extended monitors cannot be be put into sleep mode. [1916554]
  • [GeForce GTX 1060]: Blue-screen crash occurs pointing to driver (Nvlddmkm.sys) after the system reboots from sleep mode. [1814559]
  • [GeForce GTX 970][SLI]: SLI cannot be enable unless Norton 360 is disabled or Windows is booted in Safe Mode. [1919094]


Known Issues

 

  • Windows 10:
    • [DirectX 11 games]: On some titles, in-game V-Sync does not work if Fast Sync is selected from the NVIDIA Control Panel. Consequently, the game frame rate is not locked to the maximum refresh rate, resulting in possible tearing. [200304603]
    • [SteamVR titles]: SteamVR may crash when launched. [1917936]
    • [Power DVD 17]: The display may go blank while playing HDR video in exclusive full-screen mode. [200300818]
    • [GeForce GTX 1070]: Games (Witcher 3, For Honor) do not recognize the custom refresh rates set using the NVIDIA Control Panel. [1916598]
    • [SLI][GeForce GTX 1080][Battlefield 1 XP1]: With SLI enabled, corruption appears in the game when switching between full-screen and windowed mode. [1889162]
    • [GeForce GTX 1080 Ti][Mass Effect: Andromeda]: Random memory errors may occur when playing the game. [1887520]
    • [GeForce GTX 1080 Ti][Sid Meier's Civilization VI][G-Sync/SLI/DirectX 12]: Black
      corruption appears while entering the in-game menu after skipping the cutscene.
      [200283322]
    • [Notebook][GeForce GTX 970M][Tom Clancy's The Division Survival DLC]: Game
      crashes, pointing to ntdll.dll when changed to full-screen and to windowed fullscreen.
      [200252894]
    • [Notebook][GeForce GTX 970M][ShadowPlay][For Honor]: The game silently may crash if the intro video is skipped while instant replay is on. [200247313]
    • [SLI][Notebook][GeForce GTX 970M][Gears of War 4]: Level loading may hang. [1826307]
    • NVIDIA Control Panel custom color settings are reset to the default after switching a game between windowed and full-screen mode. [1917071]
    • NVIDIA Control Panel custom color profiles and ICC profiles are lost when using the Microsoft Game Bar. [1904238]
    • [GeForce Experience]: Driver installation may fail when attempting to perform a driver overinstall.
    • [Notebook][Pascal GPU]: The display remains blank while over installing the driver, requiring a reboot. [200273603]
    • Error code 43 appears in the Device Manager after installing the driver with HDMI display connected. [200283276]
    • Driver install/overinstall requires a reboot. [1757931]
  • Windows 8.1:
    • None
  • Windows 7:
    • [GeForce GTX 1080] Battlefield 1 hangs when campaign loaded with Fast Sync enabled from the NVIDIA Control Panel. [200254350]

 

Edited by joluke@inphtech

Share this post


Link to post
Share on other sites

When I try install 382.19 I end up with a black screen =/ on my M18XR2 I have to roll back into safe mode and run ddu to get it back, there was a recent big update on windows 10?

Edited by 82280zx
mispelled some stuff

Share this post


Link to post
Share on other sites

 

   GeForce Hotfix driver 382.33

 

      Game Ready
       •Provides the optimal gaming experience for Tekken 7 and Star Trek Bridge Crew.


      *Install drivers at your own risk* Windows 10 + GeForce Drivers are Killing Samsung and LG Notebook LCD Display Panels
       Uninstall PrecisionX, including screen overclocking tools. Instead, keep MSI Afterburner's RTSS for monitoring purposes.

 

       900M Requirements:

       Flash latest @Prema's v2 980M & 970M (Please consider donating to Prema)


  • Win10/8.1 'F8' Boot options 'Safe Mode' & 'Disable driver Signing'
    cmd (Admin)
bcdedit /set {default} bootmenupolicy legacy

 

        -> reboot -> F8 -> select 'Disable Driver Signature Enforcement' -> Install drivers

  • Run DDU "Clean & Shutdown (Safe Mode)
  • Extract driver using 7-Zip
  • Display.Driver folder,  copy/overwrite the proper .inf file(s).
  • Extracted driver package >> delete the folders as shown below (don't skip this step)  -> run setup.exe  

       >>> Keep these folders only <<<

373.06.PNG

 

 

    INF MOD v382.33

Alienware: nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4) excluding AW 2015 - GTX 980 , 980M , 970M , 965M , 880M , 870M , 860M , 780M , 770M , 765M , 680M , 675MX , 670MX , 660M.

Clevo & MSI non-Optimus models: nv_dispi.inf (including nvcvi.inf & nvmii.inf )

 

nvcvi.inf: Optimus Alienware 17 / 05AA (only) GTX 980M - 970M - 965M

nvcvi.inf: Clevo P170EM / P150EM *Optimus* 980M - 970M

  

    GeForce 382.33 Win7/8.1

    GeForce 382.33 Win10

 

 

Alienware

nv_dispi.inf_v382.33_Win7_8.1_PEG_Dedicated_Alienware.zip

nvcvi.inf_v382.33_Win7_8.1_Optimus_Alienware_17.zip

 

nv_dispi.inf_v382.33_Win10_PEG_Dedicated_Alienware.zip

nvcvi.inf_v382.33_Win10_Optimus_Alienware_17.zip

 

Clevo & MSI Laptops (non-Optimus)

nv_dispi.inf_v382.33_Win7_8.1_PEG_Dedicated_CLEVO_MSI.zip

nv_dispi.inf_v382.33_Win10_PEG_Dedicated_CLEVO_MSI.zip

 

 

AW 900M Throttling workarounds:

M18xR2

First, flash @Swick1981 [Bios Mod] M18xR2 - Legacy Support now Available 

M18xR2 980M workaround

 

Hibernation method HERE and HERE

 

 

Please use the SEARCH function to see if your question has been answered/posted already.

 

https://www.techinferno.com/index.php?/announcement/4-user-account-promotion-rules-read-before-posting/

 

@82280zx that's a common issue with Nv latest drivers, try to found out if officially supported Alienware's 900M are also affected. If so, report it on GF forums as being an AW 2015 issue.

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

@J95

Hey first thank you for great work.

Could I ask you if is the right way to modify nvdispi.inf for my card? Because all previous drivers always seems to install and works in this way but I'm not really sure.
If not, could I ask you to add in next mod??

ehm Thank you again

msi 1060 notebook (1C60) on m18x R2 on SG mode (optimus trough igp) on Win7x64


 

Spoiler


[NVIDIA_Devices.NTamd64.6.1]
%NVIDIA_DEV.1C60%           = Section024, PCI\VEN_10DE&DEV_1C60


[NVIDIA_Devices.NTamd64.6.3]
%NVIDIA_DEV.1C60%           = Section113, PCI\VEN_10DE&DEV_1C60


[NVIDIA_Devices.NTamd64.6.2]
%NVIDIA_DEV.1C60%           = Section025, PCI\VEN_10DE&DEV_1C60


[Strings]
DiskID1 = "NVIDIA Windows (64 bit) Driver Library Installation Disk 1"
NVIDIA = "NVIDIA"
NVIDIA_A = "NVIDIA"

NVIDIA_DEV.1C60 = "NVIDIA GeForce GTX 1060"

 

Share this post


Link to post
Share on other sites
On 5/23/2017 at 5:38 AM, aaronloveweed said:

@J95

Hey first thank you for great work.

Could I ask you if is the right way to modify nvdispi.inf for my card? Because all previous drivers always seems to install and works in this way but I'm not really sure.
If not, could I ask you to add in next mod??

ehm Thank you again

msi 1060 notebook (1C60) on m18x R2 on SG mode (optimus trough igp) on Win7x64


 

  Reveal hidden contents


[NVIDIA_Devices.NTamd64.6.1]
%NVIDIA_DEV.1C60%           = Section024, PCI\VEN_10DE&DEV_1C60


[NVIDIA_Devices.NTamd64.6.3]
%NVIDIA_DEV.1C60%           = Section113, PCI\VEN_10DE&DEV_1C60


[NVIDIA_Devices.NTamd64.6.2]
%NVIDIA_DEV.1C60%           = Section025, PCI\VEN_10DE&DEV_1C60


[Strings]
DiskID1 = "NVIDIA Windows (64 bit) Driver Library Installation Disk 1"
NVIDIA = "NVIDIA"
NVIDIA_A = "NVIDIA"

NVIDIA_DEV.1C60 = "NVIDIA GeForce GTX 1060"

 

 

Please let me know how this goes! I'd love to see that machine go another gpu generation! I may try a 1070 in one if you get this to go 100%!

Share this post


Link to post
Share on other sites
2 hours ago, loafer987 said:

 

Please let me know how this goes! I'd love to see that machine go another gpu generation! I may try a 1070 in one if you get this to go 100%!

Hi method posted seems to work but on Win10x64 the formatting of strings is different.

Did you miss this?
 

Regards!

Share this post


Link to post
Share on other sites
On 5/23/2017 at 5:17 AM, J95 said:

 

   GeForce Hotfix driver 382.33

 

      Game Ready
       •Provides the optimal gaming experience for Tekken 7 and Star Trek Bridge Crew.


      *Install drivers at your own risk* Windows 10 + GeForce Drivers are Killing Samsung and LG Notebook LCD Display Panels
       Uninstall PrecisionX, including screen overclocking tools. Instead, keep MSI Afterburner's RTSS for monitoring purposes.

 

       900M Requirements:

       Flash latest @Prema's v2 980M & 970M (Please consider donating to Prema)


  • Win10/8.1 'F8' Boot options 'Safe Mode' & 'Disable driver Signing'
    cmd (Admin)

bcdedit /set {default} bootmenupolicy legacy

 

        -> reboot -> F8 -> select 'Disable Driver Signature Enforcement' -> Install drivers

  • Run DDU "Clean & Shutdown (Safe Mode)
  • Extract driver using 7-Zip
  • Display.Driver folder,  copy/overwrite the proper .inf file(s).
  • Extracted driver package >> delete the folders as shown below (don't skip this step)  -> run setup.exe  

       >>> Keep these folders only <<<

373.06.PNG

 

 

    INF MOD v382.33


Alienware: nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4) excluding AW 2015 - GTX 980 , 980M , 970M , 965M , 880M , 870M , 860M , 780M , 770M , 765M , 680M , 675MX , 670MX , 660M.

Clevo & MSI non-Optimus models: nv_dispi.inf (including nvcvi.inf & nvmii.inf )

 


nvcvi.inf: Optimus Alienware 17 / 05AA (only) GTX 980M - 970M - 965M

nvcvi.inf: Clevo P170EM / P150EM *Optimus* 980M - 970M

  

    GeForce 382.33 Win7/8.1

    GeForce 382.33 Win10

 

 

Alienware

nv_dispi.inf_v382.33_Win7_8.1_PEG_Dedicated_Alienware.zip

nvcvi.inf_v382.33_Win7_8.1_Optimus_Alienware_17.zip

 

nv_dispi.inf_v382.33_Win10_PEG_Dedicated_Alienware.zip

nvcvi.inf_v382.33_Win10_Optimus_Alienware_17.zip

 

Clevo & MSI Laptops (non-Optimus)

nv_dispi.inf_v382.33_Win7_8.1_PEG_Dedicated_CLEVO_MSI.zip

nv_dispi.inf_v382.33_Win10_PEG_Dedicated_CLEVO_MSI.zip

 

 

AW 900M Throttling workarounds:

M18xR2

First, flash @Swick1981 [Bios Mod] M18xR2 - Legacy Support now Available 

M18xR2 980M workaround

 

Hibernation method HERE and HERE

 

 

Please use the SEARCH function to see if your question has been answered/posted already.

 

https://www.techinferno.com/index.php?/announcement/4-user-account-promotion-rules-read-before-posting/

 

@82280zx that's a common issue with Nv latest drivers, try to found out if officially supported Alienware's 900M are also affected. If so, report it on GF forums as being an AW 2015 issue.

 

@J95 from what I can tell I never had any issues till I installed the Windows 10 Creator Update, It looks like I'm not alone on the issue ether (official cards and other laptops that aren't modded are being affected as well) and I haven't tested it yet but it sounds like if I removed the update the drivers would probably work. Here is the forum thread on it on Nvidia's site https://forums.geforce.com/default/topic/1003027/geforce-drivers/w10-creator-update-and-nvidia-drivers-issues-/6/

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By BAKED
      BAKED BIOS FOR TM, KM, DM, P6, P4 SERIES WITH MOST MENUS AND OPTIONS UNLOCKED PLUS OTHER MODIFICATIONS
       
      NEW:
      I HAVEN'T BEEN ACTIVE IN A WHILE BUT I MIGHT FIND SOME TIME SOON TO WORK ON AND RELEASE NEW MODS.
      I STARTED WORKING ON V3.0 A WHILE BACK WHICH WILL INCLUDE UPDATED UEFI DRIVERS, MICROCODE, BIOS SCREEN SHOT SUPPORT AMISCE SUPPORT(For some models) PLUS MORE. 
      ALL TM, KM AND DM SERIES ARE V2.0 AND NOW HAVE WINDOWS FLASHER INSTEAD, JUST EXTRACT AND RUN FLASH.BAT
      WARNING! BIOS FLASHING IS RISKY SO MAKE SURE YOU KNOW WHAT YOU'RE DOING BEFORE PROCEEDING. 
      FLASHING THE WRONG BIOS OR INTERRUPTING THE FLASHING PROCESS WILL BRICK YOUR SYSTEM! 
      USE AT YOUR OWN RISK!
      TM, KM AND DM SERIES
      P6 AND P4 SERIES
      INSTRUCTIONS
       
    • By qamar198
      Hello Everyone,

      I am trying my Sager NP 9377 to get to work but to no avail. NO POST, NO DISPLAY.
      in short>> powering on laptop causes fans to run at full speed after 10(cpu only) + 10 (now both cpu+gpu) with Caps Lock + Num Lock + Scroll Lock LEDs blinking, continuous 1 second beep, repeats for one minute with 1 second in between, then laptop shuts down.

      IN DETAIL
      System Specs are i7 4810mq 8gb gtx 880m SLI variant (though my laptop has other GPU Slot empty so only singular 880m running) 120 Hz display.

      The Problem
      > if i take out the battery and plug in AC only, the power light comes on ORANGE
      if both battery is connected, then i have both power and battery light ORANGE
      and if only battery is connected then of course laptop is waiting for me to press the power button
      but in all 3 cases the following happens
      > Pressing the power button brings laptop to some signs of life, power LED turns green, both the CPU and GPU fans have a very quick jerk but does not spin., keyboard lights up with Blue Backlight (dont know if this is relevant or not), HDD activity light starts to blink showing HDD access maybe (even when hdd is removed)
      > Display remains blank (i dont even sense the display backlight being on)
      > HDD activity light sometimes goes off after only 1-2 seconds, sometimes shows rapid blinking/activity for 4-5 seconds
      > both fans remain off (i removed back cover to check this)
      > after about 10 seconds or so, the CPU fan spins up (speed is normal, just like when using the laptop in IDLE)
      > after 10 more seconds have passed, the CPU fan seems to be turning off for a split second then both the CPU and GPU fan turn on full speed with a lot of noise.
      > Caps Lock, Num Lock and Scroll Lock LEDs all blink together with single beep for about 1 second, repeats beep with 1 second in between.
      > goes on for about 1 minute then laptop shuts down.
      > forcing the fans to spin down using FN+1 key makes them spin back up to full speed after a split second (dont even know why i tried this one -_-)

      What I Have Tried So Far
      > EC and Bios Reset (take out battery, disconnect AC Adapter, disconnect CMOS Battery, Press Power Button for upto 30 seconds)
      > Change Ram and check all available slots
      change/remove HDD
      > Repaste CPU/GPU and clean out fans
      > Checked GPU...... Flashed the 880m in this Sager with MSI vBios and tested it in a MSI Gt70 2PC i have, gpu ran fine, tested with FurMark, AC Odessey, Ghost Recon Wildlands for over an hour (unfortunately the cooling in my MSI is not good enough it already runs hot, and this 880m causes thermal throttling as well as power limit throttling sometimes). Reflash 880m with original Clevo vBios and put back into the Sager, still no boot, same results as before.
      > Checked the CPU..........checked the 4810mq in the MSI GT 70 which worked fine, as well as tried the 4810mq from the MSI in the Sager, still no boot.
      > Suspected bad GPU fan connection......therefore forced both fans to full speed as soon as i press power button (using FN+1 Keys) and both fans turn on full speed, same results.
      > tried charging the battery to the max before turning on on battery only, same results.

      >>------- The laptop has had some random shutdowns in the past too during gaming but would turn back on fine after waiting for 10 mins or so, then i sold it to some guy who brought it back to me the next day saying that it just turned off during gaming and wont turn back on, i returned his money, did all the troubleshooting above to no avail. then i finally put it aside to wait until i get some other system in which i can test the CPU and GPU.
      Then one day i turned it on (after leaving it untouched for a couple months), same results as above, i decided to try once without battery and it Freakin Turned ON!!!, used it for a couple days without battery, played a few games (thermal throttling was observed here and there), but then this happened again and this time it seems permanent . And now i have not only repeated all the steps above but this time also checked the CPU and GPU in the MSI GT70 too. ------------<<


      Some Observations
      > touching the CPU heat pipes feels warm, but the GPU heat pipes are colder (GPU never even booted?). dont know if this is normal or not.
      > i replaced one of the capacitors near the CPU once, but i did use the laptop for quite a while after that without any issues.
      > my Idle temps were always below 40c for both CPU and GPU, so an overheat warning as soon as laptop is powered on seems unlikely (false overheat warning?, but GPU does not even seem to be detected/ booted as heat pipes remain cold to touch), also i repasted the CPU and GPU multiple times.
      > The guy who sold me the laptop told me that the power adapter was originally a Dell, and it was modified to use with this Sager by replacing the cable with a 4-Pin one from a Toshiba (same pinout as the Sager), but then again i have used this laptop for quite a while on the same adapter.
      > From day 1 of having this laptop, some keys on the keyboard (w, s, t, c and numpad 4) did not work 99% of the time. pressing really hard on any one of them sometimes made ALL of them work for a while. any thoughts on this issue?? (even if its unrelated).

      So what seems to be the issue here?
      GPU not detected ?, False temperature alert?, Bad fan?.
      Any help towards resolving this will be greatly appreciated.
      Thanks in advance .
    • By BasedKnight
      I recently purchased a replacement 980M (Clevo model) for my P770DM-G after the original died, however, after installing the card the laptop doesn't boot. I only get a black screen, and after a couple minutes the fans spin to max before shutting down, which is the same thing that happens when I try to boot it without any gpu at all. I've tried the reset procedure, unplugging, removing battery, and removing CMOS, to no avail. It does beep before shutting down (I counted 22 times exactly). Anyone have any insight as to what the problem is?
    • By Brian
      Following the release of NVIDIAs new 436.02 driver which I mentioned in an earlier article here, I've decided to make a quick and dirty video showing off NVIDIAs new Sharpen filter which is part of their Game Filter feature. It works with the most popular APIs including DX 9, 11, 12 and Vulkan and can be set on a per-game basis with granular settings of 0-100 unlike AMDs RIS which is limited to Navi and lacks DX 11 support.
       
       

      View full article
    • By Brian
      Following the release of NVIDIAs new 436.02 driver which I mentioned in an earlier article here, I've decided to make a quick and dirty video showing off NVIDIAs new Sharpen filter which is part of their Game Filter feature. It works with the most popular APIs including DX 9, 11, 12 and Vulkan and can be set on a per-game basis with granular settings of 0-100 unlike AMDs RIS which is limited to Navi and lacks DX 11 support.
       
       
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.