Jump to content
EwinRacing Flash Series Gaming Chairs
J95

[Alienware - Clevo - MSI] Aftermarket Upgrades Driver Support - Modded INF

Recommended Posts

http://www.3dmark.com/3dm/15859939?

Finally I installed this driver (375.70) and the fire strike even lower than before. 

Wanna know what I missed.

Gaming is Fine, and temperature has dropped down, the only problem is I don't see any performence improvement.

and I already flashed prema's v2.

Edited by Curtis_AW17R5

Share this post


Link to post
Share on other sites

https://www.reddit.com/r/pcmasterrace/comments/5b9hdo/nvidia_adds_telemetry_to_latest_drivers_heres_how/d9mw9f0/

http://www.ghacks.net/2016/11/07/nvidia-telemetry-tracking/

http://www.gamersnexus.net/industry/2672-geforce-experience-data-transfer-analysis

http://forum.notebookreview.com/threads/nvidia-telemetry-in-their-latest-drivers.797846/

 

Quote

In the case of Nvidia, Telemetry gets installed alongside the driver package. While you may -- and should -- customize the installation of the Nvidia driver so that only the bits that you require are installed, there is no option to disable the Telemetry components from being installed. These do get installed even if you only install the graphics driver itself in the custom installation dialog.

 

 

@J95

 

At first they got with GFE 3.x and now they are being packed with the sole driver package as well.

Sigh !! first Windows10 and now nGreedia as well...

 

 

Edited by Ashtrix
  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hi have a alienware m17x r4 with a 970m in it brought it through hidevolution and the driver I have at the minute is 372.20 but need later the 372.90 to play battlefield how do I go about

getting the latest modded driver and keep them up to date as I noticed you cant do it through NVidia as the driver has no signature, am a bit of a noob so any help would be much

appreciated

thanks

tom

Share this post


Link to post
Share on other sites
On 28.10.2016 at 10:32 PM, J95 said:

GeForce 375.70


    *Install drivers at your own risk* Windows 10 + GeForce Drivers are Killing Samsung and LG Notebook LCD Display Panels
      Uninstall PrecisionX, including screen overclocking tools. Instead, keep MSI Afterburner's RTSS for monitoring purposes.

 

       Requirements:

       Flash latest @Prema's v2 980M & 970M (Please consider donating to Prema)

  •  
  • Win10/8.1 'F8' Boot options 'Safe Mode' & 'Disable driver Signing'
    cmd (Admin)

bcdedit /set {default} bootmenupolicy legacy

 

        -> reboot -> F8 -> select 'Disable Driver Signature Enforcement' -> Install drivers

  • Run DDU "Clean & Shutdown (Safe Mode)
  • Extract driver using 7-Zip
  • Display.Driver folder,  copy/overwrite the proper .inf file(s).
  • Extracted driver package >> delete the following folders as shown below (don't skip this step)  -> run setup.exe  

       >>> Keep these folders only <<<

373.06.PNG

 

 

    INF MOD v375.70


nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4) excluding AW 2015 - GTX 980 , 980M , 970M , 965M , 880M , 870M , 860M , 780M , 770M , 765M , 680M , 675MX , 670MX , 660M

 


nvcvi.inf: Optimus Alienware 17 / 05AA (only) GTX 980M - 970M - 965M

    

GeForce 375.70 Win 7/8.1


GeForce 375.70 Win10

 

Alienware Laptops

nv_dispi.inf_v375.70_Win7_8.1_PEG_Dedicated_Alienware.zip

nvcvi.inf_v375.70_Win7_8.1_Optimus_Alienware_17.zip

 

nv_dispi.inf_v375.70_Win10_PEG_Dedicated_Alienware.zip

nvcvi.inf_v375.70_Win10_Optimus_Alienware_17.zip

 

Clevo Laptops (non-Optimus)

nv_dispi.inf_v375.70_Win7_8.1_PEG_Dedicated_CLEVO.zip

nv_dispi.inf_v375.70_Win10_PEG_Dedicated_CLEVO.zip

 

 

 

AW 900M Throttling workarounds:

M18xR2

Flash @Swick1981 [Bios Mod] M18xR2 - Legacy Support now Available 

M18xR2 980M workaround

 

Hibernation method HERE and HERE

 

 

@ All please use the SEARCH function to see if your question has been answered/posted already.

 

https://www.techinferno.com/index.php?/announcement/4-user-account-promotion-rules-read-before-posting/

 

 

Can you help me with MSI gs30 Notebook mod Inf.? Same problem  with MSI 1070 GTX  code 43 for new nvidia driver.

Edited by bbx

Share this post


Link to post
Share on other sites
10 hours ago, Sebastian Rosenberg Lenda said:

I have the AW M17X R4 what VBios would you recommend for the GTX980M?

 

@Prema clevo 980M v2 vbios.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
On 10/11/2016 at 9:59 AM, thegh0sts said:

 

@Prema clevo 980M v2 vbios.

Thanks, i just didnt want to install before being sure since it says Clevo and not Alienware. :)

 

FYI: I have problems with black screen and Audio/game continue in background, but i have to make a hard reset to get the screen to turn on again, what can be causing this?

Share this post


Link to post
Share on other sites
14 hours ago, Sebastian Rosenberg Lenda said:

Thanks, i just didnt want to install before being sure since it says Clevo and not Alienware. :)

 

FYI: I have problems with black screen and Audio/game continue in background, but i have to make a hard reset to get the screen to turn on again, what can be causing this?


Check your temps & check this thread at NBR too.

 

12 hours ago, tomhalls2rallye said:

would your recommend the same bios for the 970m, have same laptop alienware 17x r4 running 3842qm processor

 

https://biosmods.wordpress.com/gtx9/ 

 

Use Either of them and to Flash use the Premamod zip and copypasta or have a look at those commands from the batch files and flash them by going to Devicemngr and disabling them and after flash enable them, No need for the BIOS Legacy Flashing, Maxwell can be flashed from the Windows.

Edited by Ashtrix
  • Thumbs Up 1

Share this post


Link to post
Share on other sites

could you write a quick step by step sorry to be a pain am a bit new to when it comes to this, do I just download the file from prema for 970m and open it up and click the nvflash application

thanks

tom

7 hours ago, Ashtrix said:

 

Edited by tomhalls2rallye

Share this post


Link to post
Share on other sites

I think my temps are fine, never goes beyond 82 degrees under heavy load, and last time i blackscreened HWinfo log said 77c but why does the Prema Vbios updater sat GPU mismatch? 

 

 

edit: ran a Unigine Heaven Benchmark and reached max temp of 69c

2016-11-14 (1).png

Edited by Sebastian Rosenberg Lenda
More info

Share this post


Link to post
Share on other sites
On 11/11/2016 at 11:38 AM, Sebastian Rosenberg Lenda said:

When i try to install the VBios it says GPU Mismatch and clicks twice??

 

qxf.png

Are you sure you are getting the correct version of vbios:

https://biosmods.wordpress.com/gtx9/

(They are NOT compatible with models with soldered GPUs)

8GB MXM GTX980M:

GTX980M_8GB_MXM_OC_PM_v2

MD5: 3ba3bcb8f35362ce3f9a8cd32b6c1d01

Edited by mariussx
  • Thumbs Up 1

Share this post


Link to post
Share on other sites

GeForce 375.86


    *Install drivers at your own risk* Windows 10 + GeForce Drivers are Killing Samsung and LG Notebook LCD Display Panels
      Uninstall PrecisionX, including screen overclocking tools. Instead, keep MSI Afterburner's RTSS for monitoring purposes.

 

       Requirements:

       Flash latest @Prema's v2 980M & 970M (Please consider donating to Prema)


  • Win10/8.1 'F8' Boot options 'Safe Mode' & 'Disable driver Signing'
    cmd (Admin)
bcdedit /set {default} bootmenupolicy legacy

 

        -> reboot -> F8 -> select 'Disable Driver Signature Enforcement' -> Install drivers

  • Run DDU "Clean & Shutdown (Safe Mode)
  • Extract driver using 7-Zip
  • Display.Driver folder,  copy/overwrite the proper .inf file(s).
  • Extracted driver package >> delete the folders as shown below (don't skip this step)  -> run setup.exe  

       >>> Keep these folders only <<<

373.06.PNG

 

 

    INF MOD v375.86

nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4) excluding AW 2015 - GTX 980 , 980M , 970M , 965M , 880M , 870M , 860M , 780M , 770M , 765M , 680M , 675MX , 670MX , 660M

 

nvcvi.inf: Optimus Alienware 17 / 05AA (only) GTX 980M - 970M - 965M

    

GeForce 375.86 Win 7/8.1


GeForce 375.86 Win10

 

Alienware Laptops

nv_dispi.inf_v375.86_Win7_8.1_PEG_Dedicated_Alienware.zip

nvcvi.inf_v375.86_Win7_8.1_Optimus_Alienware_17.zip

 

nv_dispi.inf_v375.86_Win10_PEG_Dedicated_Alienware.zip

nvcvi.inf_v375.86_Win10_Optimus_Alienware_17.zip

 

Clevo Laptops (non-Optimus)

nv_dispi.inf_v375.86_Win7_8.1_PEG_Dedicated_CLEVO.zip

nv_dispi.inf_v375.86_Win10_PEG_Dedicated_CLEVO.zip

 

 

AW 900M Throttling workarounds:

M18xR2

Flash @Swick1981 [Bios Mod] M18xR2 - Legacy Support now Available 

M18xR2 980M workaround

 

Hibernation method HERE and HERE

 

 

Please use the SEARCH function to see if your question has been answered/posted already.

 

https://www.techinferno.com/index.php?/announcement/4-user-account-promotion-rules-read-before-posting/

 

 

  • Thumbs Up 2

Share this post


Link to post
Share on other sites
On 15/11/2016 at 8:32 PM, mariussx said:

Are you sure you are getting the correct version of vbios:

https://biosmods.wordpress.com/gtx9/

(They are NOT compatible with models with soldered GPUs)

8GB MXM GTX980M:

GTX980M_8GB_MXM_OC_PM_v2

MD5: 3ba3bcb8f35362ce3f9a8cd32b6c1d01

Its the one you have linked to i have downloaded, and when i try to use the ModMe batchfile it says GPU mismatch....... Is there some procedure i have forgot, like when you have to disable driver signing to run modded Nvidia installer?

Share this post


Link to post
Share on other sites
9 hours ago, Sebastian Rosenberg Lenda said:

Its the one you have linked to i have downloaded, and when i try to use the ModMe batchfile it says GPU mismatch....... Is there some procedure i have forgot, like when you have to disable driver signing to run modded Nvidia installer?

Wrong file, G-SYNC GPU ID 1617 GPU-Z screenshot above (980M-G)  https://biosmods.wordpress.com/gtx9-g/

 

It shouldn't matter DM or ZM for AW, but better ask @Prema anyway.

 

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
On 11/11/2016 at 11:58 PM, tomhalls2rallye said:

could you write a quick step by step sorry to be a pain am a bit new to when it comes to this, do I just download the file from prema for 970m and open it up and click the nvflash application

thanks

tom

 

For 60Hz


First get Windows 8.1 or Windows 10 installed under full UEFI, make sure you have AW OSD to switch Optimus / PEG modes.
Second flash a vBIOS from Device mngr in optimus mode, Prema mod v2.0 / svl7

 

How to flash ? -

Disable the GPU from Devicemngr after booting to the Optimus mode & follow these steps below...

 

1 - As I've said, see the zip and go through readme, there should be a bat file called modme.bat copy the commands from it, and rename the vBIOS to the same one in the cmd or issue the command wr.to the name of the vBIOS you set this depends on you, Run the command from Admin privileges cmd  (Modme.bat, wont execute depending on your OS and file permissions so best way is to run it manually)

 

Third switch to PEG mode, get an INF mod (PEG INF only), preferably from this thread (Need to disable driver sign verification. Install this driver in PEG mode)

 

 

For 120Hz

I presume, No need to use the IGFX switch, Just go to the Devicemngr and disable the card, then flash and reboot and then Install the INF modded driver from this thread, J95 always !

 

 

Also make sure to use DDU to uninstall properly, I use this everytime when I need to update or rollback or clean OS installations.

 

I'll also leave this here for all the Alienware 17 Owners who want to upgrade to a Maxwell GPU, Also this post too as a safety precaution for the MSI-AB and EVGA PX for all LVDS machines (60Hz)

 

Also check NBR for these similar threads (375.86 & 375.76 ) to get most out of your GPU without any perf loss.

 

For now stable one seems to be 373.06,  I personally use 369.05 for now since I don't have newer games than DOOM but the BF1, Mirrors Edge Catalyst might need new Drivers like the 375.76..\

 

Hope this clears out, Best of Luck.

Edited by Ashtrix
  • Thumbs Up 2

Share this post


Link to post
Share on other sites
6 hours ago, Khenglish said:

@J95 What system uses that small MSI 1080? With heatsink mods that'd fit in standard MXM systems.

Yeah I know. MSI GT83VR SLI GTX 1080. Although I still hope we could mod the beefier version 6+1 MSI GT73VR NVIDIA GTX 1080

 

MSI GT83VR SLI GTX 1080

 

MSI GT73VR NVIDIA GTX 1080

 

Share this post


Link to post
Share on other sites
Already included...anyway, you should wait.

 

MSI 1080 without power connector. 

MSI__.PNG

 

or maybe this https://www.zotac.com/us/product/mini_pcs/magnus-en1080-10-year-anniversary-edition#overview

 

 

I meant add it to the driver inf.

I have the feeling an MSI 1080 is gone cost more than I would like to pay. The 1070 is pushing it.

Sent from my SM-N910G using Tapatalk

Share this post


Link to post
Share on other sites
6 hours ago, thegh0sts said:

I meant add it to the driver inf.

I have the feeling an MSI 1080 is gone cost more than I would like to pay. The 1070 is pushing it.

Sent from my SM-N910G using Tapatalk

Yep, added two months ago.

 

I won't pay 1.2K that's for sure, cutting out the middleman.

Share this post


Link to post
Share on other sites
7 hours ago, J95 said:

Yep, added two months ago.

 

I won't pay 1.2K that's for sure, cutting out the middleman.

 

Any plans on modding the latest hotfix 375.95?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Yomaster
      Hello, 
       
      some of my computer specs are as follows: 
      CPU: I9-9900k
      GPU: RTX 2070
      memory: 32 GB (forget the manufacturer/ clocks)
      Dsanke bios mod
       
       
       I recently bought a 1440p screen that is 120hz capable, but it does not allow me to select the 120hz option. I have checked numerous places and all of the websites say that this screen is 120hz enabled. I have the dsanke bios mod on my computer. I see people being able to use this screen's 120hz functionality, but I can't get it to work. Any suggestions? If you need any additional information about my laptop, I will be happy to provide info.
       
    • By Miyagi1007
      Hello guys so i bought a used alienware m17x r3 with hd 6870m on it, so when i was trying to boot well it goes to the windows 7 loading screen that says starting windows after that the screen turns white and goes to bsod saying atikmpag.sys
       
      also i attempt to switch my integrated gpu to my discrete card ( hd6870m)  and i wont switch at all 
       
      Responses are highly appreciated 
      Thank you in advance
    • By blancaster
      does anyone know why a vbios file  8mb in size for nvidia k80 , myu backup bios is only 256kb
    • By IveGotRoot
      I have recently upgraded my laptop(an M6800 firepro 6100) and replaced it with an GTX 980m. Nvidia says that the latest driver(461) supports my card but i can only install up to 388.13 Ive tried to mod it but i can't figure it out. I can run the latest linux driver tho
    • By Freddyicy
      I have spent a little time in the past few days looking around this site. I would love for someone to point me in the right direction to a forum that has information that could help me out with my problem.
       
      I have a:
       
      Alienware M17XR3 
      Windows 7 Home Premium 64-bit
      Intel I7-2820QM 2.3
      Bios InsydeH20 Version 1.0 A12
      NVIDIA GeForce GTX 460M
      (4x) 4 GB Ram
      samsung 2.5" 256 SSD (SATA3.0Gbps)
       
      It has been an amazing machine for the last 10+ years. Minor issues, nothing that an Alien Respawn could not fix, till now! On battery power it works just perfect.  Then I plug it in and it's all OK until I try to do anything, and then the screen goes white. The screen sometimes goes yellow, sometimes blue, but mostly white screen. It will do nothing until I do a hard reset (holding the power button till it turns off and turn it back on) with the power unplugged.  If the power is not unplugged then it will go through boot up to windows swirling dots then go white again. If I plug it in and do nothing I can charge it, unplug and continue what i was doing. I have tried a lot of solutions bouncing around the internet, and thought I was having a DC Jack connection issue (replaced the ac/dc power adapter, then the motherboard). I get a better connection now but with the same white screen result. I stumbled into this forum and I'm hoping to find solutions to my issues.  Then upgrade like so many others have.
       
      Any ideas, comments or suggestions welcome.
       
      Thank you in advance!
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.