Jump to content
EwinRacing Flash Series Gaming Chairs
J95

[Alienware - Clevo - MSI] Aftermarket Upgrades Driver Support - Modded INF

Recommended Posts

@J95 Thanks for your efforts... This time, after DDU and DSE disabled. The install detects my 970M, starts the installation, slightly flash the screen to black for 1/2 seconds and fails.

 

Looking at the device managers shows no more 970M device. Looking for hidden devices reveal the device shown as "removed" (code 45). Rebooting leads to the same result.

 

DDU again and the device shows again.

Share this post


Link to post
Share on other sites

Just noticed something now:geek:.... a very old feature on M18x-r2m, the hdmi in is not working anymore. Just tried to connect a ps3 on hdmi in but nothing happens. Could be the 980M card fault? Can someone test the hdmi in feature on  a M18x to see if its working?

Share this post


Link to post
Share on other sites

Hi again!

 

With your help I managed to get a Dell M6700 going along with Nvidia GTX880m. I generally feel great about that laptop, except there are problems with gaming. Every single game crashes after 5-10 minutes with either a PC freeze or a BSOD saying something about GPU driver error. Is that the fault of 370.90 drivers? I should also mention I have a 210W PSU, so I thought this might be a problem for i7 3940XM and GTX880m. What do you guys suggest?

Share this post


Link to post
Share on other sites

It seems a driver/hardware problem. But check these two options first:

 - Card temperature.

 - If you can, grab a monitoring socket tool to check if the power supply is sufficient. From what I could check, most laptops with the 880M came with a 180w power adaptor, so a 210w should be sufficient.

Share this post


Link to post
Share on other sites
On 10/6/2016 at 10:15 PM, J95 said:

@technos try nv_dispi.inf v373.06 (minor change), remember to delete the folders above. Crashes can occur minutes after quitting firefox anyway.

 

It is resolved now. Thanks!

Share this post


Link to post
Share on other sites

Hi again!

Does anyone experience game freezes here? I tend to get a lot of crashes related to the drivers (sometimes it even gives me BSOD with an info)

Share this post


Link to post
Share on other sites
On 10.10.2016 at 3:26 PM, skandal said:

It seems a driver/hardware problem. But check these two options first:

 - Card temperature.

 - If you can, grab a monitoring socket tool to check if the power supply is sufficient. From what I could check, most laptops with the 880M came with a 180w power adaptor, so a 210w should be sufficient.

 

Hi there!

 

I did a benchmark of the temperature and it reaches 73 Celsius degrees maximum. Right now I am running the PC with a 240 Watt PSU so that shouldn't be a problem. Is it possible there is something wrong with the driver?

Share this post


Link to post
Share on other sites

So i just bought an alienware m15x off ebay that came with a gtx260m. Its not good enough to play some of the games I own. Looked around for a bit and found that this laptop can have a Clevo Nvidia GTX 970m installed. So I went onto ebay and bought this GTX970m (EBAY listing). I Put the card into the laptop and gave it new paste and then put a fresh copy of Windows 10 Pro X64 on it. The only issue is I cannot have access to the drivers listed on this site. I keep getting linked here and its frustrating me. I want to be able to download the custom drivers to make sure that my card works If I hold onto it to long and find that Its broken, I wont be able to get a refund. How van I go about getting access to the files without having this limit on this account. Im short on time and wont be able to do much after tomorrow. I have work!  Please help me out. I really want to get this beautiful laptop up and running.

 

Specs:
Model: Alienware M15x
OS: Windows 10 Pro x64
CPU: i7 740QM
RAM: 6GB DDR3-1333 Hynix
GPU: NVIDIA GTX 260m
Storage: 1TB Sandisk ssd
Battery: Original 9 Cell (35% wear) Holds charge around 1 1/2 hrs

 

 

I have tried ones found off a video on youtube (HERE) but it does not work, says it cannot find any compatible hardware. And when I tried to make my own custom files, it gets past the first part but fails to install driver part.

zHJthUK.png

Share this post


Link to post
Share on other sites

Have you disabled DSE?

If not you'll get the same result with drivers from here.

Share this post


Link to post
Share on other sites
6 hours ago, Zoldago said:

Have you disabled DSE?

If not you'll get the same result with drivers from here.

 

Yes I disabled the windows 10 driver signing enforcement when trying to install.

Share this post


Link to post
Share on other sites

@SimplexDesigns, I had the same problems with M6700 and a GTX880m - what helped me was modding the INF files from this thread by myself. Basically I had to make the OS and driver think the GTX880m was designed to run in Dell M6700. Adding just one single line didn't give proper results so I decided to find the HWID of my GPU and changed an Alienware HWID part for my M6700 four signs code. However, in order for the driver to work properly I had to change every single chosen Alienware signs for my M6700. It's a bit hard for me to explain typing, so if you need I can mod the INF for you - just write a PM.

 

The drivers work, yet games freeze and sometimes the system crashes. Can anyone relate to that?

 

edit

 

3DMark 11 Basic gave me this a moment ago:

 

Workload work failed with error message: eva::d3d11::rendering::scene_renderer::render(): draw_unshadowed_illumination_task for thread 0: File: device_context.cpp
Line: 515
Function: struct ID3D11CommandList *__cdecl eva::d3d11::deferred_device_context::do_finish_command_list(bool)

Expression: native()->FinishCommandList( restore_deferred_context_state, &result): DX11 call failed.

Device hung due to badly formed commands.
DXGI_ERROR_DEVICE_HUNG: ID3D11DeviceContext::FinishCommandList: 

 

What is going on?

Edited by szumial

Share this post


Link to post
Share on other sites
On 10/18/2016 at 10:59 PM, szumial said:

Is it possible there is something wrong with the driver?

 

Yep. But I can't help you there :( I have no idea how to mod driver inf. But I think some people here might help :D 

Share this post


Link to post
Share on other sites

I installed the drivers just as it is described here, but what happens is the gpu is not working when I launch any specific application. I believe there is something wrong with optimus here.

edit

 

I had some time to check it out and the dedicated GPU only works on external screen, such as my HDMI monitor. Despite that, it still freezes games :(
 

Edited by szumial

Share this post


Link to post
Share on other sites

GeForce 375.57


    *Install drivers at your own risk* Windows 10 + GeForce Drivers are Killing Samsung and LG Notebook LCD Display Panels
      Uninstall both PrecisionX & MSI Afterburner (Keep RTSS) including screen overclocking tools *Still at risk*

 

       Requirements:

       Flash latest @Prema's v2 980M & 970M (Please consider donating to Prema)


  • Win10/8.1 'F8' Boot options 'Safe Mode' & 'Disable driver Signing'
    cmd (Admin)
bcdedit /set {default} bootmenupolicy legacy

 

        -> reboot -> F8 -> select 'Disable Driver Signature Enforcement' -> Install drivers

  • Run DDU "Clean & Shutdown (Safe Mode)
  • Extract driver using 7-Zip
  • Display.Driver folder,  copy/overwrite the proper .inf file(s).
  • Extracted driver package >> delete the following folders as shown below (don't skip this step)  -> run setup.exe  

       >>> Keep these folders only <<<

373.06.PNG

 

 

    INF MOD v375.57

nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4) excluding AW 2015 - GTX 980 , 980M , 970M , 965M , 880M , 870M , 860M , 780M , 770M , 765M , 680M , 675MX , 670MX , 660M

 

nvcvi.inf: Optimus Alienware 17 / 05AA (only) GTX 980M - 970M - 965M

    

GeForce 375.57 Win 7/8.1


GeForce 375.57 Win10

 

Alienware Laptops

nv_dispi.inf_v375.57_Win7_8.1_PEG_Dedicated_Alienware.zip

nvcvi.inf_v375.57_Win7_8.1_Optimus_Alienware_17.zip

 

nv_dispi.inf_v375.57_Win10_PEG_Dedicated_Alienware.zip

nvcvi.inf_v375.57_Win10_Optimus_Alienware_17.zip

 

Clevo Laptops (non-Optimus)

nv_dispi.inf_v375.57_Win7_8.1_PEG_Dedicated_CLEVO.zip

nv_dispi.inf_v375.57_Win10_PEG_Dedicated_CLEVO.zip

 

 

 

AW 900M Throttling workarounds:

M18xR2

Flash @Swick1981 [Bios Mod] M18xR2 - Legacy Support now Available 

M18xR2 980M workaround

 

Hibernation method HERE and HERE

 

 

@ All please use the SEARCH function to see if your question has been answered/posted already.

 

https://www.techinferno.com/index.php?/announcement/4-user-account-promotion-rules-read-before-posting/

 

On 7/9/2016 at 3:03 AM, J95 said:

@_ALL if you are enjoying @Prema's  work, please consider making a contribution HERE.

 

 

Much appreciated!

 

Share this post


Link to post
Share on other sites
23 minutes ago, Shamil said:

why I cant download files from here?

Read SECTION 4 - ACCOUNT PROMOTIONS

https://www.techinferno.com/index.php?/ti-tos/tos/

8 minutes ago, Shamil said:

Thanks:) May be you can help me? I really need nv_dispi.inf_v375.57_Win10_PEG_Dedicated_Alienware.zip  right now. Could you please download it for me?

This does not start very well. That's not how we do it on the web. You ask me to share other people's hard work. This is wrong!!

 

Mod can you chime in@J95 @Mr.

Edited by Papusan
  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By blancaster
      does anyone know why a vbios file  8mb in size for nvidia k80 , myu backup bios is only 256kb
    • By IveGotRoot
      I have recently upgraded my laptop(an M6800 firepro 6100) and replaced it with an GTX 980m. Nvidia says that the latest driver(461) supports my card but i can only install up to 388.13 Ive tried to mod it but i can't figure it out. I can run the latest linux driver tho
    • By Freddyicy
      I have spent a little time in the past few days looking around this site. I would love for someone to point me in the right direction to a forum that has information that could help me out with my problem.
       
      I have a:
       
      Alienware M17XR3 
      Windows 7 Home Premium 64-bit
      Intel I7-2820QM 2.3
      Bios InsydeH20 Version 1.0 A12
      NVIDIA GeForce GTX 460M
      (4x) 4 GB Ram
      samsung 2.5" 256 SSD (SATA3.0Gbps)
       
      It has been an amazing machine for the last 10+ years. Minor issues, nothing that an Alien Respawn could not fix, till now! On battery power it works just perfect.  Then I plug it in and it's all OK until I try to do anything, and then the screen goes white. The screen sometimes goes yellow, sometimes blue, but mostly white screen. It will do nothing until I do a hard reset (holding the power button till it turns off and turn it back on) with the power unplugged.  If the power is not unplugged then it will go through boot up to windows swirling dots then go white again. If I plug it in and do nothing I can charge it, unplug and continue what i was doing. I have tried a lot of solutions bouncing around the internet, and thought I was having a DC Jack connection issue (replaced the ac/dc power adapter, then the motherboard). I get a better connection now but with the same white screen result. I stumbled into this forum and I'm hoping to find solutions to my issues.  Then upgrade like so many others have.
       
      Any ideas, comments or suggestions welcome.
       
      Thank you in advance!
       
    • By jonasmsi
      Hey i have an idea to change my old msi gx720 laptop Motherboard to one from a msi gx740 they look to have the same cutouts to screws and both laptops chassis look to be the same with outputs and that so my question is do you guys think it is possible to do it
       
       
      msi gx720 motherboard – Google Søgning                    msi gx740 motherboard – Google Søgning
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.