Jump to content
EwinRacing Flash Series Gaming Chairs
Charly

Mac Mini 2012 vs Mac Mini 2014

Recommended Posts

Hi guys,

 

I´m planning to buy Mac Mini to have a second setup with my 970 Zotac + Akitio Thunder 2.

 

I would like an i7 Mac Mini but prices are still high so I´m going to an i5 processor, so I´m trying to decide between to models 2012 i5 2,5 Ghz Thunderbolt 1 or 2014 i5 1,4 Ghz.

 

In one hand the 2012 model is the most upgradable Mac Mini being possible to use 16 GB RAM but it´s Thunderbolt version is 1 on the other hand the 2014 model is not RAM upgradeable but it´s Thunderbolt is version 2.

 

What do you thing? Go to 2012 or 2014? Does anybody can help me? Any benchmarks?

 

Thank you so much!

Share this post


Link to post
Share on other sites

Hi again, it looks like in terms of CPU the 2014 i5 CPU´s are a little bit faster than 2012 in single core  but slower on multicore proceses.

 

2014 models starting in 2,6 Ghz goes with Intel Iris Graphic 5100 with is twice faster than Intel 400 on 2012 models.

 

So:

 

2012

PROS : RAM upgrading, Better CPU´s (4% slower single core, 46% faster in multicore)

CON: iGPU Intel 4000 90% Slower than Iris 5100 , Thunderbolt 1

 

2014

PROS : Iris 5100, Thunderbolt 2

CONS: RAM Soldered, slower CPU´s in Multi Core

 

With these data I would choose 2012 model, but I´m not sure if Thunderbolt 2 would be a great improvement to my eGPU...

 

 

I tried to find real cases but all of them are with really different Mac Minis configs, RAM and eGPU´s so I´m still little confused.

 

Anybody?

 

UPDATE

 

I´m trying to find different benchmarks results for different Mini´s with different configurations and see the differences.

 

Mini 2012

 

i5 2,5 GHz +  16 RAM + 970 GTX

 

2012 i5  2,5 16  RAM GTX 970 OSX.jpg

 

i5 2,5 GHz + 16 RAM + 960 GTX

 

2012 i5 2,5 16 RAM GTX 960 OSX .png

 

Mini 2014

 

i5 2,8 GHz + 16 RAM + 970 GTX

2014 i5 2,8 16 RAM GTX 970 OSX.png

Edited by Charly
New Benchmarks

Share this post


Link to post
Share on other sites

I'd go with 2012 Model with upgradable since TB1 and TB2 are not much different in eGPU (Compare with my MBP2012+GTX960 and MBP2014)

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

You can have pci SSD with 2014, faster ram and faster Thunderbolt. But not upgradable ram. Anyway i would

suggest 2014

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
On 21/11/2016 at 9:35 AM, errin said:

I'd go with 2012 Model with upgradable since TB1 and TB2 are not much different in eGPU (Compare with my MBP2012+GTX960 and MBP2014)

 

Thank you for your reply!!

 

Do you have any pictures or results in benchmarks like Heaven? Would be great...

 

I have a GTX 970 and it looks like is more powerful than your 960 ;) , in your opinion, Would be a big difference or more an less like your case?

 

Thanks again errin!!

Share this post


Link to post
Share on other sites
15 hours ago, ikir said:

You can have pci SSD with 2014, faster ram and faster Thunderbolt. But not upgradable ram. Anyway i would

suggest 2014

 

ikir, thanks for your advice, i did´t know 2014 mini has an option tu upgrade the drive with a pci ssd, I asume you are talking about this, don´t you?

 

 

http://www.applecomponents.com/items/carrier-hard-drive-with-flash-storage/0000006001?pn=10&cat=Service Parts: Cables&per_page=30

 

About 2014 Mini, I know that RAM is faster than 2012 but it´s really cheap to upgrade the 2012 with 16gb and it´s really difficult and expensive to find a 2014 with 16 GB of RAM, about the thunderbolt again is faster but in terms of using my 970 GTX eGPU  I don´t know exactly the difference.

 

I wold like to compare but i´m can´t find similar eGPU configurations with similar CPU & RAM 2012 and 2014 minis to see real differences.

 

Thank you

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hi! I had a Mac mini 2014 until 2 months ago, very nice machine but I would suggest 2,6Ghz version if possible. I often had them to sell (used but tested). Yes exactly, SSD PCIe can be used with that cable. Anyway the speed limit is about 750MB/s even if you you MBP 2015 SSD which could hit 2000MB/s. You can also create a Fusion Drive.

With my Mac mini I was using a Nvidia GTX 970, you can find my thread here.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
10 hours ago, ikir said:

Hi! I had a Mac mini 2014 until 2 months ago, very nice machine but I would suggest 2,6Ghz version if possible. I often had them to sell (used but tested). Yes exactly, SSD PCIe can be used with that cable. Anyway the speed limit is about 750MB/s even if you you MBP 2015 SSD which could hit 2000MB/s. You can also create a Fusion Drive.

With my Mac mini I was using a Nvidia GTX 970, you can find my thread here.

 

Interesting, Do you have minis to sell right now?

 

I just realized that third Heaven Benchkmark picture i posted yesterday is from your thread jejeje

 

Do you thing is possible to pass again the benchmark with 1080 resolution and no aa?

 

Thank you!

Share this post


Link to post
Share on other sites

Yeah I was running in 4K! Right now I don't have minis, but I could have one soon. Write me a PM

 

i can't test since I don't have the mini anymore

Share this post


Link to post
Share on other sites

Yea man, bugger the 5 year old 2012 mac mini, and get going with thunderbolt 2.

Definitely get an 8-16gb RAM 2014 Mac Mini instead of base model, for more modern games.

And get an SSD with Mac instead of HDD, SO much faster! You will be much more happier knowing you went with a more up to date mac.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

I had no time...

 

But I´m trying to find an i7 with good price... maybe 2012 but first I´ll try to find the difference of using TB1 or TB2 with my GTX 970.

 

;)

 

I´ll post any news and conclusions. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Arman
      Hello! My name is Arman! I from Armenia, and sorry for my English!
      I have iMac Late 2013 with Intel core i5, 8Gb, NVIDIA GeForce GT 750M 1024 Mb. I have Boot Camp installation on my iMac (now i have 7 Windows, but i can update it to 10 or 8 Windows) 
      I  discover that there is an Akitio 2, wich can use with iMac 2013 for productivity increase. I want to use akitio 2 with GTX 1050 ti 4Gb, but i dont know how it is intalling on iMac?
      Who can write for me the process of installation ALL equipment (akitio 2 + GTX 1050 ti + imac)? What i must to do? I talking about from the very beginning to the very end. 
      PLEASE everyone, help me. You are my last chance !!!!

    • By letobirra
      Hi guys, im selling a modified akitio thunder 2 enclosure with an nvidia zotac 960 ddr5 2gb. I also include the power supply unit, you wont have to do any aditional manipulation.
       
      http://www.ebay.es/itm/322614048182?ssPageName=STRK:MESELX:IT&_trksid=p3984.m1555.l2649
    • By Granty
      Hi guys. I have had my egpu setup and running fine for the past year or so on my mbp (mid 2012) which has a hdd drive.
      I now want to improve the gaming performance, so I've bought an ssd.
       
      I manage to get through all the steps in eGPU Setup 1.2 but when i go through the bootloader, it says at the very end "No bootable device -- insert boot disk and press any key".
       
      I'm guessing it is to do with my ssd being in the optical drive bay location (i assume this is hd1) and the original hdd (hd0) being disconnected, so windows can't see it when in bootloader.
       
      I think I need to edit the config file for the chainloader, so the bootloader reads the ssd but what exactly do i need to change? 
       
      I tried changing the map section (line 55):
      map --harddrives=1
      if "%DRV%"=="C"
       
      map (%FIRSTHDD%) (hd0)
       
      Changing the (hd0) to (hd1) put the bootloader in a loop!? So I am not sure what to try next...
       
      Any help is greatly appreciated!
       
      Thanks
    • By dnkei
      EDIT: SOLUTION on my 4th post.
       
      Hi all,
       
      I just wanted to know if anyone found a fix for the cpu idle bug without hibernating. 
      First of all, I made my setup in 2015 and I just used an external monitor since at the time making it work with optimus having a dgpu was unknown. Recently I read that disabling the dgpu was an option so I quickly got "up to date" reading the new stuff, but I might have missed something. Keeping that in mind:
      I have a MBPr Late 2013 (GT750M dgpu) with an Akitio Thunder Box, with a dell power supply (which I always thought it might not be enough because I had to limit the power with Afterburner to 80% so it wouldn't shut down when playing a few hours) and an Nvidia GTX970 (KFA 4GB).
      Since I was using a Win 7 on Bootcamp/BIOS I decided to start from scratch: got a Win 10 EFI installed, got reFind so I could activate the visibility of the Iris igpu, and although it seems to be much more buggy, got to run the system with the egpu. Then disabled the dgpu on the device manager, used the switch-gpu bat file as admin to get the igpu as main, so far so good. Shut down, Boot.
      I get to the point where I basically have the egpu working and I tried running Tomb Raider's benchmark (what I had at hand) and it was going smoothly (which wouldn't be like that with the iris or dgpu). Also, looking at msi afterburner my egpu was at 100%.

      The ONLY thing that I can't by any means get to work is to not have the CPU idle crazy load. I get around 25-30% of CPU load and if I try to hibernate the system it... well it goes to hell, haha.
      The MBP seems to hibernate (sleep/shutdown black, fans out) but the egpu is still on with the fans (doesn't really hibernate), and from there its impossible to make it run. Pressing any button, alt, power, whatever, it tries to wake up/power on for a moment, but it simply can't finish, just black screen with the fans turning on. The only way to shut it down is to hold the power button. And after that it basically locks there and becomes even difficult to boot again, I actually have to press alt, go back to osx, reinstall refind - since it no longer appears with it trying to wake up from hibernation- run windows efi and quickly press shift+f8 to run in safe mode and then boot correctly (and again with the cpu load).
       
      I have to say that even when working, my macbook pro doesn't consistently boot with the egpu via thunderbolt2, with any combination (wait to plug the cable, have it powered on, off, preboot, when starting windows, etc.) it just seems to randomly work. It used to work a bit better before refind, though, but never consistently (don't know if that has changed in the past years).
       
      So... any ideas of how to get that cpu load off? Or to make hibernation work? 
      Oh, as a note, I read that when you disable the dgpu and use the switchgpu script you can control the screen brightness again, but I just have it locked to the max. The control osd appears and moves but it doesn't actually change. I don't care about it but I thought it might give a hint of something not done properly?

      Many thanks to whoever can give me any ideas!!!
       
      EDIT: Reduced part of the cpu idle from known w10 small stuff but the main bug is still there, about 15%)
    • By matthieuv
      Hey guys,
       
      Let me introduce you my eGPU setup, realized on a 2013 15" retina Macbook Pro, model equipped with a dedicated GT 750M. I am using an Akitio Thunder2 PCIe enclosure and a EVGA Geforce GTX 1060 SC 6Gb.
       
      I wanted to use both internal and external display on my Mac.
       
      I was looking for information during weeks before buying it and wasn’t really sure if it would work as I wanted to. Many people are convinced that using the internal screen is impossible  or way more complicated if the Mac has a dedicated GPU.
       
       
       
      I spend a whole week formatting and testing, using UEFI, BIOS, considering going back to Windows 7 (not for long)…
       
      I finally used Windows 10 UEFI, the programs rEFInd and GPU-switch and nothing else !
      No need for an HDMI headless ghost or any program to spoof the number of screens.
       
      I made a video to show you the whole installation process, I hope that it will help:
       
       
       
       
       
      My GF did the voice acting as I wasn't convinced by my own
       
      If you prefer a text-based tutorial, here are the different steps:
       
      1)    Installation of Windows 10 in UEFI mode
       
      On the 2013 retina Macbook Pro, the SSD is a PCIe model. This seems related to the UEFI mode used by default when using the Boot camp assistant. If you don’t want to use it or are using another model of Macbook, you can follow this excellent tutorial to force the UEFI mode:
      http://fgimian.github.io/blog/2016/03/12/installing-windows-10-on-a-mac-without-bootcamp/
       
      You just need to create a conventional partition and convert your table partition from “hybrid” to “protective”. By doing this, Windows will see a GPT disk instead of MBR. You just need to boot your USB drive on EFI mode.
       
      Once Windows is properly installed with the correct Macbook drivers (another reason to prefer the boot camp assistant), you need to go back to Mac OS.
       
      2)    Installing rEFInd
       
      rEFInd is a boot manager tool, like rEFIt or GRUB. Its first advantage is the ability to choose the OS without the need to press a key at startup. And the real reason why we are using it is to spoof the computer to allow Windows seeing the entire installed hardware.
       
      You can install refind from this link: http://www.rodsbooks.com/refind/
       
      Then you need to activate this spoof ability by opening a terminal and typing these two commands:
       
      sudo mkdir /Volumes/efi
      sudo mount -t msdos /dev/disk0s1 /Volumes/efi
       
       
      Now, you can see your EFI partition in your Finder.
      Go to EFI/EFI/refind and open the file refind.conf with textedit.
       
      Search for the “spoof OS version” and remove the comment symbol #
       
      Reboot your computer and choose Windows on the rEFInd screen.
      Open your device manager, you’ll see your iGPU (intel iris pro graphics 5200) and dGPU (Geforce GT 750M)
       
      3)    gpu-switch
       
      GPU-switch can be downloaded from there: https://github.com/0xbb/gpu-switch
      Download the windows version, available in the description
      (direct link : https://github.com/0xbb/gpu-switch/releases/download/v0/gpu-switch-windows.zip )
       
      Install Microsoft C++ redistributable (not sure which version do the trick, I’ve installed each version in x64 and x86 just to be sure)
      open the file integrated.bat with administrator rights, you should see the word “success”
       
      4)    GPU driver installation
       
      Not sure if this step is necessary but I’ve removed the dGPU driver before installing nVidia GeForce experience. The program DDU (Display Driver Uninstaller) is perfect for that.
      You can download it using this link: http://www.guru3d.com/files-details/display-driver-uninstaller-download.html
       
      Choose to uninstall and shutdown the computer, as you will install a new hardware indeed
       
      When your computer is off, plug the power supply to your eGPU, press the computer power button, wait for the chime and the rEFInd screen to appear, then plug your eGPU to the Macbook and launch Windows. If rEFInd is stucked, hold the power button until the computer is off.
       
      You should now see three graphics cards in the device manager, two of them not recognized at this point.
      Install nVidia GeForce experience and the latest nVidia driver. The GPU list will be updated at the end of the installation process.
      Re-launch GPU-switch and reboot. You don’t need to unplug the eGPU when rebooting.
       
      Now, your eGPU should have an error code 12, with unsufficient resources available.
      Just right clic on the dGPU (GT 750M) and disable it. Re-launch gpu-switch just to be sure (integrated.bat) and reboot.
       
      Just a last step and you’ll good to go
      Right click on the nVidia icon in your systray and open the configuration panel. Go to PhysX and set it to automatic instead of processor, like on this picture:
       
       
       
      That’s it, you can now launch your games on the internal screen or using an external monitor
       
      To switch between both, just plug the display on the eGPU and use the shortcut Win + P (Cmd + P on a Mac keyboard) to toggle between both screens.
       

       
      You can also duplicate them, it works, but don’t expect any kind of good performances doing this
       
       
      Now, the most important part, to avoid screwing your configuration: every time you go back to Mac OS, Windows will switch to the dedicated GPU (maybe also when turning off the computer, I’m not sure).
      For this reason, always re-enable the GT 750M before turning off the computer! Otherwise, you’ll get a black screen at Windows startup.
       
      Just follow this procedure when you want to use your eGPU:
      -       Use gpu-switch to set the integrated GPU as primary
      -       Disable the dGPU from the device manager
      -       Turn off your computer or reboot
      -       When you see the reEFInd screen, plug your eGPU and launch Windows
      -       Play you favorite video game or launch your intensive GPU application (there are two schools)
      -       Re-enable your dGPU from the device manager
      -       Turn off your computer
      -       Unplug your eGPU
       
       
      Now, some advices based on my little experience:
       
      If your end up with a black screen, you can restore Windows to a previous restauration point or remove the display driver. If you really can’t boot windows, using Parallels Desktop, you can boot your Windows partition from a virtual machine, then remove the display driver.
       
      At first, I was experiencing a game crash and the GPU fan running at max speed, when launching any sort of game. This issue was caused by the power supply connection, using an Xbox 360 S adapter with too thin wires
       
      These wires caused a voltage drop when consuming the 100W needed when playing a game (against 15W on Windows)
       
      About the electrical connections, here are a few pictures
       
       
      I’ve added a connector on the free PCB footprint to avoid soldering wires on the board. The cables are 0,75mm2 section and fits perfectly the original jack hole.
      About the PCIe power connector at the top of the graphic card, I had to cut it with a Dremel to fit the enclosure. You can find specific (and pretty expensive) cables on Ebay if you don’t want to modify one.
       

       
       
      For the ventilation, a colleague helped me cutting holes in front of the fan. I’m not sure to keep this solution, as some games make it very noisy.
       

       
       
      Let me know if this tutorial or the video did help you. Don't hesitate to ask for support if you want to do the same setup.
       
      Some websites are pretty discouraging about the concept of eGPU, the whole process is not pretty user-friendly but I'm happy to see that there is an active community growing each year !
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.