Jump to content
Apologies for the spam Read more... ×
EwinRacing Flash Series Gaming Chairs
wejgomi

GTX 970M Black Screen in Windows 10

Recommended Posts

Hi,

 

Long time member and even longer a lurker. I've modded and OC'ed various GPU's using the vbios' shared in the forums, however I'm having problem with the 970M 3gb, which I've gathered recently from ebay. I hope it hasn't been asked a zillion times.

 

I bought a 970M 3gb model which goes by the model name MS-1W0J1, and been trying to get it working on an Alienware M18x r2. I've successfully installed the card and it seemed to work plug and play. The card is recognised by BIOS and I get video output in startup menus, both in EFI and LEGACY modes(I'm using Swick's latest bios for this model).

 

However, there seems to be a problem when installing the Geforce drivers(both 380&390) in Windows 10, as the screen goes black instantly when the driver has been updated. I can't get any video output in Windows, and the only option is to switch to integrated card and remove the drivers.

 

I've seen different mods and modded vbios' for 970M cards, but none seems to be for the 3gb model. I wonder if there is a way to set-up this card on this hardware and flash a compatible CLEVO vbios to get it running without issues. Current vBIOS is attached.

 

Thanks in advance,

Wejgomi

GM204.rom

Edited by wejgomi
Bios added

Share this post


Link to post
Share on other sites

You could ask for a 3GB version in the corresponding Maxwell VBIOS thread. Anyway, I would recommend you to uninstall all VGA drivers of both the iGPU and the nvida drivers, then freshly installing the iGPU drivers first followed by nvidia drivers.

Share this post


Link to post
Share on other sites
49 minutes ago, sirana said:

You could ask for a 3GB version in the corresponding Maxwell VBIOS thread. Anyway, I would recommend you to uninstall all VGA drivers of both the iGPU and the nvida drivers, then freshly installing the iGPU drivers first followed by nvidia drivers.

 

Thanks for your reply. I tried uninstalling both drivers using DDU to no avail. I already have the iGPU disabled in BIOS and soon as I re-install the drivers using modified inf, the screen goes black again. I believe this is not a driver-related issue as I have tried other OS'es as ubuntu and OSX, yet the problem persists.

Share this post


Link to post
Share on other sites
4 hours ago, wejgomi said:

 

Thanks for your reply. I tried uninstalling both drivers using DDU to no avail. I already have the iGPU disabled in BIOS and soon as I re-install the drivers using modified inf, the screen goes black again. I believe this is not a driver-related issue as I have tried other OS'es as ubuntu and OSX, yet the problem persists.

Well, I am 99% sure you MUST have the iGPU enabled, install Intel HD drivers, then install Nvidia's GeForce drivers. As far as I know it has always been this way with Optimus-Notebooks. Without the Intel HD drivers nothing works :D

Share this post


Link to post
Share on other sites

The m18x R2 can choose between the igpu (called IGFX in bios) and dgpu (called PEG in bios) as the primary gpu. What is it currently set to?

 

Ideally you want the bios set to PEG for optimal performance, and if I remember right there's a bios issue that makes PEG only work in UEFI boot.

 

If PEG doesn't work though, then try IGFX

Share this post


Link to post
Share on other sites

Yes, the GFX setting is set to PEG and I'm booting Windows 10 in UEFI mode. What's weird is after many restarts, the screen came up in Windows randomly. I'm not sure if everything is OK now and bit afraid to restart again to try, but I guess I'm having the issue of black screen after cold boot/hibernate which has been discussed in some topics.

 

I am running 369.0 drivers with modified .inf(else won't install) and I also tried the GFX setting in AUTO mode but same result. Thanks.

 

Edit: No, the problem is actually the opposite. I still get the same black screen no matter how I cold/hot boot or restart and the trick is to let the computer go to sleep and when it wakes up, it comes back with the screen. Go figure :)

Edited by wejgomi
New argument

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By learnfromit
      alienware 15 r2 970m with i7-6700hq vbios request so i can overclock and mess with voltage.

      BIOS version backup made with techpowerup GPU-z.

      GM204.rom
       
      or can someone re direct me to one already made that will work? all links i find are dead, thanks.

    • By Adomis63
      Hi guys,
       
      I'm sorry for making another thread just for this but I really wanted to pick your brains on this!
       
      I have an m15x with a 770m running windows 7 and everything works. Rock. Solid. I'm pretty happy with it. Since windows 7 is on it's way out, I would like to upgrade to windows 10. Now I've looked into it before and had a really hard time getting the 770m to behave nicely and had all these issues with green/yellow/pink screens and I remember it being a miracle I got it to work on 7 as good as it does.
       
      My question is how well does the 970m install vs the 770m - particularly on windows 10? I would buy it in a heartbeat if it makes the install less tedious with the colored screens and all that. Especially if all the functions work on it! I have been searching the internet and I cannot find nearly as many problems with the 970m as I could with the 770m, or am I just  not looking in the right places?
       
      Thanks a million!
    • By Seolly
      I have several questions on upgrading my M18X R2.
      My rig's GPU is 680m and video ram is 2GB. It's a relic :p So I will change it to 980m.
       
      1. Is it working on windows 7? (If it works, legacy or UEFI mode?)
      2. Is 980m /w G-sync compatible with my rig? 
      3. Are there any compatibility issues with M18X R2 and Windows 10? 
       
      I tried to find useful information far as I can do, but my English ability sucks :S
       
      Guys, please help me!
    • By Psycha
      Hello, I'm on an alienware m17 r4 and am trying mod my vbios for a 970m 3GB msi. I've managed to get the max boost with an increase in voltage, however I believe my voltage settings maybe unstable. When attempting to load programs capable of high gpu usage capabilities, the gpu begins to become pretty unstable. would anyone be able to provide assistance? I have both my edited and original roms as well.
       
      *update
       
      I'm not sure how to delete this thread but disregard this please. I've figured out the issue.
    • By Night
      My laptop doesn't display when I turn discrete mode it work only on mshybrit mode.I plug hdmı cable to pc it display to tv.Gpu z program show no uefi support on 970m(6gb) but  ıt show on intel hd  630 there is no problem about screen ıt justy problen on vbios ı thınk ı cant fınd on ınternet stock gpu vbios  can anybody help for it or to fix this promblem?
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.