Jump to content
DanKnight

US$300 AKiTiO Thunder3 PCIe Box (32Gbps-TB3)

Recommended Posts

UPDATE: It is now available on Amazonhttps://amzn.com/B01K5Z13I2

Hi guys,

 

Just wanted to share this with you guys! If yall been waiting for a Thunderbolt 3 version.


https://www.akitio.com/press-releases/2016/akitio-unveils-thunder3-pcie-box

 

MSRP $299.99

Available sometime this month.

Edited by DanKnight

Share this post


Link to post
Share on other sites

I hope we see some tests with different notebooks soon after this baby is released.

Depending on the cost of the other cases that are to be released it might even be a viable option.

Share this post


Link to post
Share on other sites
12 hours ago, rene_canlas said:

Anyone order this yet? Reviews please! :)

Its no longer available. 

 

Share this post


Link to post
Share on other sites

INFO: First pics of a AKiTIO Thunder3 DIY eGPU

 

@benjaminlsr presents the first eGPU build with a AKiTiO Thunder3 at https://www.techinferno.com/index.php?/forums/topic/10280-intel-nuc6i7kyk-gtx106032gbps-tb3-akitio-thunder3/&do=findComment&comment=149495  quoted below.  Thank you :)

 

Looks to have the same chassis as the AKiTiO Thunder2 with some slight cosmetic differences and of course a TB3 internal board. I would expect the same AKiTiO Thunder2 power and chassis mods can be applied here.

 

On 13/09/2016 at 6:17 AM, benjaminlsr said:

I received the Thunder3 model at 6PM local time. Here it is modded and working at 10PM (including meal time).

 

- Created 8 pins wires coming from barrel plug (4x 12v, 4x GROUND).

- Drilled a 110mm hole.

- Fixed a 120mm fan protection.

 

PART_1473713627177_P_20160912_193347.jpg

PART_1473713634894_P_20160912_194453.jpg

 

IMG_20160912_220417.jpg

IMG_20160912_220421.jpg

IMG_20160912_220426.jpg

 

  • Thumbs Up 4

Share this post


Link to post
Share on other sites

Pay attention ! There are stability issues between TB3 (maybe 2 also) and Wifi 2.4Ghz ! If you're egpu is disconnecting randomly, try to use a 5Ghz network and/or ethernet wire.

It works 

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
1 hour ago, benjaminlsr said:

Pay attention ! There are stability issues between TB3 (maybe 2 also) and Wifi 2.4Ghz ! If you're egpu is disconnecting randomly, try to use a 5Ghz network and/or ethernet wire.

It works 

Hmm..no issues on my end. Used a 1080 + TB3 HDK (Akitio TB3 PCIe Box) + the Intel 8260. I used this setup for about 5 days, before switching over to M.2. 

Edited by bloodhawk

Share this post


Link to post
Share on other sites
10 hours ago, bloodhawk said:

Hmm..no issues on my end. Used a 1080 + TB3 HDK (Akitio TB3 PCIe Box) + the Intel 8260. I used this setup for about 5 days, before switching over to M.2. 

Well maybe the issue only/mostly appears with small form factor computer (NUC6i7KYK). The issue is realy "gone" since I switched to ethernet and then to 5Ghz.

I've read this information somewhere online on a razer core discussion having disconnection issues.

Share this post


Link to post
Share on other sites
7 hours ago, benjaminlsr said:

Well maybe the issue only/mostly appears with small form factor computer (NUC6i7KYK). The issue is realy "gone" since I switched to ethernet and then to 5Ghz.

I've read this information somewhere online on a razer core discussion having disconnection issues.

Gotcha. Ill do some more testing tonight and see if it shows up on my end.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Blocker35
      Hi guys, bit of a rookie to the whole EGPU scene. Currently I have:
       
      - MacBook Pro 2015 13inch (3.1GHz Core i7 16GB RAM)
      - Razer X Core 
      - Apple TB3 to TB2 Adapter
      -  TB2 Cable (Cable Matters)
      - 23inch AOC External Monitor
       
      I am wonder about what graphics card to get to run X-Plane11 with high graphic settings?
      I have purgewrangler set up and ready to use with an AMD graphics card, but am also open to the idea of an Nvidia graphics card.
      Any advice appreciated. I did not buy a Windows PC as I need a Mac for various other things and wanted an all-in-one laptop.
    • By SnipeKing17
      The GPU works, The PSU works, The system works. [individually they all do work]
       
      The system works perfectly fine without the WLAN card.
       
      When i put the system to sleep and hotswap the mPCIe riser and WLAN press something on the keyboard.. Restarts.
      Will shutdown in roughly 27 seconds for those 27 seconds it works just fine like how it normally would on external monitor.
       
      When i shut it down and plug the riser and switch it on, same story. 27 seconds.
       
      I don't even see a error. I get to login screen directly. I used DDU already.
       
      I timed it. no matter what i do if i use the eGPU, External monitor it restarts instead of pause-play. I have 27 seconds.
       
      Need help!
    • By Kel
      I got the exp gdc beast 8.5 got all the connections right... laptop boots up... fans turn on the gpu.... device manager detects gtx 1060 with a “ ! “ in a yellow triangle. Now what to do.... i tried to do the bios mod.... but realised that i have 3.07 version. 
      Questions-
      1 is there any way to get this done without the mod?? 
      2 if mod is the only way... kindly help me with step by step instruction in laymans terms... i m not a techy... so i might not understand technical terms.... altho i am interested... but learning yet. Please help. 
    • By Drozof
      Has any company out there launched a laptop with an external MXM port? 
       
      Just curious since with the boom in the gaming laptop market and some companies launching eGPU thunderbolt enclosures, isnt the MXM faster?
       
      Is it because of licensing issues? or hardware problems?
       
    • By Iwillsolo
      Hello guys ...

      i wanna make sure that everything is going to work fine with my laptop so i got some questions

      First of all my laptop is Lenovo Z51-70
      CPU: I5-5200U 2.2ghz
      iGPU Intel HD 5500
      dGPU:AMD R9 M375
      Ram: 8GB (will raise it to 16GB)
      HDD: 1TB stock one
      SSD: 120GB (for my games and windows only)

      now i investigated  a little about eGPUs and found that i need a M.2 or thunderbolt, i've found that my wifi card use a M.2 a/e key aka ngff, so i will be using the GDC Beast NGFF version

      to the bad part / question part

      What do i need to know other than the stuff above?
      what is the white-listing thing? i found on support forums that my laptop support some wifi cards only and it's bios cann't be modified according to bios modifying forums (not here)
      in same time saw some posts on reddit that says if ur bios have UMA graphic option then you will need to disable PAX / WIRELESS and enable UMA and it will work fine, the question is that true?

      i wasn't able to find anyone who did it on Z51-70 i found only 1 post on reddit for Z41-70 (which after research found that both are using same M.2 a/e key slot and also same bios... but the one who posted only replied that it's recognized with some errors and never replied back with any updates so still not sure about it.....

       
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.