Jump to content
EwinRacing Flash Series Gaming Chairs
mrdatamx

14" Lenovo T400 + GTX970@2Gbps-EC (EXP GDC v8.3) + Win 10 [mrdatamx]

Recommended Posts

I was able to spare some time and implement an eGPU with my wife's T400, here is a brief documentation.

 

System:

Lenovo T400

Intel Core2Duo P9600

8 GB DDR3

 

eGPU:

EXP GDC v8.3 ExpressCard

nVidia GTX 970

350w 80+ Bronze PSU

 

Steps:

  1. Booted into windows and downloaded the most recent drivers as well as DDU.
  2. Executed DDU and set it to reboot in safe mode. Rebooted.
  3. Removed all previously installed video drivers using DDU and shut down.
  4. Plugged in eGPU in ExpressCard slot. Unable to boot. Initial boot sequence looping.
  5. Unplugged eGPU and tried to boot.
  6. Logged into Windows and set the system to sleep.
  7. Plugged in the eGPU and woke up the system.
  8. eGPU was recognised. Installed drivers and rebooted.
  9. Device manager showed error code 12.
  10. Not using Setup 1.x proceeded to perform DSDT substitution according to the guide.
  11. I followed the listed steps. I did not have any error during the procedure, just some warnings, however, the generated file was not working. Windows was crashing when trying to load the DSDT tables.
  12. I had to generate the same .aml file a couple of times using two "iasl" from both referenced packages. What seemed to fix the issue was executing "iasl dsdt.asl" instead of "iasl -oa dsdt.asl"
  13. Once Windows was able to boot correctly I verified the new "Large Memory" was activated.
  14. Suspended the system.
  15. Plugged in the eGPU and woke the system up.
  16. Windows woke up, recognised the eGPU and enabled it.
  17. Installed 3d Mark 06. Tweaked some drivers parameters using Nvidia Control Panel
  18. Tested the setup.
  19. Done
 
Using 3d Mark 06 and an external LCD this system scored: 12861
Now she is able to game with a decent experience using her everyday laptop.

Share this post


Link to post
Share on other sites

Nice to hear it's working for you. I wish it was for me!

 

I have a Lenovo T530 (i5-3320M, 16GB RAM) and the EXP GDC v8 ExpressCard adapter and I can't run a 3d benchmark test without the eGPU turning off immediately. I have Setup 1.30 that performs a DSDT substitution and that works with no problems, but it seems when I run anything remotely graphically intensive it turns itself off.

 

 

Edited by goochmonster
Grammar
  • Thumbs Up 1

Share this post


Link to post
Share on other sites
On 4.10.2016 at 2:38 AM, goochmonster said:

Nice to hear it's working for you. I wish it was for me!

 

I have a Lenovo T530 (i5-3320M, 16GB RAM) and the EXP GDC v8 ExpressCard adapter and I can't run a 3d benchmark test without the eGPU turning off immediately. I have Setup 1.30 that performs a DSDT substitution and that works with no problems, but it seems when I run anything remotely graphically intensive it turns itself off.

 

 

 

When I first started using an eGPU, I had a Lenovo X230 and a BPlus Expresscard adapter. Initially I tried to use a GTX470 with the 180W Dell power adapter I had. It would work fine until I put the card under load and then it would shut down immediately. The reason was that the GTX470 consumed a lot more than 180W of power (a different card worked flawlessly with that setup later on). I suspect your issue may be similar: You may be struggling to feed your video card with enough power.

Share this post


Link to post
Share on other sites

I have a Enermax 500 watt modular PSU. The card is powered through the 8-pin connector that connects to the 24-pin (motherboard) and 4-pin (CPU) cables on the PSU. There is also additional power to the card using a dual molex to 8 pin cable. Here's a picture of my setup at the moment. It should have all the power it needs...

 

 

IMG_0500.JPG

Share this post


Link to post
Share on other sites

Umm, yeah. A GTX750Ti doesn't consume a lot of power at all, so it should work with pretty much any PSU. Since the OP has a GTX970 and you didn't state what your eGPU was, I assumed a similar, more-power-hungry card. Sorry!

Edited by Yukikaze
  • Thumbs Up 1

Share this post


Link to post
Share on other sites

To mrdatamx,

I would like to know more about the dsdt, I am currently having the error 12 (not enough resources or something like that) and I would like to fix it. You mentioned a guide, can you kindly provide that for me please, thanks.

 

Nevermind, I managed to fix it by disabling a bunch of stuff in my device manager.

Edited by Mr_Western

Share this post


Link to post
Share on other sites
On 4.10.2016 at 11:38 AM, goochmonster said:

Nice to hear it's working for you. I wish it was for me!

 

I have a Lenovo T530 (i5-3320M, 16GB RAM) and the EXP GDC v8 ExpressCard adapter and I can't run a 3d benchmark test without the eGPU turning off immediately. I have Setup 1.30 that performs a DSDT substitution and that works with no problems, but it seems when I run anything remotely graphically intensive it turns itself off.

 

 

I've got stability crashes on my T430 when I was changing EXpresscard-HDMI cables between V6 and V8 of EXPGDC adapter, and when a was tring to extend the lenght of this cable by adding an aditional HDMI cable. Maybe there is soemthing wrong with yours???? T530 and T430 are same architecture just size is diffrent.

Share this post


Link to post
Share on other sites

Hi!

 

I wonder if you can help me:
 
Follow my Setup
Lenovo T400 - 8gb RAM, Intel Core 2 Duo T9900 - Windows 10 64bit
EXP GDC beast - expressCard - Asus GTX750 ti oc 02Gb
 
I did the DSDT replacement process, big memory (memória grande) appeared successfully.
 
->Image1
 
I do the process using setup 1.35, but when I connect the note, the gtx750 does not show up where it should. (Only the internal video adapter appears)
 
->Image2
 
She appears here, System devices (dispositivos do sistema.) 
 
->image3
 
 
 
Do you have any idea how to fix it?

Image1.png

Image2.png

Image3.png

Edited by Thiago_Stark

Share this post


Link to post
Share on other sites

Hi Thiago_Stark,

 

I can't see all of your images...I wrote a step by step guide to how I got my setup working. It's very detailed with pictures. I'm about to put it on a blog if you're interested?

 

 

Edited by goochmonster

Share this post


Link to post
Share on other sites
Nice to hear it's working for you. I wish it was for me!

 

I have a Lenovo T530 (i5-3320M, 16GB RAM) and the EXP GDC v8 ExpressCard adapter and I can't run a 3d benchmark test without the eGPU turning off immediately. I have Setup 1.30 that performs a DSDT substitution and that works with no problems, but it seems when I run anything remotely graphically intensive it turns itself off.

 

 


Hey have you tried you tried the procedure he has given in the middle it was initially not working for me too if you need help I can help you it worked for me later strangely I actually did some steps exactly the way he did

Sent from my SM-J700F using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.