Jump to content
EwinRacing Flash Series Gaming Chairs
PixelRaide

MSI GX660 upgrade, does it worth it ?

Recommended Posts

Hi guys !

 

I'm currently giving a second life to my GX660-405 (i7 740QM / 6Go RAM /  5870M / 15,6") :

 

- replaced the fan because one little part of plastic was broken. 

- installed a SSD for the OS.

- replaced the keyboard because the "x" wasn't working anymore.

- upgraded the CPU, it's now a 920XM

- bought the Targus 180W power adapter

 

I'm looking for the modified BIOS in the specific thread to be able to take a look to the overclocking potential of my new 920XM.

 

I have a question for you guys : i7 920XM  + 180W power adapter.  do i have to limit myself to a GTX 770M if i want to upgrade because of the Max TDP (and because the price isn't crazy high) ?

 

What performance should i expect from the 920XM/770M combo ?

 

Do you think it is still relevant to invest in such an "old" laptop ?

 

Last question : Since i installed the new CPU, sometimes when i unplug the power adapter the laptop immediatly shuts down and sometimes it's running on the battery like usual. What do you think it could be ?

 

Sorry for this bunch of questions but i have to admit that i'm not that aware of is going on in the laptop world !

 

Thanks :D

Edited by PixelRaide
of --> to

Share this post


Link to post
Share on other sites

Hello

 

Don`t buy a GTX 770M,this is very expensive and not nessesary.

The Best Choise for Your Money You will get with a GTX xxxMX or a Quadro KxxxM.

All this Cards are working in Your Barebone,also the GTX 970M/GTX 980M.

I think the best Choise is the GTX 675MX or the Quadro K4100M for nearly 200€

The Performance is like the GTX 680M with 6000-6500 Points in 3Dmark11 with OC Vbios.

 

Share this post


Link to post
Share on other sites

i found a GTX 770M for around 260€ and a k4100M for around 250€. So the prices aren't that different at the fisrt look.

 

I have one question : The k4100M seems to have a TDP of 100W, this number will rise if i want to overclock it. The 770M have a TDP of 50-55 (according to notebookcheck).

 

It seems logical to prefer the 770M, with less heat and a better overclocking potential no ?

 

By the way i only have a 180W power adapter,.

 

What do you think ? 

 

Anyway, thanks for your answer, very appreciated !

Share this post


Link to post
Share on other sites

The Performance of the K4100M is much more better than the GTX 770M,You only need a modified Vbios for it.

K4100M is with 824MHz simular to GTX 680M,the TPD is no Problem.

The Temperature is also no Problem and the Heatsink for both are the same.

It is also not possible to use a Power Adapter with more than 180W,because it is locked in the EC Firmware at this Value.

K4100M

http://www.3dmark.com/3dm11/11264952

http://www.3dmark.com/3dm11/11264968

GTX 670MX

http://www.3dmark.com/3dm11/11341403

http://www.3dmark.com/3dm11/11331966

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Thanks for this new answer !

 

Will take a look to the k4100M when i will have the money (already paid a lot this month to bring back this laptop to life).

 

If i understood well, i will have to find a heatsink from GTX 460M/560M to fit with this kind of card. It seems to be hard to find one on ebay for what i saw. 

 

Hoped that my original heatsink could fit with a little mod...

Share this post


Link to post
Share on other sites

Thanks for those tips ! 

 

The main issue seems to be the heatsink : really hard to find one. Looked after that for a hour now and found nothing...

 

A lot of people have, i think, already bought a lot of them for their upgrade... 

Share this post


Link to post
Share on other sites

Today i got my K4000M,here the 3Dmark11.

It works very well with HP OC Vbios without modded Driver in GX660R

The Performance Value could be better,it is without Turbo because i didn`t install scm.

And i have only 4GB Ram installed,is only for Testing.

It is a little faster than a overclocked GTX 770M because the K4000M have 256Bit.

http://www.3dmark.com/3dm11/11406972

Edited by Bloetschkopf

Share this post


Link to post
Share on other sites

Hi Bloetschkopf ! Just ordered a k4100m, found one on ebay from a seller in my country and for 160€ (delivery fees included). 

Already  downloaded your vBIOS, can't wait to try this baby. 

 

I have three questions for you : 

 

- The K4100m come from a  Dell Precision M6800, is it good ?

- You said in an other thread " 920XM is definitely a good upgrade compared to 720qm. I had one one a GX660 and with unlocked bios (and thottlestop) I ran rock stable @ 3.36Ghz on 4 core (140 x 24). So nearly twice as much as 1.73ghz of 720qm on 4 core.

What were your temps at that time with your 920XM ? When i'm playing i'm around 75 degrees Celsius with an agressive fan profile. Tried to overclock but temps easily goes in the low 90's. Had you an external cooler ? What is the secret behind this crazy overclock ? 

 

- Which kind of thermal pad is needed to fill up the gaps of the heatsink (one from a 570m) ?

Edited by PixelRaide
added one question

Share this post


Link to post
Share on other sites

Hello

 

I never had a Dell M6800,i only bought the Card from it and changed the Clockrates.

If You use a i7-920XM,it is better to use the Heatsink with CPU Bridge for Keplercards

The CPU will go very high with the Temperature,the Cooler Boost Heatsink will help take down it.

Thermalpads with minimum 5-7W/mK,the original are ca. 5W/mK.

 

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hi, thanks for your answers !

 

Alright, i only wanted you to confirm that this card is compatible so it's great :)

 

The cooler boost 2 heatsink isn't easy to find, will take a look from time to time.

 

Won't do any overclock until i find one.

 

Thanks, 

 

efforts appreciated !

 

 

Share this post


Link to post
Share on other sites

I'm reviving this old thread to give eventual GX660 owners an update about what they can expect from their computer.

 

i finally found a heatsink with the CPU bridge for a decent price (from ebay, ordered from a seller in the USA, it was cheaper than what i could find in germany. I'm living in France btw).

 

At the end of the week i will finally install the K4100m i bought in 2016 (yes, it is a long term project).

 

I will come back here and give my impressions and some numbers.

 

Hope i will not be disappointed with the performance that the 920XM and the overclocked K4100M can provide.

 

This is the last update i'm planning to do for my precious GX660 that served me well for 6 years now.

 

I'm still amazed by this old laptop and can't imagine selling it even if i have a pretty decent gaming RIG.

 

Hail to the GX660 !

 

Share this post


Link to post
Share on other sites

Hi Bloetschkopf !

 

Installed the new card and it doesn't pass the BIOS screen and i can't access the BIOS's settings anymore.

 

Any idea ? 

 

If i wait the screen just go black and there nothing happen after that.

 

I reseted my windows and uninstalled the drivers of my 5870m

 

EDIT : Maybe it is linked to a bad vbios ? When i put back my 5870m it's working again...

 

Need to flash your vbios but i can't access to the boot menu to boot on the usb drive...

Edited by PixelRaide
i'm looking for a solution for 4 hours now

Share this post


Link to post
Share on other sites

I think the card is from Dell,then You must find another Way to flash the Vbios.

Maybe You have a Friend with another Laptop where You can flash it.

 

Share this post


Link to post
Share on other sites

Yes it's from dell.

 

And no i haven't any friend with this kind of laptop.

 

Well, i'm doomed...

Share this post


Link to post
Share on other sites

Do you think that a blind flash can't be achieved to fix it by myself ?

 

i really don't want to buy an other card...

 

EDIT : sometimes, when the USB drive with FreeDOS is plugged, if i let the computer run, it will end by showing me the first screen of the FreeDOS OS, the one where you can chose your keyboard layout. 

 

At this point, the keyboard seems to be unresponsive because nothing seems to happen when i press enter or any other key. It's maybe the OS which is frozen...

Edited by PixelRaide
findings

Share this post


Link to post
Share on other sites

I MADE IT !

 

Successfully flashed the vBios by myself using a Win98 DOS instead of FreeDos !

 

Reinstalling the whole Windows 10 right now, coming back soon to give you updates !

 

Hell yeah !

 

EDIT : The vbios you provided me seems to be too high, temps goes quickly to 93°C in 3Dmark (firestrike) and the core clock is throttling.

 

The kepler heatsink should provide sufficient cooling capabilities for your vbios no ?

 

i used some Arctic Silver 5 thermal paste i put some new thermal pads on the components, it should be enough.

 

BTW thanks again for your vBios, really appreciated ;)

 

EDIT 2 :

 

Maybe the heatsink isn't properly fitting on the chip, the thermal pads that i used are larger than the original ones. They are soft and i though that the pressure of the heatsink could be enough to flat them well.

Edited by PixelRaide
other question asked

Share this post


Link to post
Share on other sites
I MADE IT !

 

Successfully flashed the vBios by myself using a Win98 DOS instead of FreeDos !

 

Reinstalling the whole Windows 10 right now, coming back soon to give you updates !

 

Hell yeah !

 

EDIT : The vbios you provided me seems to be too high, temps goes quickly to 93°C in 3Dmark (firestrike) and the core clock is throttling.

 

The kepler heatsink should provide sufficient cooling capabilities for your vbios no ?

 

i used some Arctic Silver 5 thermal paste i put some new thermal pads on the components, it should be enough.

 

BTW thanks again for your vBios, really appreciated [emoji6]

 

EDIT 2 :

 

Maybe the heatsink isn't properly fitting on the chip, the thermal pads that i used are larger than the original ones. They are soft and i though that the pressure of the heatsink could be enough to flat them well.


Hello guys,

Did you find a solution for the temperature?

I have an MSI Gx683dxr with a gtx570m, anyone know if the GTX680m 2GB from an alienware will work? My cousin has one and he can send me for free.

Thank you,

Enviado do meu SM-N9005 através de Tapatalk

Share this post


Link to post
Share on other sites

Hello,

 

I'm using my laptop for my studies right now so i'm only using Word and Chrome, don't have time to play so i have no time to investigate on the temps.

 

The Vbios that Bloetschkopf gave me is overclocked, if i downclock the frequencies to their initial state the temps are acceptable (~85°C).

 

In the future i certainly will take a closer look on the heatsink, the thermal paste etc. to exploite the full OC potential of the K4100M.

 

If you can get it for free and if you have a heatsink that fit (don't know your laptop and don't have time to search sorry !) you should catch this opportunity !

 

Hope you will not struggle too much with the vBios as i did as it's coming from an Alienware. At least you know that the HP USB tool and the Win98 DOS can help you :)

 

Good luck !

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

If the temperature goes to 93° something is wrong with Your cooler.

I had used more than one Keplercard in this Barebone,also with  OC the Temperature goes never to 93°

Only the GTX 880M make this Temperature in Full lLoad.

824MHz is nothing for this Card,this is the normal Coreclock from the GTX 780M.

 

Share this post


Link to post
Share on other sites
13 minutes ago, Bloetschkopf said:

If the temperature goes to 93° something is wrong with Your cooler.

I had used more than one Keplercard in this Barebone,also with  OC the Temperature goes never to 93°

Only the GTX 880M make this Temperature in Full lLoad.

824MHz is nothing for this Card,this is the normal Coreclock from the GTX 780M.

 

 

I will look at it one of this days, i know that those temps aren't normal.

 

Like i told you before, i think that the thermal pads i used dont let the heatsink fit properly on the chip. 

 

As i'm using the computer, i hope that the heat and the pressure will do their job to flat them !

 

will come back here anytime i have some updates about that !

 

For now i have an other issue to solve : The laptop isn't working when using the battery : If it's plugged, perfect.

 

If i unplug it, even with the battery in it, immediat shutdown.

 

Can't starts it if unplugged.

 

In Windows it tells me that the battery is charging and the LED of the touchpad is orange (or blue).

 

Wierd !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.