Jump to content
Apologies for the spam Read more... ×
EwinRacing Flash Series Gaming Chairs
Chevrotine669

help : eGPU usage 0%

Recommended Posts

So, I've tried everything I found out there, and nothing does the trick. 

I found some pages where they said that, apparently, windows 10's Optimus is not  working correctly and they can't use their eGPUs anymore. 

So, since I still have my Windows 8.1 installation CD, I'm gonna downgrade it from windows 10 to 8.1 and see if THAT does solve my problem.

 

Wish me luck.

Edited by Chevrotine669

Share this post


Link to post
Share on other sites
On 6/07/2016 at 2:23 AM, Chevrotine669 said:

yes I was. I always do restart it in safe mode.

 

edit: As desperate as I am right now, I tried some things I read on other websites like this one:

http://www.owen-lu.com/egpu/

(look for the "driver" §)

As well a this video:

 

Both have similarities with what you told me to do, but for instance, they don't comment out the 2 lines in the dispi. file ...

 

After having tried both of them, I had the following results:

The problem isn't solved, but the driver installation does NOT fail and finishes properly.

Which is kinda like installing the vanilla driver actually. 

No real help there.

 

Oh and I also tried a benchmark with my 960 which does make it's usage go up to 60-80%. IDK if this is any help to you..

So i'm guessing it IS indeed an optimus problem.

 

It is necessary to comment out the lines in the dispi file - this disables the non optimus drivers. When you add the lines with a section that refers to NVSupportOptimus = 1, you are telling the installer to use an optimus enabld driver for your card.

 

I have it running on my internal screen on windows 10, so it IS possible to get it working.

Share this post


Link to post
Share on other sites
On 3/07/2016 at 5:18 PM, Chevrotine669 said:

the latest inf it is using is called "nv_dispi.inf".

This means it is STILL using the desktop drivers, not the optimus drivers. Comment out all instances of GTX 960 (two lines for each id; one under strings, one that refers to the section).

If the drivers have been modified correctly, it would be using nvami.inf (the file where you added the lines), not nv_dispi.inf.


As it is using nv_dispi.it means it is ignoring the changes you've made in nvami.inf.

Edited by utopian201

Share this post


Link to post
Share on other sites

Now I have a problem I didn't have before ... "(code 43)" which means that something isn't working properly. I'm checking all the cables ...

 

Do you have a clean windows 10 installation or an updgraded one ? I had an upgraded one (from 8.1 obviously) maybe that changes something?

 

Edit: OK, Code 43 Fixed. I'll begin to test again.

I am now under windows 8.1.

 

Edit 2 : Nope. Code 43 is back at it again. only by restarting my PC ... I don't know what is wrong this time.

Edited by Chevrotine669

Share this post


Link to post
Share on other sites

yeah our good old friend Error 43 is famous. it has to do with Driver+ OS conflict.

I suggest you should revert back from the last time it's working & detected.

And if possible try your 960 on other Desktop PC if any or use other pcie card on your egpu, just to make sure your 960 is fine.

Got my both Quadro 4000 and Q6000 bricked with Error 43 and subsys/subvendor showing (Unknown) FFFF on GPUZ.

before it was bricked, i installed Win 8 legacy driver on my Win 10 from NVIDIA site. working flawlessly until i plugged my external monitor to it and my Lenovo W520 shutdown itself and here comes the error 43.

If i'm not mistaken, Optimus was build for Windows 7. And Windows 10 has it's own Hybrid feature.

so make sure after using DDU you disconnect from Internet or disable windows driver autoupdate.

Are you using EXP GDC or what?

Have you tried to switch the PTD to 7s?

Better to Shutdown and power cycle both your laptop & egpu (unplugged power) and wait 5sec to make it's cache cleared before powering up again

Disable all the Power Managements on BIOS make it run at Maximum Performance.

I'm 100% sure all these eGPU will work flawlessly on Win 7. But it's impossible to downgrade my OEM Lenovo W520 legitimately.

good luck ;)

Share this post


Link to post
Share on other sites

yup, I'm using an EXP GDC

PTD (i'm guessing the little switch on the PCIE expansion itself, right?) is already on 7s . I might test it with the other 2 positions.

Share this post


Link to post
Share on other sites
yup, I'm using an EXP GDC

PTD (i'm guessing the little switch on the PCIE expansion itself, right?) is already on 7s . I might test it with the other 2 positions.

Yes correct

Share this post


Link to post
Share on other sites

Sounds like i have a similar problem. Just to know.. Does anything appear on your monitor/TV that is connect to your eGPU ?

Share this post


Link to post
Share on other sites

I have a question.. everything is connected:the eGPU is recognized (in device manager)+Updated, and the eGPU is connected to the TV.

 

When i boot the laptop; the TV is black and it boots only on my laptop screen. However, when i boot and i go into the BIOS; the BIOS appears on BOTH my laptop screen and TV screen. So that means that there is a connection which should work.. I don't understand why i can see the BIOS on both screens but out of the BIOS: the TV screen is black and I can only see my laptop screen.

 

My problem is that the eGPU is recognized BUT when i launch a game: My computer still uses the integrated graphics card EVEN though i have set 'Preferred Graphics Processor to High Performance NVIDIA" in NVIDIA Control Panel and it states that 'My Rig' has a GTX 970 in NVIDIA GeForce Experience. Ive also noticed that when i launch a game; the eGPU Clock goes up to 1000 for 2 seconds and then back down to 135MHz (idle).

 

What is happening?? Please help!!

 

BTW i did start in LEGACY Mode but still no luck.

Untitled.png

Share this post


Link to post
Share on other sites

what laptop did you use?

You should set Integrated Graphic on BIOS Display options and disable OS Optimus detection.

So, it should be only 2 Display Adapters shown in Device Manager: Intel integrated, and Nvidia eGPU.

How about in Boot screen, did it also appears on eGPU/TV?

Share this post


Link to post
Share on other sites

I use Asus ROg G551J. It is not possible to change the BIOS primary display with this comp. I also tried installing the Setup 1.x but it wont let me install it. There is no boot screen on TV. Only can see the BIOS on the TV

Share this post


Link to post
Share on other sites
On 7/21/2016 at 3:06 AM, Chevrotine669 said:

yup, I'm using an EXP GDC

PTD (i'm guessing the little switch on the PCIE expansion itself, right?) is already on 7s . I might test it with the other 2 positions.

 

Did you managed to solved Error 43? Got mine solved. Turns out my gpu BIOS is corrupted. Check out my post here: 

Hope this helps

Share this post


Link to post
Share on other sites

My GPU load stays at 0%.. nothing appears when i connect my TV directly to the eGPU..

and the laptop itself refuses to use the eGPU; instead it uses the iGPU..

GPU load 0%.png

Share this post


Link to post
Share on other sites

Nope, didn't solve Error 43..

I tried with all 3 PTD positions (just in case, you know...) and still same result.

I had a look in my BIOS but .. There seems to be missing some things compared to others. For instance, I can't chose my GPU to "integrated" or "switchable" because i don't even have such a line.

 

Should I update it?

I never updated a BIOS btw.. I'm quite reluctant cause I read you could mess it up and end with a "non starting brick".

Share this post


Link to post
Share on other sites

@Chevrotine669 Can you screenshots DevManager with that Error 43? Double click your eGPU with Error43,  General Tab & Details Tab > Property dropdown menu > Hardware ID.

Or screenshot GPU-Z

Share this post


Link to post
Share on other sites

Here it is:

GPU Z.gif

OK, I'm looking at it right now... and for instance, SLI should be enabled ... but it isn't ..

Edited by Chevrotine669

Share this post


Link to post
Share on other sites

@Chevrotine669 No. SLI only enabled if you have multiple desktop GPU and connected thru SLI bridge. I'm more concerned on the Computing check list.  Normally it should be Checked/Detected by the system.

Share this post


Link to post
Share on other sites

I actually have:

My intel graphics (obviously)

A Nvidia 840M (iGPU)

And my Nvidia 960 (eGPU)

 

So .. 

Anyways. I left everything like it was when I opened it. 

You're telling me it's supposed to be checked? does checking it by myself work?

Wait!

Would be too easy, right?

Share this post


Link to post
Share on other sites

@Chevrotine669 You cannot checked. It shows what's your GPUs capable of and read / detected by the system or Driver.

 

Here's the example of other's MSI GTX960 i've found on the net

GPUZ.gif

 

and here's my eGPU with Quadro 6000:

GPUZ Q6000 Success.PNG

 

Is it possible to check your 960 on a desktop computer? or use other PCIe cards on your eGPU just to make sure both are OK. Since you have mentioned in first post that it worked without Error 43.

 

[EDIT] My mistake, PhysX System Software must be Installed in order to run properly and detected by GPU-Z. The rest feature is by default Installed by the Driver.

Download PhysX System Software: http://www.nvidia.com/object/physx-9.16.0318-driver.html

Download PhysX FluidMark to test: http://www.geeks3d.com/20130308/fluidmark-1-5-1-physx-benchmark-fluid-sph-simulation-opengl-download/

 

I just installed it and it's greatly improves PhysX benchmark. 

 

GPUZ Q6000 PhysX.PNG

Edited by ssamydla
Additional infos

Share this post


Link to post
Share on other sites

I don't know if I can. I have an old desktop computer, but I don't know if it will be able to run it properly. Unless all you want to do is prove that it's not the GPU itself that is damaged. In which case, I could try and mount it on it.

 

Edit: I tried to install PhysX System Software and it tells me that it's already installed. so that's that.

Edited by Chevrotine669

Share this post


Link to post
Share on other sites

I just discovered the following:

The code 43 is still my main issue, but I can get rid of it after RE-installing the proper driver.

But there's a catch. If I restart my laptop, it's here again. Code 43 appears once again...

 

At least I got it to work (even for a short period), which means that it's at least functionnal.

 

And here is the GPU-Z after the re-instal:

GPU Z 2.gif

So that seems to be good news isn't it?

Edited by Chevrotine669

Share this post


Link to post
Share on other sites
7 hours ago, Chevrotine669 said:

I just discovered the following:

The code 43 is still my main issue, but I can get rid of it after RE-installing the proper driver.

But there's a catch. If I restart my laptop, it's here again. Code 43 appears once again...

 

At least I got it to work (even for a short period), which means that it's at least functionnal.

 

And here is the GPU-Z after the re-instal:

GPU Z 2.gif

So that seems to be good news isn't it?

 

 

Theres no problem with driver yes sounds good, but about Code 43 sometimes happen cuz mpci cable unplugged normally in socket just try to plugout and plugin again and see if err gone or wat..

 

my regards, :)

 

 

 

 

 

Share this post


Link to post
Share on other sites

external screen should do the trick. You can find out I went through the same hassle in my XPS 15 implementation guide.

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
On 7/20/2016 at 8:14 AM, utopian201 said:

 

It is necessary to comment out the lines in the dispi file - this disables the non optimus drivers. When you add the lines with a section that refers to NVSupportOptimus = 1, you are telling the installer to use an optimus enabld driver for your card.

 

I have it running on my internal screen on windows 10, so it IS possible to get it working.

@utopian201

 

I'm in a bit of a pickle...

To start off, here's the specs _ Acer Laptop w/ Intel N2840 + GTX 950 w/ EXP BEAST adapter + Windows 10

 

I firstly CAN get an image on an external monitor through my eGPU connection. My device manager will initially have 'Intel HD' and 'Microsoft Basic Adapter' in the Display drop-down. The only way to get it to recognize and say 'GTX 950' is if I install an Nvidia driver.

 

Going off of your format, I got my card's Hardware ID (which is A:1402, B:1402, C:10DE) and put it in place accordingly.

 

So essentially I have the correct lines commented out (;) in my nv_dispi.inf file

... and in my nvami.inf file I've added lines,

NVIDIA_DEV.1402.1402.10DE = "NVIDIA GeForce GTX 950" under the ' NVIDIA_A = "NVIDIA" ' under the 'Strings' section.

and %NVIDIA_DEV.1402.1402.10DE% = Section001, PCI\VEN_10DE&DEV_1402&SUBSYS_140210DE in the  [NVIDIA_Devices.NTamd64.10.0] section. 

*The first Section I had that had NVSupportOptimus = 1 was also Section001... so I used that.

 

I'll delete all current drivers and disable driver signature enforcement and try to apply the modified driver...

Though after initiating the setup.exe, it loads to the point of an error saying something along the lines of 'cannot find hardware to apply this driver to'... or something like that.

I though that was because it was displaying 'Microsoft Basic Adapter'.

I then tried to download an unmodified driver so it'd display the card name 'GTX 950' in the display section of the manager and THEN try to run the modified driver again - choosing the 'delete previous drivers' option _ same result. The modified driver states that it cannot find a GPU to apply it to.

An unmodified driver will find it and execute fine... just not the modified one.

 

What do you think I'm doing wrong.

Please ask any questions you have, I'd have no problem going back over everything that I've set up step-by-step.

 

Any help or insight would be greatly appreciated!

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Wotan
      Hi guys,
      So with the help of svl7, I got my GTX770m successfully working in my MS16f2.
      Now, I'm experiencing a strange problem on two video-games specifically: Company of Heroes and Garry's Mod 13. I do not believe this is a hardware problem, because other games run fine.
      In these games, I am experiencing poor framerates (10-15 fps) because my GPU just isn't doing any work. With EVGA precision X, I monitor GPU load in game only to see that it floats around 5-15%.
      On other games such as World of Tanks, GPU usage floats around 80% and the game runs optimally.
      My CPU and Ram are not bottle-necking my system either, as they are functioning at normal load levels when the game is running.
      I have tried to adjust power settings to maximize performance and even overclock the GPU. It simply is not processing video, as if the game wasn't running at all.
      Does any one have an idea as to what is wrong?
      Thanks,
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.