Jump to content
Chevrotine669

help : eGPU usage 0%

Recommended Posts

Hello everybody !

I'm quite new to all the eGPU stuff so this may be really an easy fix, but still. 

 

Let's start off with my specs:

 

MSI GP 70 2PE LEOPARD

I7 4700 hq 2.4 GHz

8Go of Ram

Nvidia GT 840M already build in

eGPU : GTX 960

eGPU connected via mPCIE

(tell me if there's something missing!)

 

I have a little problem here with my eGPU setup ==> everything works fine (fans spin, can be controlled by MSI afterburner ...) 

But it seems like none of my games uses it .

 

I had MSI Kombustor 3 with it's GPU monitoring running while gaming and realised that the usage of my eGPU was 0% .

 

What I already tried so far:

 

-unnistall all drivers thanks to DDU (Display Driver Unnistaller) and re-instal them.

-I tried to deactivate my GT 840M to see if I could force my laptop to use the GTX 960, but ... it used the intel graphics instead. so, yeah.

-tried to experiment around with the NVidia control pannel to force my laptop to use the eGPU 

 

The funny thing is, that my eGPU is running at 80-90% for ONE applicatio only: total war Attila 's launcher .

Only the launcher, not the game itself.

 

A friend of mine told me right click on a game icon and chose  "which GPU i want to use" . But apparently, I don't have an option to select that.

 

It maybe be a little confused, i'm sorry if it's the case, I'm not really good at it, plus english isn't my mother language..

 

So, if anyone could give me some thing to test out, i'd be very happy.

oh and, of course, if there's some info missing, all you need to do is ask.

 

Thanks!

Matt

Share this post


Link to post
Share on other sites

Install the god damn notebook drivers.

 

Then set preferred gfx to nvidia in the nvidia cp.

Edited by Arbystrider

Share this post


Link to post
Share on other sites

I must be dumber than the average.

I searched for any driver I could get for my laptop (on the official MSI support website) , but no one seems contextual .

What driver am I supposed to look for ?

Share this post


Link to post
Share on other sites

ohhh. GPU drivers ... already did that some time ago

The one I had was a month old, the new one is 1.5 weeks old, so .. yeah. thanks. 

But that didn't solve my problem.

Here, maybe that screen shot will help understand my problem better. This is after I launched a game. 0% usage for my GTX 960. 

And yes, I've put everything I could in the Nvidia Control Panel in order for it to use the 960 but ... here I am.

GPU usage.jpg

edit: WAIT !! I got confused: for some reason it changed my GPU 1 & 2 and I mistook the 960 for my 840M, so my bad, it 's working now. 

I just didn't get any awesome FPS boost and therefore thought that it wasn't working.

 

edit2: Restared my computer, and it's back. the 960 is "GPU 2" and not used anymore... how's that possible ?

GPU usage2.jpg

Edited by Chevrotine669
my bad !

Share this post


Link to post
Share on other sites

No, i'm not . 

I found evidences that it wasn't needed .

if I remember well ... should be that :

If I don't have an external screen, I would ... bottleneck it ? right ? or even more? 

 

Share this post


Link to post
Share on other sites
On 17/06/2016 at 9:21 PM, Chevrotine669 said:

A friend of mine told me right click on a game icon and chose  "which GPU i want to use" . But apparently, I don't have an option to select that.

That is what I meant : I don't have any option to select my GPU via context menu.. and that's most of my problem ...

And disabling the dGPU will make it run my intel graphics ..

Edited by Chevrotine669

Share this post


Link to post
Share on other sites

Have you enabled the option to show "Run on..." in context menu in the nvidia drivers?

 

And does it work with an external monitor? This will help narrow down what is going wrong.

Edited by utopian201

Share this post


Link to post
Share on other sites

I'm going to see if it's enabled or not (might be it). Btw , where do I need to search for that ? CP?

and ... try to find an external monitor .

 

Edit: I had a box called "show execute with GPU option to the contexte menu" (I translated it from my language so it might be called different on your PC..) should be it right? well it was enabled. (I did disable it to re-enable it but didn't change a thing).

Edited by Chevrotine669

Share this post


Link to post
Share on other sites

I'm assuming it shows up in device manager correctly?
And have you tried disabling your 840M?

Share this post


Link to post
Share on other sites

Yup, it's in the device manager . (But It doesn't show up in Dxdiag, is that an useful info?)

 

And as said above, disabling the 840M will make it run on the intel ...

Edited by Chevrotine669

Share this post


Link to post
Share on other sites

No .. But I heard you could mess it up and end with a "non starting brick", so I wanted to keep it as a last resort.

I guess I will have to test it at some point.

Share this post


Link to post
Share on other sites

Do you have a TV you could output to? Having it running on an external monitor at least will let you know that it is all working correctly, just not the internal monitor.

Share this post


Link to post
Share on other sites

ok, I just plugged my eGPU to my TV via HDMI and I could use the TV as an additional screen .

 

Could you tell me what I just tested there? I planned to help a friend do the same as soon as I managed to get my eGPU running, and I'd like to know what I just tested there. The GPU itself? or the connection between the laptop and the eGPU ? or ...?

 

Thanks !

 

Edited by Chevrotine669

Share this post


Link to post
Share on other sites

Was the GPU usage 0% when you were outputting to the TV? To me it is sounding like an optimus issue which I can help with, but it is not exactly straight forward.

Share this post


Link to post
Share on other sites

Ok, the instructions are quite long winded but here goes:

1. Go to Device manager and go to your GTX 960

 

2. On the details tab, go to Hardware IDs. The second line will be something like

PCI\VEN_10DE&DEV_1183&SUBSYS_28451462

And make a note of the bolded numbers. Your ones will be different.

I will name these three numbers like this:

A: 1183

B: 2845

C: 1462

 

3. Use DDU driver uninstaller to remove your nvidia drivers.

 

4. Go to your nvidia driver package. You may need to unzip them.

 

5. Go to the Display.Driver folder and open up nv_dispi.inf

 

6. Search for all lines starting with

%NVIDIA_DEV.(A)

In my case, I searched for all lines starting with

%NVIDIA_DEV.1183

 

In my case (because I am using a 660Ti) there were two lines;

%NVIDIA_DEV.1183%           = Section009, PCI\VEN_10DE&DEV_1183 (line 400 in my file)  

NVIDIA_DEV.1183 = "NVIDIA GeForce GTX 660 Ti" (line 7959 in my file)

 

There may be more or less depending on what version drivers you use and what your card is.

 

Comment both of them out by placing a semi colon at the start like this:

;%NVIDIA_DEV.1183%           = Section009, PCI\VEN_10DE&DEV_1183

;NVIDIA_DEV.1183 = "NVIDIA GeForce GTX 660 Ti"

 

This disables the desktop drivers (which don't support optimus) for the 660Ti. If you tried to now install this driver package, it would say no supported hardware found (because we have disabled the driver for the 660Ti)

 

7. Open up nvami.inf and search for the [Strings] section. On nvidia drivers 368.22, it is on line 9235.

 

8. Place this line in that section underneath "NVIDIA_A = "NVIDIA":

NVIDIA_A = "NVIDIA"

NVIDIA_DEV.(A).(B).(C) = "(your graphics card)"

 

In my one I did this:

NVIDIA_A = "NVIDIA"

NVIDIA_DEV.1183.2845.1462 = "NVIDIA GeForce GTX 660 Ti"

 

8. In the same file, search for [Section and look for one that has the key line
NVSupportOptimus = 1

 

This is a driver that will support optimus. In my one, [Section001] had that line.

 

9. In the same file, search for the [NVIDIA_Devices.NTamd64.10.0] section. On my one it is line 283.

 

10. Place this line underneath that section:

%NVIDIA_DEV.(A).(B).(C)% = Section001, PCI\VEN_10DE&DEV_(A)&SUBSYS_(B)(C)

 

In my one, it looks like

%NVIDIA_DEV.1183.2845.1462% = Section001, PCI\VEN_10DE&DEV_1183&SUBSYS_28451462

 

I used Section001 because in my driver, Section001 supported Optimus. Your Section001 may not, so find a Section00X that does.

 

This tells the installer that, if it finds a 660Ti, use the driver at Section001 which supports optimus.

 

11. With your graphics card plugged in, install the driver. And then you should have it working on the internal screen!

 

Let me know how you get on.

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

Hey! thanks for the awesome guide (very well explained btw!) . 

 

I did everything that is written, but for some reason, when trying to install it, it fails at some point. (says something like "installation program failed")

 

I tried the section001 (point n° 8 on your guide) since it was the first one which had the " NVSupportOptimus = 1 " line.

I also tried the section 013 which is the second time  " NVSupportOptimus = 1 " appears, but still same result.

 

Should I keep trying other sections? (there are still some left which have the line)

 

Thanks again !

Share this post


Link to post
Share on other sites

after you install the driver, go to device manager and then your graphics card. On the events tab, what is the last line when it says "Device Installed"? Does it say nvami.inf or something else?

Share this post


Link to post
Share on other sites

Well that's the problem. the installation isn't complete.

it just fails .

And there is no other error message than " installation program failed " and shows me that he didn't install anything...

Share this post


Link to post
Share on other sites

What happens when you uncomment those lines (ie reenable the lines in nv_dispi.inf)?

That should make it work again (but not the internal screen). If that is the case, I can only assume there is an error in the nvami.inf - it means the installer cannot find a driver for your card.

Maybe paste the lines you've added and commented out as well has your hardware ID?

Share this post


Link to post
Share on other sites

ok, I tested with the uncommented lines and it still failed . I double checked (more than that actually..) the lines I added in the nvami file, just to be sure..

 

(A) 1401

(B) 3201

(C) 1462

 

lines commented out:

 

;%NVIDIA_DEV.1401%           = Section045, PCI\VEN_10DE&DEV_1401   

;NVIDIA_DEV.1401 = "NVIDIA GeForce GTX 960"

 

 

Added lines:

 

NVIDIA_DEV.1401.3201.1462 = "NVIDIA GeForce GTX 960"

%NVIDIA_DEV.1401.3201.1462% = Section001, PCI\VEN_10DE&DEV_1401&SUBSYS_32011462

Section001.jpg

 

Edited by Chevrotine669

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Wotan
      Hi guys,
      So with the help of svl7, I got my GTX770m successfully working in my MS16f2.
      Now, I'm experiencing a strange problem on two video-games specifically: Company of Heroes and Garry's Mod 13. I do not believe this is a hardware problem, because other games run fine.
      In these games, I am experiencing poor framerates (10-15 fps) because my GPU just isn't doing any work. With EVGA precision X, I monitor GPU load in game only to see that it floats around 5-15%.
      On other games such as World of Tanks, GPU usage floats around 80% and the game runs optimally.
      My CPU and Ram are not bottle-necking my system either, as they are functioning at normal load levels when the game is running.
      I have tried to adjust power settings to maximize performance and even overclock the GPU. It simply is not processing video, as if the game wasn't running at all.
      Does any one have an idea as to what is wrong?
      Thanks,
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.