Jump to content
EwinRacing Flash Series Gaming Chairs
dpham

My eGPU isn't doing any work

Recommended Posts

Hi All,

 

I have an Akitio with a GTX 950 inside. Its being powered by the stock power supply that came w/ the Akitio and a PC power supply through the 6pin connector. 

http://imgur.com/a/Oa7hz

 

I've ran the following script successfully without any errors. My system report Graphics/Displays shows the card is being detected. I've set the Graphics Drivers to use "NVIDIA Web Drivers". However when I run heaven benchmark my GPU is not doing any work, the graphics card's fan isn't even spinning. 

https://github.com/goalque/automate-eGPU/blob/master/automate-eGPU.sh

 

The graphics card's fan does spin during bootup but once the computer has booted its sitting idle.

Any tips or suggestions would be appreciated.

 

Regards,

Dat

Share this post


Link to post
Share on other sites

Perhaps the eGPU should go and find a job?

 

Try using an external monitor.

 

Install nvidia notebook drivers.

Share this post


Link to post
Share on other sites

Don't use the Akitio Power supply. Use only one PSU you need to modify the cables from PC PSU and make one on the back of Akitio and one for GPU card. And also I can't see the cable connect to your GPU card HDMI or Displayport? You need External Display to make it works.

Share this post


Link to post
Share on other sites

@errin

I'm plugging the thunderbolt cable from the Akito to my macbook.

@Arbystrider

After plugging in an external monitor to the card i see the performance gain in Heaven Benchmark when it is running on that screen, however when Heaven Benchmark is running on my macbook screen the cpu is doing all the work. I was under the assumption my eGPU would drive all the graphics processing. Is there any way to do that?

 

Forgot to mention i'm not running bootcamp or anything, just OSX 10.11.15. 

Edited by dpham

Share this post


Link to post
Share on other sites

So is there a way to disable the discrete graphics and have the eGPU to do all the work?

Share this post


Link to post
Share on other sites

You should still have to set the NVIDIA GPU as the default GPU within NVIDIA Control Panel.

Share this post


Link to post
Share on other sites

Same question. I have almost the identical setup except I have integrated graphics. It seems the eGPU is used on benchmarks and some gamrs but not for everyday tasks. When I watch videos like HBOGO or do other things in the browser, like browser games the integrated gpu seems to be doing all the work as I hear the fan crank up. Is this to be expected? I thought watching Netflix, YouTube, etc. full screen on my 4k monitor would benefit from the eGPU, but it still seems to struggle. I am using Chrome, should I try another browser? I have the dell 27" 4k monitor hooked up via display port to the card.

Share this post


Link to post
Share on other sites

In the Windows world, the NVIDIA drivers include Optimus, which allows an NVIDIA GPU to render images displayed on a monitor connected to an integrated GPU; this works on a Boot Camp installation on a MBP as well; you have to use a utility to force EFI to enable the integrated GPU for use by Windows to use Optimus, otherwise it will always default to the discrete GPU.  As far as I know, there's no Optimus for OSX, so you're out of luck there.  The graphics switching on discrete GPU-equipped MBPs seems to actually switch the card the monitor is connected to.

Share this post


Link to post
Share on other sites

I'm having the same issue. All works fine, but in Final Cut or Premiere still de CPU and internal graphics is doing all the work, while the eGPU ist chilling... 

Bildschirmfoto 2016-09-30 um 18.35.41.png

Share this post


Link to post
Share on other sites

FYI - I was running into the exact same issue (OSX 10.12 Sierra, mid-2015 MBPro, Akitio eGPU with EVGA GTX 750Ti [w/out 6-pin power]).  I was trying to run the Heaven benchmark on the external monitor and was getting awful performance (12FPS).  Here is how I solved it:

  • Open Control Panel - Power Savings --> Disable Automatic Graphic Switching
  • Disconnect the DVI cable from the eGPU card, wait 1sec, plug back in
  • Re-run Heaven on eGPU at High Settings (2550x1440) - 30FPS!

BTW - You can tell which GPU it is using by looking at the temperature number in Heaven.  The internal GPU runs 50-60degC and the eGPU runs 40deg.

 

Hope this helps someone!

 

 

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.