Jump to content
Sign in to follow this  
fandangos

MSI GT with 570m plus eGPU

Recommended Posts

I own a MSI GT683DXR with 570m dedicated graphics card. 

 

I´ve installed a GTX 750 using EXP GDC Beast and it gets detect by Windows 10, no problem but I want to be able to use my internal monitor with it. 

I can hook external monitors to the graphics card and they work but when running games the 570m is the one used to render graphics.

 

I was wondering if it was possible to use Nvidia Optimus but thats only for intel graphics plus Nvidia Cards. Sicne my notebook uses an i7 second generation I don't have a intel graphics here.

 

Is there a way to make the eGPU output to my notebook monitor and be used in games?

Share this post


Link to post
Share on other sites
15 hours ago, fandangos said:

Sicne my notebook uses an i7 second generation I don't have a intel graphics here.

 

Yes you do.

 

dbd0ef1002.png

 

Only Nvidia notebook drivers have Optimus included, which is required for internal LCD operation.

 

Install them.

 

If you really don't have HDG3k, which should not be the case, then

 

Edited by Arbystrider
  • Thumbs Up 1

Share this post


Link to post
Share on other sites

That's weird, my i7 cpu is described as hd 3000 capable but the original BIOS don't have an option to turn it on.

Since I'm using the unlocked bios I can turn it on and windows can see it.

 

I've tried to install the drivers in regular mode, safe mode, from intel website and from windows update. It always result in crashing or black screen after windows logo.

 

It seems like if my notebook didn't support the iGPU but my cpu does.

 

Even the official site don't have any bios for it, even for old OS like windows 7.

Share this post


Link to post
Share on other sites

Ok, I give up, it's been a few days that I'm tweaking windows to work with my Intel HD Graphics 3000 without any success.

 

That LucidLogix website doesn't seem to exist anymore. 

Is there any other option to try?

Share this post


Link to post
Share on other sites

Yes, some notebooks like yours do not have the igpu wired through. Therefore optimus wont work.

 

Your only option for internal lcd mode is to drag and drop a *windowed* app started on the external lcd to the internal lcd.

 

It's possible to do that without using a physical lcd by way of a VGA or dvi dummy plug on the egpu to provide a fake  external lcd. Then use software like Actual window manager to start the app on the fake external lcd and move it to the internal lcd.

 

Good luck with it.

 

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Thanks Tech Inferno Fan for your input. 

 

Do you have any experience with Actual Window Manager? 

 

I just have to select the game I want and select the fake monitor and it will start there. 

Than, how do I drag it if I can't see the image on the fake monitor?

 

EDIT: Nevermind just found out that it would greatly impact on performance. 

It seems I'm screwed with this notebook, sadly because I like it :( 

Edited by fandangos

Share this post


Link to post
Share on other sites
2 hours ago, Tech Inferno Fan said:

Yes, some notebooks like yours do not have the igpu wired through. Therefore optimus wont work.

 

This just seems like a very douchey act on the part of the manufacturer. I see no reason that MSI would have to not have the iGP wired to the internal LCD.

 

Well, at least I learned something today.

 

2 hours ago, fandangos said:

EDIT: Nevermind just found out that it would greatly impact on performance. 

It seems I'm screwed with this notebook, sadly because I like it

 

Well, there's always the option of external monitor.

 

That said, I found an interesting link: https://downloadcenter.intel.com/download/19993/Lucid-Virtu-

 

Try it out if you want, and please report back with results.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

I did a few tries marking everything I changed from BIOS. After each test I did a full bios reset, clearing CMOS and trying again.

This is the graphics menu from the unlocked BIOS from my notebook:

 

http://i.imgur.com/tj7ptLB.jpg

 

The original BIOS from MSI, even the latest, show no option to enabled iGPU.

All test were done using WINDOWS 10 - fresh install. 

 

I have not tweaked any other settings since I'm not familiar with:

Graphics Turbo IMON current:

GTT Size

Apperture size

DVMT Pre-allocated

DVMT TOTAL GFX Memory

I have no idea if any of those would stop windows crashing when using iGPU.

 

From the tests:

First Display PEG [DEFAULT]

IGFX DISABLED [DEFAULT]

Low Power Mode OFF [DEFAULT]

BOOT OK FROM BIOS - BOOT OK FROM WINDOWS - NO IGPU IN DEVICE MANAGER

 

First Display PEG

IGFX Enabled

Low Power Mode Off

NO BOOT FROM BIOS

 

First Display PEG

IGFX Enabled

Low Power Mode On

NO BOOT FROM BIOS

 

First Display PCI

IGFX Enabled

Low Power Mode ON

NO BOOT FROM BIOS

 

First Display PCI

IGFX Enabled

Low Power Mode OFF

NO BOOT FROM BIOS

 

First Display IGFX

IGFX Enabled

Low Power Mode OFF

NO BOOT FROM BIOS

 

First Display IGFX

IGFX Enabled

Low Power Mode ON

BOOT OK FROM BIOS - WINDOWS CRASH DURING BOOT IF DRIVERS ARE INSTALLED.

IT WOULD ALSO CRASH WINDOWS DURING DRIVER INSTALLATION. 

 

@Arbystrider

I wasn't able to try Intel's Lucid Virtu just yet because I took my eGPU setup apart, but as far as I can see it's meant for selected motherboards only. 

Also I don't think the problem is related to wiring the LCD internal display but a few lanes from the CPU itself to make iGPU to work. 

 

@utopian201

I can't boot into windows with both, dGPU and iGPU so I can't switch. 

 

 

 

 

Share this post


Link to post
Share on other sites

I think you are out of luck, your notebook hardware has not enabled optimus. My understanding is that optimus is required to use the internal screen.

 

http://www.anandtech.com/show/4746/geforce-gtx-570m-available-in-msis-gt683dxr-and-gt780dxr

 

"Like all the 500M GPUs (and the 400M parts before them), the 570M supports NVIDIA's Optimus graphics switching technology, though it's up to the notebook manufacturers to actually use it or not. Unfortunately, it appears MSI has decided to not support Optimus with their G-series updates, so we'll have to wait for a future model to get that feature."

Edited by utopian201

Share this post


Link to post
Share on other sites
10 hours ago, utopian201 said:
I think you are out of luck, your notebook hardware has not enabled optimus. My understanding is that optimus is required to use the internal screen.

Nope. I have an intel igpu and amd dgpu and after adding an nvidia egpu and disabling the amd dgpu I can use the internal screen. I could only use internal after getting setup 1.3 and disabling my amd dgpu. Not really useful to me though since I already have an external monitor

 

P.S. But you need the intel card to work for optimus to run and you said it doesn't if I'm not mistaken. From what I understand Optimus term used here on the forums means running the egpu on internal so it's not really "optimus" the way nvidia means it.

Edited by templeka

Share this post


Link to post
Share on other sites
9 hours ago, templeka said:

Nope. I have an intel igpu and amd dgpu and after adding an nvidia egpu and disabling the amd dgpu I can use the internal screen. I could only use internal after getting setup 1.3 and disabling my amd dgpu. Not really useful to me though since I already have an external monitor

 

P.S. But you need the intel card to work for optimus to run and you said it doesn't if I'm not mistaken. From what I understand Optimus term used here on the forums means running the egpu on internal so it's not really "optimus" the way nvidia means it.

 

Thats right, the intel chip is used to drive the internal screen. Wouldn't your setup be using optimus if you are using an nvidia egpu to drive your internal screen?

In any case, the OP cannot boot with integrated graphics which is required to use the notebook screen.

Edited by utopian201

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.